This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 831233 - dhclient-script does not recreate resolv.conf entries on changing runlevel
dhclient-script does not recreate resolv.conf entries on changing runlevel
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: dhcp (Show other bugs)
16
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Jiri Popelka
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-12 10:19 EDT by stef
Modified: 2012-06-12 10:52 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-12 10:52:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description stef 2012-06-12 10:19:10 EDT
Description of problem:

To avoid non-root or non-sudoer users to modify the network parameters or disable the eth0 interface I configured the following in 

/etc/sysconfig/network-scripts/ifcfg-eth0
NM_CONTROLLED="no"
PEERDNS="yes"

then I issued the command
chkconfig network on

doing this I have the eth0 interface being configured by dhcp and the DNS informations written in /etc/resolv.conf at boot time.
So far so good, except when I issue a command to change runlevel (ex: init 3 or init 5), then the IP address is good but no more DNS information in /etc/resolv.conf.

I have to reissue manualy a /etc/init.d/network restart 

A chkconfig gives me the following (in french) :
network        	0:arrêt	1:arrêt	2:marche 3:marche 4:marche 5:marche 6:arrêt

Version-Release number of selected component (if applicable):

Linux Fedora Core 16

How reproducible:

Always

Steps to Reproduce:
1.modify network config as explained above
2.change runlevel
3.
  
Actual results:

DNS information is lost on each runlevel change

Expected results:

DNS information does not change

Additional info:
Comment 1 Jiri Popelka 2012-06-12 10:33:25 EDT
Could be a similar problem as bug #824053.

I did some improvements in dhclient-script in Fedora-17 that could solve this problem.
Could you try to copy the dhclient-script from F-17 [1] to /sbin/dhclient-script (make it executable) and let me know if the problem remains.

[1] http://pkgs.fedoraproject.org/gitweb/?p=dhcp.git;a=blob_plain;f=dhclient-script;hb=HEAD
Comment 2 stef 2012-06-12 10:52:34 EDT
even better than this, it seems that problem was fixed by a previous update, my FC16 test box was not up-to-date, I made a new test after issuing a 'yum-y upgrade' and a reboot and the problem is gone.

Sorry about this, it appears it was already fixed

Note You need to log in before you can comment on or make changes to this bug.