Bug 831294 - [abrt] gpodder-2.20.1-1.fc17: gui.py:252:new:AttributeError: 'gPodder' object has no attribute 'toolbar'
[abrt] gpodder-2.20.1-1.fc17: gui.py:252:new:AttributeError: 'gPodder' object...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: gpodder (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jef Spaleta
Fedora Extras Quality Assurance
abrt_hash:aa17b88bcb14e09caa3bd4d711c...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-12 13:30 EDT by Terry Wallwork
Modified: 2013-07-31 21:55 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-31 21:55:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Terry Wallwork 2012-06-12 13:30:10 EDT
libreport version: 2.0.10
abrt_version:   2.0.10
cmdline:        /usr/bin/python /bin/gpodder
comment:        tried to start gpodder, and get toolbar property missing error.
event_log:      2012-06-12-19:20:13> Smolt profile successfully saved
executable:     /bin/gpodder
kernel:         3.4.0-1.fc17.x86_64
time:           Tue 12 Jun 2012 03:46:35 PM BST
uid:            1000
username:       terry

backtrace:
:gui.py:252:new:AttributeError: 'gPodder' object has no attribute 'toolbar'
:
:Traceback (most recent call last):
:  File "/bin/gpodder", line 218, in <module>
:    gui.main(options)
:  File "/usr/lib/python2.7/site-packages/gpodder/gui.py", line 4253, in main
:    gp = gPodder(bus_name, config)
:  File "/usr/lib/python2.7/site-packages/gpodder/gui.py", line 179, in __init__
:    BuilderWidget.__init__(self, None)
:  File "/usr/lib/python2.7/site-packages/gpodder/gtkui/interface/common.py", line 56, in __init__
:    GtkBuilderWidget.__init__(self, gpodder.ui_folders, gpodder.textdomain, **kwargs)
:  File "/usr/lib/python2.7/site-packages/gpodder/gtkui/base.py", line 70, in __init__
:    self.new()
:  File "/usr/lib/python2.7/site-packages/gpodder/gui.py", line 252, in new
:    self.toolbar.set_property('visible', self.config.show_toolbar)
:AttributeError: 'gPodder' object has no attribute 'toolbar'
:
:Local variables in innermost frame:
:self: <gpodder.gui.gPodder at /gui at 0x2e78590>

smolt_data:
:
:
:General
:=================================
:UUID: f3fd51a4-23d3-40dd-8959-52ac81727411
:OS: Fedora release 17 (Beefy Miracle)
:Default run level: Unknown
:Language: en_US.UTF-8
:Platform: x86_64
:BogoMIPS: 4190.48
:CPU Vendor: GenuineIntel
:CPU Model: Intel(R) Core(TM) i3-2310M CPU @ 2.10GHz
:CPU Stepping: 7
:CPU Family: 6
:CPU Model Num: 42
:Number of CPUs: 4
:CPU Speed: 2100
:System Memory: 5882
:System Swap: 0
:Vendor: TOSHIBA
:System: SATELLITE C670-14P PSC3UE-00Y009EN
:Form factor: Laptop
:Kernel: 3.4.0-1.fc17.x86_64
:SELinux Enabled: 1
:SELinux Policy: targeted
:SELinux Enforce: Permissive
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(32902:7241:4473:64630) pci, None, PCI/ISA, HM65 Express Chipset Family LPC Controller
:(32902:278:4473:64624) pci, i915, VIDEO, 2nd Generation Core Processor Family Integrated Graphics Controller
:(32902:7171:4473:64630) pci, ahci, STORAGE, 6 Series/C200 Series Chipset Family 6 port SATA AHCI Controller
:(32902:7184:4473:64630) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 1
:(32902:7186:4473:64630) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 2
:(32902:7196:4473:64630) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 7
:(32902:7200:4473:64628) pci, snd_hda_intel, MULTIMEDIA, 6 Series/C200 Series Chipset Family High Definition Audio Controller
:(32902:7202:4473:64630) pci, i801_smbus, SERIAL, 6 Series/C200 Series Chipset Family SMBus Controller
:(4332:33078:4473:64614) pci, r8169, ETHERNET, RTL8101E/RTL8102E PCI Express Fast Ethernet controller
:(4332:33142:4332:33154) pci, rtl8192ce, NETWORK, RTL8188CE 802.11b/g/n WiFi Adapter
:(32902:7213:4473:64630) pci, ehci_hcd, USB, 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2
:(32902:7206:4473:64630) pci, ehci_hcd, USB, 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1
:(32902:260:4473:64624) pci, agpgart-intel, HOST/PCI, 2nd Generation Core Processor Family DRAM Controller
:(32902:7226:4473:64630) pci, None, SIMPLE, 6 Series/C200 Series Chipset Family MEI Controller #1
:(32902:7194:4473:64630) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 6
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/sda3 / ext4 4096 4096 62659641 55311909 54684815 15687680 15387845 15387845
:
Comment 1 Vinzenz Vietzke 2012-07-05 11:53:16 EDT
Directly after start either on command line or via graphical menu.

Package: gpodder-2.20.1-1.fc17
OS Release: Fedora release 17 (Beefy Miracle)
Comment 2 Jefferson 2012-08-24 17:45:22 EDT
Attempted to open gPodder from application toolbar, didn't work.
Program only opens from terminal using command: /usr/bin/gpodder


Package: gpodder-2.20.1-1.fc17
OS Release: Fedora release 17 (Beefy Miracle)
Comment 3 Ville-Pekka Vainio 2012-08-25 03:59:56 EDT
Which desktop environments are you using?
Comment 4 Kerry 2012-08-31 02:14:19 EDT
Tried starting from console typing 'gpodder' (using KDE desktop) and the application crashed.

Tried again using full path /usr/bin/gpodder and the application started correctly.

It appears that I have scripts both at /bin/gpodder and /usr/bin/gpodder.

$ ls -l /bin/gpodder /usr/bin/gpodder
-rwxr-xr-x. 1 root root 8429 Feb 27  2012 /bin/gpodder
-rwxr-xr-x. 1 root root 8429 Feb 27  2012 /usr/bin/gpodder


Package: gpodder-2.20.1-1.fc17
OS Release: Fedora release 17 (Beefy Miracle)
Comment 5 Ville-Pekka Vainio 2012-08-31 05:37:34 EDT
Here's the gPodder upstream bug: https://bugs.gpodder.org/show_bug.cgi?id=1015

It seems this is happening on Windows, OS X and Linux.

Kerry: That's not a problem, /bin is symlinked to /usr/bin so these files are both the same.
Comment 6 Fedora End Of Life 2013-07-03 19:19:48 EDT
This message is a reminder that Fedora 17 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 17. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '17'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 17's end of life.

Bug Reporter:  Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 17 is end of life. If you 
would still like  to see this bug fixed and are able to reproduce it 
against a later version  of Fedora, you are encouraged  change the 
'version' to a later Fedora version prior to Fedora 17's end of life.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 7 Fedora End Of Life 2013-07-31 21:55:50 EDT
Fedora 17 changed to end-of-life (EOL) status on 2013-07-30. Fedora 17 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.