Bug 831300 - Error syncing a centos repo
Error syncing a centos repo
Status: CLOSED NOTABUG
Product: Pulp
Classification: Community
Component: user-experience (Show other bugs)
2.0.6
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: John Matthews
Preethi Thomas
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-12 13:46 EDT by Preethi Thomas
Modified: 2013-09-09 12:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-13 14:21:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Preethi Thomas 2012-06-12 13:46:19 EDT
Description of problem:

Getting the following error on syncing a centos repo

Version-Release number of selected component (if applicable):

[root@preethi-el6-pulp ~]# rpm -q pulp
pulp-0.0.295-1.el6.noarch

How reproducible:


Steps to Reproduce:
1. create a centos repo  wth the feed  http://www.gtlib.gatech.edu/pub/centos/6.2/os/x86_64/

2. Sync the repo
3.
  
Actual results:

Error on sync
Expected results:
Sync complete

Additional info:

[root@preethi-el6-pulp ~]# pulp-v2-admin -u admin -p admin repo sync run --repo-id centos
+----------------------------------------------------------------------+
                   Synchronizing Repository [centos]
+----------------------------------------------------------------------+

This command may be exited by pressing ctrl+c without affecting the actual
operation on the server.

Downloading metadata...
[\]
... completed

Downloading repository content...
[==================================================] 100%
RPMs:       0/0 items
Delta RPMs: 0/0 items
Tree Files: 1/1 items
Files:      0/0 items
... completed

Individual package errors encountered during sync:

Package: CentOS-6.2-x86_64-netinstall.iso
Error:   (28, 'Timeout was
reached')
Traceback:
Traceback (most recent call last):
  File
"/usr/lib/python2.6/site-packages/grinder/ParallelFetch.py", line 310, in run
  
result = self.fetcher.fetchItem(itemInfo)
  File
"/usr/lib/python2.6/site-packages/grinder/activeobject.py", line 82, in
__call__
    return self.object(self, *args, **kwargs)
  File
"/usr/lib/python2.6/site-packages/grinder/activeobject.py", line 269, in
__call__
    return self.__call(method, args, kwargs)
  File
"/usr/lib/python2.6/site-packages/grinder/activeobject.py", line 245, in __call

return self.__rmi(method.name, args, kwargs)
  File
"/usr/lib/python2.6/site-packages/grinder/activeobject.py", line 137, in __rmi
 
raise ex
error: (28, 'Timeout was reached')


Importing errata...
[\]
... completed

Error during repository synchronization

[u'PulpExecutionException: Importer indicated a failed response\n']
Comment 1 Preethi Thomas 2012-06-13 14:21:34 EDT
I can't reproduce this with a new feed.

[root@preethi-el6-pulp ~]# pulp-v2-admin -u admin -p admin repo create --repo-id centos --feed http://mirror.centos.org/centos/6.2/os/x86_64/
Successfully created repository [centos]

[root@preethi-el6-pulp ~]# 
[root@preethi-el6-pulp ~]# 
[root@preethi-el6-pulp ~]# 
[root@preethi-el6-pulp ~]# pulp-v2-admin -u admin -p admin repo sync run --repo-id centos
+----------------------------------------------------------------------+
                   Synchronizing Repository [centos]
+----------------------------------------------------------------------+

This command may be exited by pressing ctrl+c without affecting the actual
operation on the server.

Downloading metadata...
[-]
... completed

Downloading repository content...
[==================================================] 100%
RPMs:       6294/6294 items
Delta RPMs: 0/0 items
Tree Files: 4/4 items
Files:      0/0 items
... completed

Importing errata...
[|]
... completed

Publishing packages...
[==================================================] 100%
Packages: 6294/6294 items
... completed

Publishing distributions...
[==================================================] 100%
Distributions: 4/4 items
... completed

Generating metadata
[\]
... completed

Publishing repository over HTTP
[-]
... skipped

Publishing repository over HTTPS
[-]
... completed

Successfully synchronized repository

Note You need to log in before you can comment on or make changes to this bug.