Bug 831321 - [abrt] kernel: [1124666.050329] WARNING: at lib/list_debug.c:53 __list_del_entry+0xa1/0xd0()
[abrt] kernel: [1124666.050329] WARNING: at lib/list_debug.c:53 __list_del_en...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
abrt_hash:41572bddec8ea8650a1258d083b...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-12 14:56 EDT by Bas Hulsken
Modified: 2016-06-06 01:10 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-11 08:33:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bas Hulsken 2012-06-12 14:56:03 EDT
libreport version: 2.0.8
abrt_version:   2.0.7
cmdline:        BOOT_IMAGE=/vmlinuz-3.3.7-1.fc16.x86_64 root=/dev/vg_steady/lv_root ro nomodeset rd.md=0 rd.dm=0 KEYTABLE=us SYSFONT=latarcyrheb-sun16 rd.lvm.lv=vg_steady/lv_root rd.luks=0 rd.lvm.lv=vg_steady/lv_swap LANG=en_US.UTF-8
comment:        no idea, seems not correlated to any action
event_log:      2012-06-12-20:42:19> Smolt profile successfully saved
kernel:         3.3.7-1.fc16.x86_64
reason:         [1124666.050329] WARNING: at lib/list_debug.c:53 __list_del_entry+0xa1/0xd0()
time:           Mon 11 Jun 2012 09:31:55 PM CEST

backtrace:
:[1124666.050329] WARNING: at lib/list_debug.c:53 __list_del_entry+0xa1/0xd0()
:[1124666.050380] Hardware name: Z68P-DS3
:[1124666.050420] list_del corruption. prev->next should be ffff8801cec935f0, but was ffff8829cec935f0
:[1124666.050482] Modules linked in: tcp_lp usb_storage rmd160 crypto_null camellia lzo cast6 cast5 deflate zlib_deflate cts gcm ccm serpent_sse2_x86_64 serpent_generic blowfish_generic blowfish_x86_64 blowfish_common twofish_generic twofish_x86_64_3way lrw xts gf128mul twofish_x86_64 twofish_common xcbc sha256_generic sha512_generic des_generic ah6 ah4 esp6 esp4 xfrm4_mode_beet xfrm4_tunnel tunnel4 xfrm4_mode_tunnel xfrm4_mode_transport xfrm6_mode_transport xfrm6_mode_ro xfrm6_mode_beet xfrm6_mode_tunnel ipcomp ipcomp6 xfrm_ipcomp xfrm6_tunnel tunnel6 af_key tun xt_state xt_multiport ipt_MASQUERADE ipt_REDIRECT iptable_nat nf_nat nf_conntrack_ipv4 nf_conntrack nf_defrag_ipv4 xt_DSCP xt_mark coretemp iptable_mangle tea5767 arc4 tuner_simple tuner_types wm8775 ath9k snd_hda_codec_hdmi tda9887 snd_hda_codec_realtek tda8290 tuner cx25840 mac80211 ath9k_common ath9k_hw raid456 ivtv nfsd lockd cx2341x v4l2_common videodev snd_hda_intel snd_hda_codec snd_hwdep nfs_acl snd_seq e1000e media
:tveeprom ppdev parport_pc r8169 async_raid6_recov async_pq parport shpchp mii i2c_i801 ati_remote2 snd_seq_device auth_rpcgss ath iTCO_wdt cfg80211 usblp iTCO_vendor_support uinput sunrpc raid6_pq async_xor xor snd_pcm snd_timer snd soundcore snd_page_alloc rfkill async_memcpy microcode async_tx i915 drm_kms_helper drm i2c_algo_bit i2c_core video [last unloaded: scsi_wait_scan]
:[1124666.051629] Pid: 54, comm: kswapd0 Tainted: G        W    3.3.7-1.fc16.x86_64 #1
:[1124666.051688] Call Trace:
:[1124666.051717]  [<ffffffff81057adf>] warn_slowpath_common+0x7f/0xc0
:[1124666.051751]  [<ffffffff81057bd6>] warn_slowpath_fmt+0x46/0x50
:[1124666.051785]  [<ffffffff812d47d1>] __list_del_entry+0xa1/0xd0
:[1124666.051819]  [<ffffffff811963a0>] dentry_iput+0x40/0xf0
:[1124666.051852]  [<ffffffff8119796e>] shrink_dentry_list+0x21e/0x260
:[1124666.051887]  [<ffffffff811985d4>] prune_dcache_sb+0x124/0x150
:[1124666.051922]  [<ffffffff81184740>] prune_super+0x130/0x1a0
:[1124666.051956]  [<ffffffff81132964>] shrink_slab+0x154/0x310
:[1124666.051989]  [<ffffffff811781b5>] ? mem_cgroup_iter+0xe5/0x230
:[1124666.052055]  [<ffffffff8113645a>] balance_pgdat+0x52a/0x6f0
:[1124666.052089]  [<ffffffff81136787>] kswapd+0x167/0x3e0
:[1124666.052123]  [<ffffffff8107a7f0>] ? remove_wait_queue+0x50/0x50
:[1124666.052157]  [<ffffffff81136620>] ? balance_pgdat+0x6f0/0x6f0
:[1124666.052190]  [<ffffffff81079da3>] kthread+0x93/0xa0
:[1124666.052223]  [<ffffffff815fd8e4>] kernel_thread_helper+0x4/0x10
:[1124666.052257]  [<ffffffff81079d10>] ? kthread_freezable_should_stop+0x70/0x70
:[1124666.052293]  [<ffffffff815fd8e0>] ? gs_change+0x13/0x13

smolt_data:
:
:
:General
:=================================
:UUID: b61135f6-b855-4161-b800-860a7f145beb
:OS: Fedora release 16 (Verne)
:Default run level: Unknown
:Language: en_US.UTF-8
:Platform: x86_64
:BogoMIPS: 6218.20
:CPU Vendor: GenuineIntel
:CPU Model: Intel(R) Core(TM) i5-2400 CPU @ 3.10GHz
:CPU Stepping: 7
:CPU Family: 6
:CPU Model Num: 42
:Number of CPUs: 4
:CPU Speed: 3301
:System Memory: 15968
:System Swap: 18015
:Vendor: Gigabyte Technology Co., Ltd.
:System: Z68P-DS3 
:Form factor: Desktop
:Kernel: 3.3.7-1.fc16.x86_64
:SELinux Enabled: 1
:SELinux Policy: targeted
:SELinux Enforce: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Terra.1024.768
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(32902:256:0:0) pci, agpgart-intel, HOST/PCI, 2nd Generation Core Processor Family DRAM Controller
:(4739:34962:5208:20480) pci, None, PCI/PCI, N/A
:(17476:22:112:59399) pci, ivtv, MULTIMEDIA_VIDEO, WinTV PVR 500 (1st unit)
:(32902:7168:5208:45058) pci, ata_piix, STORAGE, 6 Series/C200 Series Chipset Family 4 port SATA IDE Controller
:(32902:7236:5208:20481) pci, None, PCI/ISA, Z68 Express Chipset Family LPC Controller
:(17476:22:112:59415) pci, ivtv, MULTIMEDIA_VIDEO, WinTV PVR 500 (2nd unit)
:(32902:7176:5208:45058) pci, ata_piix, STORAGE, 6 Series/C200 Series Chipset Family 2 port SATA IDE Controller
:(32902:7188:5208:20481) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 3
:(32902:4307:32902:40991) pci, e1000e, ETHERNET, Gigabit CT Desktop Adapter
:(32902:7213:5208:20486) pci, ehci_hcd, USB, 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2
:(32902:7206:5208:20486) pci, ehci_hcd, USB, 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1
:(32902:7226:5208:7226) pci, None, SIMPLE, 6 Series/C200 Series Chipset Family MEI Controller #1
:(4332:33128:5208:57344) pci, r8169, ETHERNET, GA-EP45-DS5 Motherboard
:(32902:258:5208:53248) pci, None, VIDEO, 2nd Generation Core Processor Family Integrated Graphics Controller
:(32902:9294:5208:20481) pci, None, PCI/PCI, 82801 PCI Bridge
:(32902:7184:5208:20481) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 1
:(32902:7186:5208:20481) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 2
:(32902:7200:5208:40962) pci, snd_hda_intel, MULTIMEDIA, 6 Series/C200 Series Chipset Family High Definition Audio Controller
:(5772:36:4486:14960) pci, ath9k, NETWORK, AR5008 Wireless Network Adapter
:(17476:22:112:34817) pci, ivtv, MULTIMEDIA_VIDEO, WinTV PVR 150
:(32902:7202:5208:20481) pci, i801_smbus, SERIAL, 6 Series/C200 Series Chipset Family SMBus Controller
:(13192:33:0:0) pci, None, PCI/PCI, HB6 Universal PCI-PCI bridge (non-transparent mode)
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/mapper/vg_steady-lv_root / ext4 4096 4096 55823999 44408392 42016627 14139392 13764480 13764480
:/dev/sdf2 /boot ext4 1024 1024 508745 408587 382987 128016 127743 127743
:/dev/sde1 WITHHELD ext4 4096 4096 240369457 16544162 4334662 122109952 122105371 122105371
:/dev/md127 WITHHELD ext4 4096 4096 1096249534 335355639 280491698 274325504 274004415 274004415
:/dev/md127 /home ext4 4096 4096 1096249534 335355639 280491698 274325504 274004415 274004415
:/dev/mapper/vg_steady-lv_root WITHHELD ext4 4096 4096 55823999 44408392 42016627 14139392 13764480 13764480
:/dev/mapper/vg_steady-lv_root WITHHELD ext4 4096 4096 55823999 44408392 42016627 14139392 13764480 13764480
:/dev/mapper/vg_steady-lv_root WITHHELD ext4 4096 4096 55823999 44408392 42016627 14139392 13764480 13764480
:/dev/mapper/vg_steady-lv_root WITHHELD ext4 4096 4096 55823999 44408392 42016627 14139392 13764480 13764480
:/dev/mapper/vg_steady-lv_root WITHHELD ext4 4096 4096 55823999 44408392 42016627 14139392 13764480 13764480
:
Comment 1 Dave Jones 2012-07-10 17:56:23 EDT
have you seen this again on 3.4 ?
Comment 2 Bas Hulsken 2012-07-11 03:37:12 EDT
(In reply to comment #1)
> have you seen this again on 3.4 ?

Nope, I haven't. This bug should be invalidated, the report is unreliable. I'm quite certain it was caused by a faulty memory module. I've taken out the defective module (with the help of memtest86), and haven't had any problems for the last two days on 3.4. Even when simulating heavy I/O load, which would trigger the bug previously. Haven't tested 3.3 again though.

apologies for the noise
Comment 3 Josh Boyer 2012-07-11 08:33:22 EDT
Thanks for letting us know.
Comment 4 madge gafford 2016-06-06 01:10:28 EDT
Timely suggestions - BTW , if your business is searching for a a form , my friend encountered a sample version here "http://pdf.ac/1E6KTl"

Note You need to log in before you can comment on or make changes to this bug.