Bug 831334 - doxygen-1.4.7-2 can't be rebuild in mock
doxygen-1.4.7-2 can't be rebuild in mock
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: doxygen (Show other bugs)
5.8
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Ngo Than
BaseOS QE - Apps
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-12 15:34 EDT by Levente Farkas
Modified: 2012-06-14 09:00 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-14 09:00:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
build.log (54.45 KB, text/x-log)
2012-06-13 07:50 EDT, Levente Farkas
no flags Details
root.log (37.80 KB, text/x-log)
2012-06-13 07:50 EDT, Levente Farkas
no flags Details

  None (edit)
Description Levente Farkas 2012-06-12 15:34:28 EDT
g++ -c -pipe -Wall -W -fno-exceptions -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m32 -march=i386 -mtune=generic -fasynchronous-unwind-tabl
es -DNO_DEBUG -I../../src -I/usr/lib/qt-3.3/include -o obj/moc_doxywizard.o moc/moc_doxywizard.cpp                                                                                                  
<stdout>: In function 'void configYY_init_buffer(yy_buffer_state*, FILE*)':                                                                                                                         
<stdout>:2131: error: 'isatty' was not declared in this scope                                                                                                                                       
gmake[2]: *** [obj/config.o] Error 1                                                                                                                                                                
gmake[2]: *** Waiting for unfinished jobs....                                                                                                                                                       
input.h:7: warning: 'class IInput' has virtual functions but non-virtual destructor                                                                                                                 
gmake[2]: Leaving directory `/builddir/build/BUILD/doxygen-1.4.7/addon/doxywizard'                                                                                                                  
gmake[1]: *** [all] Error 2                                                                                                                                                                         
gmake[1]: Leaving directory `/builddir/build/BUILD/doxygen-1.4.7/addon/doxywizard'                                                                                                                  
make: *** [all] Error 2
Comment 1 Ngo Than 2012-06-13 05:46:08 EDT
strange, i don't see this issue in our build system. it looks like you have new gcc version which requires #include <unistd.h>.

Could you please attach your build.log and root.log?

thanks
Comment 2 Levente Farkas 2012-06-13 07:49:37 EDT
it's a fully updated 5.8. ie with gcc-4.1.2-52.el5_8.1.
do you build on base 5.8 or updated 5.8?
Comment 3 Levente Farkas 2012-06-13 07:50:07 EDT
Created attachment 591454 [details]
build.log
Comment 4 Levente Farkas 2012-06-13 07:50:28 EDT
Created attachment 591455 [details]
root.log
Comment 5 Ngo Than 2012-06-13 11:56:46 EDT
I rebuilt doxygen with the rhel-5.8 (with all latest updates) without any problem.
Your root.log file tell me that you are using flex from media repository,
it's not the version shipped in rhel!

---
Package                 Arch      Version                   Repository   Size
flex                    i386      2.5.35-7.el5              media        308 k
--

I think it's the cause of this issue. Could you please use the flex version in rhel and try to rebuild doxygen again?

thanks
Comment 6 Levente Farkas 2012-06-13 13:20:16 EDT
sorry. you've got right:-(
anyway it'd be useful to be able to build with newer flex too.
Comment 7 Ngo Than 2012-06-14 09:00:57 EDT
The bug is caused in flex which generates config.cpp during the compiler process.
i recommend to not use new flex

Note You need to log in before you can comment on or make changes to this bug.