Bug 83134 - Second NIC, eth1, does not recieve DHCP address
Second NIC, eth1, does not recieve DHCP address
Product: Red Hat Linux
Classification: Retired
Component: dhcp (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Depends On:
  Show dependency treegraph
Reported: 2003-01-30 11:49 EST by Paul Witting
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2003-03-10 16:41:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Paul Witting 2003-01-30 11:49:35 EST
Description of problem:
Second ethernet interface does not pick up dhcp address when it is brought up. 
Manually requesting on via dhclient eth1 does work. See exchange below:

[root@admin18 network-scripts]# ifup eth1
[root@admin18 network-scripts]# ifconfig eth1
eth1      Link encap:Ethernet  HWaddr 00:90:27:6A:DB:EF  
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:100 
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
          Interrupt:21 Base address:0xe000 

[root@admin18 network-scripts]# dhclient eth1
Internet Software Consortium DHCP Client V3.0pl1
Copyright 1995-2001 Internet Software Consortium.
All rights reserved.
For info, please visit http://www.isc.org/products/DHCP

Listening on LPF/eth1/00:90:27:6a:db:ef
Sending on   LPF/eth1/00:90:27:6a:db:ef
Sending on   Socket/fallback
DHCPDISCOVER on eth1 to port 67 interval 6
DHCPREQUEST on eth1 to port 67
bound to -- renewal in 138799 seconds.
[root@admin18 network-scripts]# ifconfig eth1
eth1      Link encap:Ethernet  HWaddr 00:90:27:6A:DB:EF  
          inet addr:  Bcast:  Mask:
          RX packets:6 errors:0 dropped:0 overruns:0 frame:0
          TX packets:5 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:100 
          RX bytes:926 (926.0 b)  TX bytes:830 (830.0 b)
          Interrupt:21 Base address:0xe000 

eth0 works fine, and the interfaces are configured identically, though one is a 
3com card and the other is an intel. This behavior is repeatable on several 
different machines (The NICs are on a primary net and a dedicated NFS net, so 
there are many systems with this config, we wish to migrate them to DHCP from 
the current static IP's)

[root@admin18 network-scripts]# cat ifcfg-eth0
[root@admin18 network-scripts]# cat ifcfg-eth1

Version-Release number of selected component (if applicable):

How reproducible:
Every time

Steps to Reproduce:
1.Kickstart a dual NIC system
2.set second NIC to ONBOOT=yes and BOOTPROTO=dhcp
3.Stop & Start network service, or simple ifup eth1
Actual results:
eth1 does not recieve IP address, but eth0 does

Expected results:
Both interfaces should get addresses

Additional info:
running dhclient eth1 gets the correct IP with no problems.
Comment 1 Paul Witting 2003-02-01 22:48:29 EST
Modified the ks.cfg script to specify both adapters explicitly:

network --interface eth0 --bootproto dhcp
network --interface eth1 --bootproto dhcp 

Syntax may be off, but this is the crux of it. Both interfaces come right up 
now, curiously the network-scripts are identical from the config that works to 
the config that doesn't, implying that something else (beyond ifcfg-eth1) needs 
to be modified to let dhcp on the second interface work... 
Comment 2 Daniel Walsh 2003-03-10 16:41:34 EST
I just tried this and it works fine on my machine.
I am using with the latest dhcp client.  Have you tried installing the version
on rawhide?

Comment 3 Paul Witting 2003-03-10 17:50:50 EST
I'm sorry, but what did you try exactly, my initial problem (standard ks.cfg
generated by redhat-config-kickstart) or my workaround (manually edit ks.cfg to
specify both in my ammendment)?

I'm curious because this was a very repeatable problem, on two different systems
(same kickstart disk, redhat 8.0, psyche); making the change to the ks.cfg file
made the problem go away even though there were no differences in the original
ifcfg-eth1 and the now working ifcfg-eth1

But I'll leave it closed because I'm happy with my work-around for now and the
systems are now in production, so I can no longer test.
Comment 4 David Lawrence 2006-04-24 15:04:13 EDT
Adding to blocker bug 185486 and adding IBM group.
Comment 5 David Lawrence 2006-04-24 15:46:12 EDT
The last changes to these bugs were mistakenly made. Removing incorrect blocker
bug and confidential group.

Note You need to log in before you can comment on or make changes to this bug.