Bug 831348 - [abrt] kernel: BUG: unable to handle kernel paging request at 0000004200000018 __d_lookup_rcu()
[abrt] kernel: BUG: unable to handle kernel paging request at 000000420000001...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
abrt_hash:e10589a249d3fac239c18e8d213...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-12 16:18 EDT by Bas Hulsken
Modified: 2012-07-11 08:33 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-11 08:33:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bas Hulsken 2012-06-12 16:18:03 EDT
libreport version: 2.0.8
abrt_version:   2.0.7
cmdline:        BOOT_IMAGE=/vmlinuz-3.3.7-1.fc16.x86_64 root=/dev/vg_steady/lv_root ro nomodeset rd.md=0 rd.dm=0 KEYTABLE=us SYSFONT=latarcyrheb-sun16 rd.lvm.lv=vg_steady/lv_root rd.luks=0 rd.lvm.lv=vg_steady/lv_swap LANG=en_US.UTF-8
event_log:      2012-06-12-22:16:27> Smolt profile successfully saved
kernel:         3.3.7-1.fc16.x86_64
reason:         BUG: unable to handle kernel paging request at 0000004200000018
time:           Tue 12 Jun 2012 09:49:44 PM CEST

backtrace:
:BUG: unable to handle kernel paging request at 0000004200000018
:IP: [<ffffffff81198bac>] __d_lookup_rcu+0x8c/0x170
:PGD 1f4d8d067 PUD 0 
:Oops: 0000 [#1] SMP 
:CPU 1 
:Modules linked in: binfmt_misc rmd160 crypto_null camellia lzo cast6 cast5 deflate zlib_deflate cts gcm ccm serpent_sse2_x86_64 serpent_generic blowfish_generic blowfish_x86_64 blowfish_common twofish_generic twofish_x86_64_3way lrw xts gf128mul twofish_x86_64 twofish_common xcbc sha256_generic sha512_generic des_generic ah6 ah4 esp6 esp4 xfrm4_mode_beet xfrm4_tunnel tunnel4 xfrm4_mode_tunnel xfrm4_mode_transport xfrm6_mode_transport xfrm6_mode_ro xfrm6_mode_beet xfrm6_mode_tunnel ipcomp ipcomp6 xfrm_ipcomp xfrm6_tunnel tunnel6 af_key tun xt_state xt_multiport ipt_MASQUERADE ipt_REDIRECT iptable_nat nf_nat nf_conntrack_ipv4 nf_conntrack nf_defrag_ipv4 xt_DSCP xt_mark coretemp iptable_mangle snd_hda_codec_hdmi snd_hda_codec_realtek arc4 tea5767 tuner_simple tuner_types ath9k mac80211 ath9k_common nfsd ath9k_hw lockd ath nfs_acl auth_rpcgss wm8775 raid456 async_raid6_recov tda9887 async_pq tda8290 tuner cx25840 sunrpc ivtv cx2341x v4l2_common videodev e1000e media tvee
:prom i2c_i801 cfg80211 iTCO_wdt snd_hda_intel iTCO_vendor_support ati_remote2 rfkill snd_hda_codec snd_hwdep ppdev snd_seq snd_seq_device snd_pcm snd_timer snd soundcore snd_page_alloc shpchp parport_pc parport raid6_pq async_xor xor r8169 async_memcpy async_tx mii usblp microcode uinput usb_storage i915 drm_kms_helper drm i2c_algo_bit i2c_core video [last unloaded: scsi_wait_scan]
:Pid: 4972, comm: rsync Not tainted 3.3.7-1.fc16.x86_64 #1 Gigabyte Technology Co., Ltd. Z68P-DS3/Z68P-DS3
:RIP: 0010:[<ffffffff81198bac>]  [<ffffffff81198bac>] __d_lookup_rcu+0x8c/0x170
:RSP: 0018:ffff880203f73bf8  EFLAGS: 00010206
:RAX: ffffc90000b3c9a0 RBX: 0000004200000000 RCX: 0000000000000015
:RDX: ffffc90000002000 RSI: ffff880203f73dd8 RDI: ffff8801858a9b40
:RBP: ffff880203f73c68 R08: 00002a6e0adcb080 R09: 0000000000000000
:R10: 0000000000000000 R11: 000000000000000a R12: 000000000adcb080
:R13: ffff880203f73d40 R14: ffff8801858a9b40 R15: ffff880203f73dd8
:FS:  00007f1abae9f700(0000) GS:ffff88042fa40000(0000) knlGS:0000000000000000
:CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
:CR2: 0000004200000018 CR3: 00000001f4d34000 CR4: 00000000000406e0
:DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
:DR3: 0000000000000000 DR6: 00000000ffff0ff0 DR7: 0000000000000400
:Process rsync (pid: 4972, threadinfo ffff880203f72000, task ffff8802f1ed8000)
:Stack:
: ffff880203f73c08 ffffffff8126961c ffff880203f73c28 ffffffff8118cea8
: ffff880203f73dc8 ffff8802f1ee903d ffff880203f73cb4 ffff880203f73d40
: ffff880203f73c58 ffff880203f73d18 ffff880203f73dc8 ffff880203f73d40
:Call Trace:
: [<ffffffff8126961c>] ? security_inode_permission+0x1c/0x30
: [<ffffffff8118cea8>] ? inode_permission+0x48/0x100
: [<ffffffff8118dc1b>] do_lookup+0x4b/0x3a0
: [<ffffffff8118e9af>] ? path_init+0x16f/0x3a0
: [<ffffffff8118f68c>] path_lookupat+0x11c/0x740
: [<ffffffff8116e485>] ? kmem_cache_alloc+0x125/0x150
: [<ffffffff8118c78b>] ? getname_flags+0x3b/0x280
: [<ffffffff8118fce1>] do_path_lookup+0x31/0xc0
: [<ffffffff81191079>] user_path_at_empty+0x59/0xa0
: [<ffffffff8121d2c8>] ? __ext4_journal_stop+0x78/0xa0
: [<ffffffff811910d1>] user_path_at+0x11/0x20
: [<ffffffff811861ca>] vfs_fstatat+0x3a/0x70
: [<ffffffff8119ecec>] ? mntput_no_expire+0x2c/0x120
: [<ffffffff8118621e>] vfs_lstat+0x1e/0x20
: [<ffffffff811863ba>] sys_newlstat+0x1a/0x40
: [<ffffffff810d345c>] ? __audit_syscall_entry+0xcc/0x310
: [<ffffffff810d3a76>] ? __audit_syscall_exit+0x3d6/0x410
: [<ffffffff815fc529>] system_call_fastpath+0x16/0x1b
:Code: 00 48 8b 15 3f c9 b3 00 48 8d 04 c2 48 8b 18 48 83 e3 fe 75 16 e9 95 00 00 00 0f 1f 44 00 00 48 8b 1b 48 85 db 0f 84 84 00 00 00 <44> 39 63 18 75 ee 44 8b 6b fc 41 f6 c5 01 0f 85 85 00 00 00 4c 
:RIP  [<ffffffff81198bac>] __d_lookup_rcu+0x8c/0x170
: RSP <ffff880203f73bf8>
:CR2: 0000004200000018

smolt_data:
:
:
:General
:=================================
:UUID: b61135f6-b855-4161-b800-860a7f145beb
:OS: Fedora release 16 (Verne)
:Default run level: Unknown
:Language: en_US.UTF-8
:Platform: x86_64
:BogoMIPS: 6217.75
:CPU Vendor: GenuineIntel
:CPU Model: Intel(R) Core(TM) i5-2400 CPU @ 3.10GHz
:CPU Stepping: 7
:CPU Family: 6
:CPU Model Num: 42
:Number of CPUs: 4
:CPU Speed: 3301
:System Memory: 15968
:System Swap: 18015
:Vendor: Gigabyte Technology Co., Ltd.
:System: Z68P-DS3 
:Form factor: Desktop
:Kernel: 3.3.6-3.fc16.x86_64
:SELinux Enabled: 1
:SELinux Policy: targeted
:SELinux Enforce: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Terra.1024.768
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(32902:256:0:0) pci, agpgart-intel, HOST/PCI, 2nd Generation Core Processor Family DRAM Controller
:(4739:34962:5208:20480) pci, None, PCI/PCI, N/A
:(17476:22:112:59399) pci, ivtv, MULTIMEDIA_VIDEO, WinTV PVR 500 (1st unit)
:(32902:7168:5208:45058) pci, ata_piix, STORAGE, 6 Series/C200 Series Chipset Family 4 port SATA IDE Controller
:(32902:7236:5208:20481) pci, None, PCI/ISA, Z68 Express Chipset Family LPC Controller
:(17476:22:112:59415) pci, ivtv, MULTIMEDIA_VIDEO, WinTV PVR 500 (2nd unit)
:(32902:7176:5208:45058) pci, ata_piix, STORAGE, 6 Series/C200 Series Chipset Family 2 port SATA IDE Controller
:(32902:7188:5208:20481) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 3
:(32902:4307:32902:40991) pci, e1000e, ETHERNET, Gigabit CT Desktop Adapter
:(32902:7213:5208:20486) pci, ehci_hcd, USB, 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2
:(32902:7206:5208:20486) pci, ehci_hcd, USB, 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1
:(32902:7226:5208:7226) pci, None, SIMPLE, 6 Series/C200 Series Chipset Family MEI Controller #1
:(4332:33128:5208:57344) pci, r8169, ETHERNET, GA-EP45-DS5 Motherboard
:(32902:258:5208:53248) pci, None, VIDEO, 2nd Generation Core Processor Family Integrated Graphics Controller
:(32902:9294:5208:20481) pci, None, PCI/PCI, 82801 PCI Bridge
:(32902:7184:5208:20481) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 1
:(32902:7186:5208:20481) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 2
:(32902:7200:5208:40962) pci, snd_hda_intel, MULTIMEDIA, 6 Series/C200 Series Chipset Family High Definition Audio Controller
:(5772:36:4486:14960) pci, ath9k, NETWORK, AR5008 Wireless Network Adapter
:(17476:22:112:34817) pci, ivtv, MULTIMEDIA_VIDEO, WinTV PVR 150
:(32902:7202:5208:20481) pci, i801_smbus, SERIAL, 6 Series/C200 Series Chipset Family SMBus Controller
:(13192:33:0:0) pci, None, PCI/PCI, HB6 Universal PCI-PCI bridge (non-transparent mode)
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/mapper/vg_steady-lv_root / ext4 4096 4096 55823999 44401695 42009930 14139392 13764310 13764310
:/dev/sde1 WITHHELD ext4 4096 4096 240369457 15233621 3024121 122109952 122105367 122105367
:/dev/sdf2 /boot ext4 1024 1024 508745 408587 382987 128016 127743 127743
:/dev/md127 /home ext4 4096 4096 1096249534 335355637 280491696 274325504 274004411 274004411
:/dev/md127 WITHHELD ext4 4096 4096 1096249534 335355637 280491696 274325504 274004411 274004411
:/dev/mapper/vg_steady-lv_root WITHHELD ext4 4096 4096 55823999 44401695 42009930 14139392 13764310 13764310
:/dev/mapper/vg_steady-lv_root WITHHELD ext4 4096 4096 55823999 44401695 42009930 14139392 13764310 13764310
:/dev/mapper/vg_steady-lv_root WITHHELD ext4 4096 4096 55823999 44401695 42009930 14139392 13764310 13764310
:/dev/mapper/vg_steady-lv_root WITHHELD ext4 4096 4096 55823999 44401695 42009930 14139392 13764310 13764310
:/dev/mapper/vg_steady-lv_root WITHHELD ext4 4096 4096 55823999 44401695 42009930 14139392 13764310 13764310
:
Comment 1 Dave Jones 2012-07-10 17:47:54 EDT
can you reproduce this in 3.4 ?
Comment 2 Bas Hulsken 2012-07-11 03:37:49 EDT
(In reply to comment #1)
> can you reproduce this in 3.4 ?

Nope, I haven't. This bug should be invalidated, the report is unreliable. I'm quite certain it was caused by a faulty memory module. I've taken out the defective module (with the help of memtest86), and haven't had any problems for the last two days on 3.4. Even when simulating heavy I/O load, which would trigger the bug previously. Haven't tested 3.3 again though.

apologies for the noise
Comment 3 Josh Boyer 2012-07-11 08:33:08 EDT
Thanks for letting us know.

Note You need to log in before you can comment on or make changes to this bug.