Bug 831356 - After installing nvidia driver from rpmfusion yum returns that it has an update for ati driver.
After installing nvidia driver from rpmfusion yum returns that it has an upda...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Fedora Packaging Toolset Team
Fedora Extras Quality Assurance
:
: 831357 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-12 16:42 EDT by Yiannis
Modified: 2014-01-21 18:22 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-13 10:30:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yiannis 2012-06-12 16:42:42 EDT
Description of problem:

running 'yumex' or 'yum update' returns that there is an update to xorg-x11-drv-ati even if i dont have an ATI gfx and thus dont have the prev xorg-x11-drv-ati installed 

Version-Release number of selected component (if applicable): 17


How reproducible:
I installed xorg-x11-drv-nvidia (I have an Nvidia gtx 260) and then after restarting and performing 'yumex' or 'yum update' i get an update for the ati driver

Steps to Reproduce:
1.Install nvidia driver from rpmfusion
2.restart
3.run 'yum update'
  
Actual results:
yum gives an update for ati driver that is not even installed in system

Expected results:
not return an update for a package not installed

Additional info:
Comment 1 Yiannis 2012-06-12 16:46:57 EDT
*** Bug 831357 has been marked as a duplicate of this bug. ***
Comment 2 Tim Lauridsen 2012-06-13 01:11:00 EDT
xorg-x11-drv-ati is part of a default fedora X11 installation  and so is a lot of other xorg-x11-drv-* drivers. So X can support a lot of graphics adapters out of the box.

you can check 'yum list xorg-x11-drv-ati' so see it.
Comment 3 Yiannis 2012-06-13 02:02:45 EDT
(In reply to comment #2)
> xorg-x11-drv-ati is part of a default fedora X11 installation  and so is a
> lot of other xorg-x11-drv-* drivers. So X can support a lot of graphics
> adapters out of the box.
> 
> you can check 'yum list xorg-x11-drv-ati' so see it.

ofc i understand that but its a package like all others its not installed by default. in my system that has an nvidia gfx only driver installed was then nouveau driver. After installing the nvidia driver yum update tells me to install ati driver too? why? i don't have an ati card.
Comment 4 Tim Lauridsen 2012-06-13 10:30:49 EDT
I don't matter what gfx card you have, X will have installed a lot of drivers for different hardware to make it work out of the box if you change your gfx card.
The xorg-x11-drv-ati is not releated to installing the nvidia driver, the update just popped up at the same time.

Try:

sudo yum history pkg-list xorg-x11-drv-ati

and you will see that xorg-x11-drv-ati when the system was installed.

$ repoquery --whatrequires xorg-x11-drv-ati
xorg-x11-drivers-0:7.4-8.fc17.x86_64

$ repoquery --requires xorg-x11-drivers
xorg-x11-drv-apm
xorg-x11-drv-ast
xorg-x11-drv-ati
xorg-x11-drv-cirrus
xorg-x11-drv-dummy
xorg-x11-drv-evdev
xorg-x11-drv-fbdev
xorg-x11-drv-glint
xorg-x11-drv-i128
xorg-x11-drv-i740
xorg-x11-drv-intel
xorg-x11-drv-keyboard
xorg-x11-drv-mach64
xorg-x11-drv-mga
xorg-x11-drv-modesetting
xorg-x11-drv-mouse
xorg-x11-drv-nouveau
xorg-x11-drv-nv
xorg-x11-drv-openchrome
xorg-x11-drv-qxl
xorg-x11-drv-r128
xorg-x11-drv-rendition
xorg-x11-drv-s3virge
xorg-x11-drv-savage
xorg-x11-drv-siliconmotion
xorg-x11-drv-sis
xorg-x11-drv-sisusb
xorg-x11-drv-synaptics
xorg-x11-drv-tdfx
xorg-x11-drv-trident
xorg-x11-drv-v4l
xorg-x11-drv-vesa
xorg-x11-drv-vmmouse
xorg-x11-drv-vmware
xorg-x11-drv-void
xorg-x11-drv-voodoo
xorg-x11-drv-wacom

Note You need to log in before you can comment on or make changes to this bug.