Bug 831373 - Cannot delete Personal calendar (and rename doesn't stick)
Cannot delete Personal calendar (and rename doesn't stick)
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-12 17:49 EDT by Kevin R. Page
Modified: 2012-06-14 02:57 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-13 05:45:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kevin R. Page 2012-06-12 17:49:55 EDT
The "Personal" calendar doesn't have a delete option. I have set another calendar to be the default, but it still cannot be deleted.

I also cannot rename it: if I do so in "Properties" the change is apparently accepted, but the name reverts to Personal when Evolution is restarted.

I had wondered whether the Gnome shell clock/calendar was locking the backend, but after a reboot it no longer seems to be displaying the content of the "Personal" calendar (hopefully it's displaying the new default).

evolution-3.2.3-3.fc16.x86_64
gnome-shell-3.2.2.1-1.fc16.x86_64
Comment 1 Milan Crha 2012-06-13 05:45:28 EDT
Thanks for a bug report, though this is not a bug. Any On This Computer/Personal source (calendar/tasks/memos/address book) is a "system" source, which users cannot delete or rename. This is done by design.

I cannot tell with respect of the gnome-shell, which calendars are used and which not, that might be question for gnome-shell developers. Nonetheless, I vaguely recall about some changes being done in gnome-shell's calendar, which might be part of 3.4.x of gnome-shell, thus Fedora 17. What exact changes they were I do not recall, I'm sorry.
Comment 2 Kevin R. Page 2012-06-13 06:04:18 EDT
(In reply to comment #1)
> Thanks for a bug report, though this is not a bug. Any On This
> Computer/Personal source (calendar/tasks/memos/address book) is a "system"
> source, which users cannot delete or rename. This is done by design.

Thanks for the reply.

1) How can I delete all entries within this calendar? (rather than the calendar itself). Is deleting the calendar file on disk the least worst way? Now knowing the above I realise it was a mistake to import into the Personal calendar -- I should have created a separate test calendar. There are many thousands of entries covering more than a decade, so deleting individually isn't practical.

2) Rename in the Properties dialog should be greyed out for This Computer/Personal, then?
Comment 3 Milan Crha 2012-06-14 02:57:22 EDT
You can Actions->Purge old appointments and meetings from active calendars, though the easiest option is surely to delete files under ~/.local/share/evolution/calendar/system when evolution and evolution-calendar-factory is not running.

I just tried the development 3.5.3 version and the name is stored per localization, thus it sticks even after restart if you change it.

Note You need to log in before you can comment on or make changes to this bug.