Bug 831382 - ImportError: No module named shlex in Beaker's anamon on RHEL3, RHEL4
ImportError: No module named shlex in Beaker's anamon on RHEL3, RHEL4
Status: CLOSED WORKSFORME
Product: Beaker
Classification: Community
Component: beah (Show other bugs)
0.9
Unspecified Unspecified
unspecified Severity unspecified (vote)
: 0.9.0
: ---
Assigned To: Dan Callaghan
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-12 18:13 EDT by Dan Callaghan
Modified: 2012-06-19 03:08 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-19 03:08:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Callaghan 2012-06-12 18:13:43 EDT
Traceback (most recent call last): 
  File "/tmp/anamon", line 31, in ? 
    import shlex 
ImportError: No module named shlex 

RHEL3 and RHEL4 have Python 2.2 but shlex was only added in Python 2.3.
Comment 1 Dan Callaghan 2012-06-19 00:43:07 EDT
(In reply to comment #0)
> RHEL3 and RHEL4 have Python 2.2 but shlex was only added in Python 2.3.

Not quite... shlex was added in Python 1.5, shlex.split was added in Python 2.3. The anamon script already has a workaround for missing shlex.split in Python 2.2.

If the shlex module is missing entirely then there must be something else going on here.
Comment 2 Dan Callaghan 2012-06-19 03:08:42 EDT
Closing as I can't reproduce this.

Note You need to log in before you can comment on or make changes to this bug.