Bug 831396 - ibus-anthy multilib conflict
ibus-anthy multilib conflict
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: ibus-anthy (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: fujiwara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-12 18:42 EDT by Philippe Troin
Modified: 2012-06-25 02:51 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-25 02:51:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Philippe Troin 2012-06-12 18:42:52 EDT
# yum install ibus-anthy
Loaded plugins: changelog, downloadonly, priorities, remove-with-leaves, show-
              : leaves, tsflags
16 packages excluded due to repository priority protections
Package ibus-anthy-1.4.99.20120327-1.fc17.x86_64 already installed and latest version
Resolving Dependencies
--> Running transaction check
---> Package ibus-anthy.i686 0:1.4.99.20120327-1.fc17 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package          Arch       Version                         Repository    Size
================================================================================
Installing:
 ibus-anthy       i686       1.4.99.20120327-1.fc17          fedora       141 k

Transaction Summary
================================================================================
Install  1 Package

Total size: 141 k
Installed size: 705 k
Is this ok [y/N]: y
Downloading Packages:
Running Transaction Check
Running Transaction Test


Transaction Check Error:
  file /usr/libexec/ibus-engine-anthy from install of ibus-anthy-1.4.99.20120327-1.fc17.i686 conflicts with file from package ibus-anthy-1.4.99.20120327-1.fc17.x86_64
  file /usr/share/ibus-anthy/engine/_config.pyc from install of ibus-anthy-1.4.99.20120327-1.fc17.i686 conflicts with file from package ibus-anthy-1.4.99.20120327-1.fc17.x86_64
  file /usr/share/ibus-anthy/setup/_config.pyc from install of ibus-anthy-1.4.99.20120327-1.fc17.i686 conflicts with file from package ibus-anthy-1.4.99.20120327-1.fc17.x86_64
  file /usr/share/ibus-anthy/engine/_config.pyo from install of ibus-anthy-1.4.99.20120327-1.fc17.i686 conflicts with file from package ibus-anthy-1.4.99.20120327-1.fc17.x86_64
  file /usr/share/ibus-anthy/setup/_config.pyo from install of ibus-anthy-1.4.99.20120327-1.fc17.i686 conflicts with file from package ibus-anthy-1.4.99.20120327-1.fc17.x86_64
  file /usr/share/ibus-anthy/engine/engine.pyc from install of ibus-anthy-1.4.99.20120327-1.fc17.i686 conflicts with file from package ibus-anthy-1.4.99.20120327-1.fc17.x86_64
  file /usr/share/ibus-anthy/engine/engine.pyo from install of ibus-anthy-1.4.99.20120327-1.fc17.i686 conflicts with file from package ibus-anthy-1.4.99.20120327-1.fc17.x86_64
  file /usr/share/ibus-anthy/engine/factory.pyc from install of ibus-anthy-1.4.99.20120327-1.fc17.i686 conflicts with file from package ibus-anthy-1.4.99.20120327-1.fc17.x86_64
  file /usr/share/ibus-anthy/engine/factory.pyo from install of ibus-anthy-1.4.99.20120327-1.fc17.i686 conflicts with file from package ibus-anthy-1.4.99.20120327-1.fc17.x86_64
  file /usr/share/ibus-anthy/engine/jastring.pyc from install of ibus-anthy-1.4.99.20120327-1.fc17.i686 conflicts with file from package ibus-anthy-1.4.99.20120327-1.fc17.x86_64
  file /usr/share/ibus-anthy/engine/jastring.pyo from install of ibus-anthy-1.4.99.20120327-1.fc17.i686 conflicts with file from package ibus-anthy-1.4.99.20120327-1.fc17.x86_64
  file /usr/share/ibus-anthy/engine/kana.pyc from install of ibus-anthy-1.4.99.20120327-1.fc17.i686 conflicts with file from package ibus-anthy-1.4.99.20120327-1.fc17.x86_64
  file /usr/share/ibus-anthy/engine/kana.pyo from install of ibus-anthy-1.4.99.20120327-1.fc17.i686 conflicts with file from package ibus-anthy-1.4.99.20120327-1.fc17.x86_64
  file /usr/share/ibus-anthy/engine/main.pyc from install of ibus-anthy-1.4.99.20120327-1.fc17.i686 conflicts with file from package ibus-anthy-1.4.99.20120327-1.fc17.x86_64
  file /usr/share/ibus-anthy/setup/main.pyc from install of ibus-anthy-1.4.99.20120327-1.fc17.i686 conflicts with file from package ibus-anthy-1.4.99.20120327-1.fc17.x86_64
  file /usr/share/ibus-anthy/engine/main.pyo from install of ibus-anthy-1.4.99.20120327-1.fc17.i686 conflicts with file from package ibus-anthy-1.4.99.20120327-1.fc17.x86_64
  file /usr/share/ibus-anthy/setup/main.pyo from install of ibus-anthy-1.4.99.20120327-1.fc17.i686 conflicts with file from package ibus-anthy-1.4.99.20120327-1.fc17.x86_64
  file /usr/share/ibus-anthy/engine/romaji.pyc from install of ibus-anthy-1.4.99.20120327-1.fc17.i686 conflicts with file from package ibus-anthy-1.4.99.20120327-1.fc17.x86_64
  file /usr/share/ibus-anthy/engine/romaji.pyo from install of ibus-anthy-1.4.99.20120327-1.fc17.i686 conflicts with file from package ibus-anthy-1.4.99.20120327-1.fc17.x86_64
  file /usr/share/ibus-anthy/engine/segment.pyc from install of ibus-anthy-1.4.99.20120327-1.fc17.i686 conflicts with file from package ibus-anthy-1.4.99.20120327-1.fc17.x86_64
  file /usr/share/ibus-anthy/engine/segment.pyo from install of ibus-anthy-1.4.99.20120327-1.fc17.i686 conflicts with file from package ibus-anthy-1.4.99.20120327-1.fc17.x86_64
  file /usr/share/ibus-anthy/engine/tables.pyc from install of ibus-anthy-1.4.99.20120327-1.fc17.i686 conflicts with file from package ibus-anthy-1.4.99.20120327-1.fc17.x86_64
  file /usr/share/ibus-anthy/engine/tables.pyo from install of ibus-anthy-1.4.99.20120327-1.fc17.i686 conflicts with file from package ibus-anthy-1.4.99.20120327-1.fc17.x86_64
  file /usr/share/ibus-anthy/engine/thumb.pyc from install of ibus-anthy-1.4.99.20120327-1.fc17.i686 conflicts with file from package ibus-anthy-1.4.99.20120327-1.fc17.x86_64
  file /usr/share/ibus-anthy/engine/thumb.pyo from install of ibus-anthy-1.4.99.20120327-1.fc17.i686 conflicts with file from package ibus-anthy-1.4.99.20120327-1.fc17.x86_64
  file /usr/share/ibus-anthy/setup/anthyprefs.pyc from install of ibus-anthy-1.4.99.20120327-1.fc17.i686 conflicts with file from package ibus-anthy-1.4.99.20120327-1.fc17.x86_64
  file /usr/share/ibus-anthy/setup/anthyprefs.pyo from install of ibus-anthy-1.4.99.20120327-1.fc17.i686 conflicts with file from package ibus-anthy-1.4.99.20120327-1.fc17.x86_64
  file /usr/share/ibus-anthy/setup/prefs.pyc from install of ibus-anthy-1.4.99.20120327-1.fc17.i686 conflicts with file from package ibus-anthy-1.4.99.20120327-1.fc17.x86_64
  file /usr/share/ibus-anthy/setup/prefs.pyo from install of ibus-anthy-1.4.99.20120327-1.fc17.i686 conflicts with file from package ibus-anthy-1.4.99.20120327-1.fc17.x86_64

Error Summary
-------------

[2]    12108 exit 1     noglob yum install ibus-anthy
Comment 1 Parag Nemade 2012-06-14 00:00:16 EDT
I am sure something wrong here with yum repos. If this is x86_64 system then yum installs only x86_64 package. Just see the repo contents.

I think on this x86_64 system i686 repo has been setup.
Comment 2 Philippe Troin 2012-06-14 11:36:59 EDT
Er no, installing i686 packages is allowed on x86_64 for binary compatibility.
In fact you can even compile software both both arches on a properly set-up x86_64 box.  It's called multilib, and I invite you to check it out.

http://fedoraproject.org/wiki/PackagingDrafts/MultilibTricks
Comment 3 fujiwara 2012-06-15 03:03:12 EDT
AFAIK, those python files can be put in the arch independent directory:

https://fedoraproject.org/wiki/Packaging:Python#Macros

python_sitelib	/usr/lib/python2.X/site-packages	Where pure python2 modules are installed 

python_sitearch	/usr/%_lib/python2.X/site-packages	Where python2 extension modules that are compiled C are installed 


The directories are separated if the modules are compiled C and pure python files can be installed in the same directory.
Comment 4 Parag Nemade 2012-06-15 05:30:24 EDT
But can you tell what is a need of installing i686 package on x86_64 package? If you read first line of http://fedoraproject.org/wiki/PackagingDrafts/MultilibTricks#Multiarch.2C_binaries_and_compilation_scripts, you will see that its not recommended to use i686 package on x86_64 arch.

Are you using secondary architectures like ppc64 or s390x?
Comment 5 fujiwara 2012-06-25 02:51:44 EDT
As I noted, I think this is not a bug.

Note You need to log in before you can comment on or make changes to this bug.