Bug 831464 - pid files have incorrect permissions
pid files have incorrect permissions
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: tomcat6 (Show other bugs)
18
All Linux
unspecified Severity high
: ---
: ---
Assigned To: Mikolaj Izdebski
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-12 23:52 EDT by Ade Lee
Modified: 2013-03-25 14:53 EDT (History)
5 users (show)

See Also:
Fixed In Version: tomcat6-6.0.36-1.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-14 10:38:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ade Lee 2012-06-12 23:52:15 EDT
Description of problem:
In /usr/sbin/tomca6-sysd, the following command occurs in the start() function:
chown root:${TOMCAT_USER} $CATALINA_PID

When /usr/sbin/tomcat6 runs though (which it does as TOMCAT_USER), the following lines fail:

if [ ! -z "$CATALINA_PID" ]; then
      echo $! > $CATALINA_PID
fi

because TOMCAT_USER does not have permissions to write to the CATALINA_PID file.

By default, the file is created with rw-r--r-- permissions -- ie. no write permissions for group members.

So either CATALINA_PID needs to be chowned to tomcat_user:tomcat_user - or its permissions need to be changed so that it has group write permissions.

Without this change, the server fails to start.

Version-Release number of selected component (if applicable):
tomcat6-6.0.35-1

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Dmitri Pal 2012-06-13 10:48:19 EDT
The priority of this bug is high. Please help!
Comment 2 Mikolaj Izdebski 2013-03-14 10:38:40 EDT
Package tomcat6 has been deprecated in Fedora 19 and later.
I am closing this bug as WONTFIX.

For more information why tomcat6 was deprecated see:
  http://bugzilla.redhat.com/918010
  http://lists.fedoraproject.org/pipermail/devel/2013-March/179847.html
  http://fedorahosted.org/fesco/ticket/1094
Comment 3 David Knox 2013-03-25 14:53:57 EDT
The permissions for CATALINA_PID are TOMCAT_USER:TOMCAT_USER. Changing to CURRENTRELEASE to document the fix is in f18

Note You need to log in before you can comment on or make changes to this bug.