Bug 831478 - unexpected warning messages for the broken dependency parseconfig (1.0.2)
unexpected warning messages for the broken dependency parseconfig (1.0.2)
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Command Line Interface (Show other bugs)
2.x
Unspecified Unspecified
high Severity medium
: ---
: ---
Assigned To: Clayton Coleman
libra bugs
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-13 01:47 EDT by Meng Bo
Modified: 2015-05-14 21:57 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-25 14:27:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Meng Bo 2012-06-13 01:47:18 EDT
Description of problem:
Install rhc client via 'gem install rhc', it will install the dependency parseconfig (=1.0.2) automatically. 
Run any rhc command from the terminal, error message "ParseConfig Deprecation Warning: get_value() is deprecated. Use config['param'] or config['group']['param'] instead." appears.

Version-Release number of selected component (if applicable):
parseconfig 1.0.2

How reproducible:
always

Steps to Reproduce:
1.install rhc client via gem install
2.run any rhc command
3.
  
Actual results:
warning message "ParseConfig Deprecation Warning: get_value() is deprecated. Use config['param'] or config['group']['param'] instead." appears.

Expected results:
no any warning message.

Additional info:
This issue caused by parseconfig upgrade today, which is ok for parseconfig (0.5.2).


$gem list
parseconfig (1.0.2)
<......>
rhc (0.93.19)


$rhc domain show
[root@F17i386-openshift ~]# rhc domain show
ParseConfig Deprecation Warning: get_value() is deprecated. Use config['param'] or config['group']['param'] instead.
ParseConfig Deprecation Warning: get_value() is deprecated. Use config['param'] or config['group']['param'] instead.
ParseConfig Deprecation Warning: get_value() is deprecated. Use config['param'] or config['group']['param'] instead.
ParseConfig Deprecation Warning: get_value() is deprecated. Use config['param'] or config['group']['param'] instead.
ParseConfig Deprecation Warning: get_value() is deprecated. Use config['param'] or config['group']['param'] instead.
Password:******

User Info
=========
Namespace: mydomain
  RHLogin: bmeng@redhat.com


Application Info
================
No applications found.  You can use 'rhc app create' to create new applications.
Comment 1 Xiaoli Tian 2012-06-18 04:34:37 EDT
Checked it on rhc-0.94.4, it will install parseconfig 0.5.2 in default now, if that's the fix for this bug, please help to move it to ON_QA, we'll move it to verified.

Thanks
Comment 2 Clayton Coleman 2012-06-18 12:40:08 EDT
We want to be more flexible to future usage - we're going to support both 0.5.2 and 1.0+ with no warnings in the code.
Comment 3 Clayton Coleman 2012-06-18 15:11:09 EDT
Johnp committed a fix today.
Comment 4 Meng Bo 2012-06-19 22:12:07 EDT
Verified with rhc-0.94.7.gem, rhc do not need install parseconfig as dependency now.
Mark bug as verified.

Note You need to log in before you can comment on or make changes to this bug.