Bug 831502 - Missing Dependency between openstack-nova-novncproxy and novnc
Summary: Missing Dependency between openstack-nova-novncproxy and novnc
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: novnc
Version: el6
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Pádraig Brady
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-06-13 07:13 UTC by Jose Castro Leon
Modified: 2012-07-03 19:32 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-07-03 19:32:27 UTC
Type: Bug


Attachments (Terms of Use)

Description Jose Castro Leon 2012-06-13 07:13:28 UTC
Description of problem:
There is a missing dependency in the openstack-nova-novncproxy rpm.
It should require novnc package to be installed and it is not included in the required section

Version-Release number of selected component (if applicable):
openstack-nova-novncproxy-0.3-6.el6

How reproducible:
100%

Steps to Reproduce:
1. Install openstack-nova-novncproxy package
2. The service cannot run because there is a missing dependency
3.
  
Actual results:
Service 'openstack-nova-novncproxy' unable to start

Expected results:
Service 'openstack-nova-novncproxy' started successfully

Additional info:

diff -u novnc.spec.nopatch novnc.spec
--- novnc.spec.nopatch  2012-06-13 09:11:30.000000000 +0200
+++ novnc.spec  2012-06-13 08:30:12.000000000 +0200
@@ -39,6 +39,7 @@
 Summary:        Proxy server for noVNC traffic over Websockets
 Requires:       numpy
 Requires:       python-websockify
+Requires:       novnc

 %if %{with_systemd}
 Requires(post): systemd-units

Comment 1 Fedora Update System 2012-06-13 14:41:22 UTC
novnc-0.3-8.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/novnc-0.3-8.fc17

Comment 2 Fedora Update System 2012-06-13 14:44:02 UTC
novnc-0.3-8.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/novnc-0.3-8.el6

Comment 3 Fedora Update System 2012-06-14 15:22:24 UTC
novnc-0.3-9.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/novnc-0.3-9.el6

Comment 4 Fedora Update System 2012-06-15 02:09:41 UTC
novnc-0.3-9.el6 has been pushed to the Fedora EPEL 6 testing repository.

Comment 5 Fedora Update System 2012-06-15 09:34:24 UTC
novnc-0.3-10.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/novnc-0.3-10.el6

Comment 6 Fedora Update System 2012-07-03 19:32:27 UTC
novnc-0.3-10.el6 has been pushed to the Fedora EPEL 6 stable repository.


Note You need to log in before you can comment on or make changes to this bug.