Bug 831607 - Torquebox sources cannot be built out of the box
Torquebox sources cannot be built out of the box
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise WFK Platform 2
Classification: JBoss
Component: TorqueBox (Show other bugs)
2.0.0.ER7
Unspecified Unspecified
low Severity low
: ER1
: 2.1.0
Assigned To: Ben Browning
Karel Piwko
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-13 08:31 EDT by Karel Piwko
Modified: 2012-11-30 10:34 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
A number of artifacts required to build TorqueBox from source are not present in the Maven Central and Enterprise Maven repositories. The TorqueBox documentation has been updated to clarify that the JBoss Nexus repository must be enabled, as it contains the required artifacts. Refer to the TorqueBox User Guide for further information on building TorqueBox from source and the Red Hat Maven Guide for details about configuring repositories.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-30 10:34:49 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karel Piwko 2012-06-13 08:31:55 EDT
TorqueBox compilation requires artifacts which are not present in Maven Central nor distributed Maven repositories, you have to enable JBoss Nexus repository according to instructions at https://community.jboss.org/wiki/MavenGettingStarted-Users


<profile>
      <id>jboss-public-repository</id>
      <repositories>
        <repository>
          <id>jboss-public-repository-group</id>
          <name>JBoss Public Maven Repository Group</name>
          <url>https://repository.jboss.org/nexus/content/groups/public-jboss/</url>
          <layout>default</layout>
          <releases>
            <enabled>true</enabled>
            <updatePolicy>never</updatePolicy>
          </releases>
          <snapshots>
            <enabled>true</enabled>
            <updatePolicy>never</updatePolicy>
          </snapshots>
        </repository>
      </repositories>
      <pluginRepositories>
        <pluginRepository>
          <id>jboss-public-repository-group</id>
          <name>JBoss Public Maven Repository Group</name>
          <url>https://repository.jboss.org/nexus/content/groups/public-jboss/</url>
          <layout>default</layout>
          <releases>
            <enabled>true</enabled>
            <updatePolicy>never</updatePolicy>
          </releases>
          <snapshots>
            <enabled>true</enabled>
            <updatePolicy>never</updatePolicy>
          </snapshots>
        </pluginRepository>
      </pluginRepositories>
    </profile>


  <activeProfiles>
    <activeProfile>jboss-public-repository</activeProfile>
  </activeProfiles>
Comment 1 Karel Piwko 2012-06-13 08:33:11 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Compilation of TorqueBox requires artifacts which are not present in Maven Central nor distributed Maven repositories. You have to enable JBoss Nexus repository according to instructions at https://community.jboss.org/wiki/MavenGettingStarted-Users, namely include following snippet into settings.xml file:

<profile>
      <id>jboss-public-repository</id>
      <repositories>
        <repository>
          <id>jboss-public-repository-group</id>
          <name>JBoss Public Maven Repository Group</name>
          <url>https://repository.jboss.org/nexus/content/groups/public-jboss/</url>
          <layout>default</layout>
          <releases>
            <enabled>true</enabled>
            <updatePolicy>never</updatePolicy>
          </releases>
          <snapshots>
            <enabled>true</enabled>
            <updatePolicy>never</updatePolicy>
          </snapshots>
        </repository>
      </repositories>
      <pluginRepositories>
        <pluginRepository>
          <id>jboss-public-repository-group</id>
          <name>JBoss Public Maven Repository Group</name>
          <url>https://repository.jboss.org/nexus/content/groups/public-jboss/</url>
          <layout>default</layout>
          <releases>
            <enabled>true</enabled>
            <updatePolicy>never</updatePolicy>
          </releases>
          <snapshots>
            <enabled>true</enabled>
            <updatePolicy>never</updatePolicy>
          </snapshots>
        </pluginRepository>
      </pluginRepositories>
    </profile>


  <activeProfiles>
    <activeProfile>jboss-public-repository</activeProfile>
  </activeProfiles>
Comment 2 Rebecca Newton 2012-06-18 00:51:03 EDT
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1,42 +1,5 @@
-Compilation of TorqueBox requires artifacts which are not present in Maven Central nor distributed Maven repositories. You have to enable JBoss Nexus repository according to instructions at https://community.jboss.org/wiki/MavenGettingStarted-Users, namely include following snippet into settings.xml file:
+TorqueBox sources cannot be built out of the box due to a compilation of required TorqueBox artifacts which are not present in Maven Central or distributed in the Enterprise Maven repository. To workaround this issue, enable the JBoss Nexus repository by including the following snippet in the settings.xml file:
 
-<profile>
-      <id>jboss-public-repository</id>
-      <repositories>
-        <repository>
-          <id>jboss-public-repository-group</id>
-          <name>JBoss Public Maven Repository Group</name>
-          <url>https://repository.jboss.org/nexus/content/groups/public-jboss/</url>
-          <layout>default</layout>
-          <releases>
-            <enabled>true</enabled>
-            <updatePolicy>never</updatePolicy>
-          </releases>
-          <snapshots>
-            <enabled>true</enabled>
-            <updatePolicy>never</updatePolicy>
-          </snapshots>
-        </repository>
-      </repositories>
-      <pluginRepositories>
-        <pluginRepository>
-          <id>jboss-public-repository-group</id>
-          <name>JBoss Public Maven Repository Group</name>
-          <url>https://repository.jboss.org/nexus/content/groups/public-jboss/</url>
-          <layout>default</layout>
-          <releases>
-            <enabled>true</enabled>
-            <updatePolicy>never</updatePolicy>
-          </releases>
-          <snapshots>
-            <enabled>true</enabled>
-            <updatePolicy>never</updatePolicy>
-          </snapshots>
-        </pluginRepository>
-      </pluginRepositories>
-    </profile>
+<snipped for brevity>
 
-
+More information on setting the public repository is available here: https://community.jboss.org/wiki/MavenGettingStarted-Users-  <activeProfiles>
-    <activeProfile>jboss-public-repository</activeProfile>
-  </activeProfiles>
Comment 4 Karel Piwko 2012-09-24 09:15:18 EDT
This is related to Torquebox Maven repository configuration bug 849695. There should be a single place where Maven configuration is shown in documenation.
Comment 5 Marek Novotny 2012-09-25 04:48:31 EDT
Just to be precise, what artifacts are missing?
Comment 7 rfalhar 2012-09-27 06:23:16 EDT
It seems only Maven plugins, that have -redhat-1 version are missing. Adding plugin repository http://download.devel.redhat.com/brewroot/repos/mead-jb-eap-6-rhel-6-maven-plugins/latest/maven/ makes it build correctly.
Comment 8 Marek Novotny 2012-09-27 06:37:07 EDT
That is expected, so we could close this issue, right?
Comment 9 Karel Piwko 2012-09-27 09:50:44 EDT
Yes, marking as verified.
Comment 10 Karel Piwko 2012-11-30 10:34:49 EST
Distributed as a part of WFK 2.1.0.GA release.

Note You need to log in before you can comment on or make changes to this bug.