Bug 831610 - [abrt] libreoffice-core-3.5.4.2-1.fc17: SwDoc::getListByName killed by signal 11 (SIGSEGV)
[abrt] libreoffice-core-3.5.4.2-1.fc17: SwDoc::getListByName killed by signal...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
abrt_hash:8fbc3ce68325bb660f7e655e0f0...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-13 08:39 EDT by markusN
Modified: 2012-09-11 09:05 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-11 09:05:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (59.14 KB, text/plain)
2012-06-13 08:39 EDT, markusN
no flags Details
File: maps (83.34 KB, text/plain)
2012-06-13 08:39 EDT, markusN
no flags Details
File: dso_list (18.73 KB, text/plain)
2012-06-13 08:39 EDT, markusN
no flags Details

  None (edit)
Description markusN 2012-06-13 08:39:10 EDT
libreport version: 2.0.10
abrt_version:   2.0.10
backtrace_rating: 4
cmdline:        /usr/lib64/libreoffice/program/soffice.bin FEM_CRI_Rendicontazione_2011_DBEM_PGIS.doc --splash-pipe=6
comment:        accepting change in change tracking
crash_function: operator()
executable:     /usr/lib64/libreoffice/program/soffice.bin
kernel:         3.4.0-1.fc17.x86_64
pid:            31447
pwd:            /home/neteler/Dropbox/piattaforma_GIS_RS/pgis/rendicontazione/2012
time:           Wed 13 Jun 2012 02:25:41 PM CEST
uid:            1338
username:       neteler
xsession_errors: 

backtrace:      Text file, 60557 bytes
dso_list:       Text file, 19184 bytes
maps:           Text file, 85340 bytes

cgroup:
:9:perf_event:/
:8:blkio:/
:7:net_cls:/
:6:freezer:/
:5:devices:/
:4:memory:/
:3:cpuacct,cpu:/
:2:cpuset:/
:1:name=systemd:/user/neteler/2

core_backtrace:
:8569c49435bdc41bfb176cc47e66fec0fa406fb4 0x386b60 SwDoc::getListByName(String) libswlo.so -
:8569c49435bdc41bfb176cc47e66fec0fa406fb4 0x5d749c SwTxtNode::HasMarkedLabel() libswlo.so -
:8569c49435bdc41bfb176cc47e66fec0fa406fb4 0x56be7c - libswlo.so -
:8569c49435bdc41bfb176cc47e66fec0fa406fb4 0x581f84 - libswlo.so -
:8569c49435bdc41bfb176cc47e66fec0fa406fb4 0x57def1 - libswlo.so -
:8569c49435bdc41bfb176cc47e66fec0fa406fb4 0x566729 - libswlo.so -
:8569c49435bdc41bfb176cc47e66fec0fa406fb4 0x4f9e17 - libswlo.so -
:8569c49435bdc41bfb176cc47e66fec0fa406fb4 0x4f9e17 - libswlo.so -
:8569c49435bdc41bfb176cc47e66fec0fa406fb4 0x4fab1f - libswlo.so -
:8569c49435bdc41bfb176cc47e66fec0fa406fb4 0x7374f4 ViewShell::ImplEndAction(unsigned libswlo.so -
:8569c49435bdc41bfb176cc47e66fec0fa406fb4 0x30cecf SwCrsrShell::EndAction(unsigned libswlo.so -
:8569c49435bdc41bfb176cc47e66fec0fa406fb4 0x44483e - libswlo.so -
:8569c49435bdc41bfb176cc47e66fec0fa406fb4 0x8b72f1 - libswlo.so -
:8569c49435bdc41bfb176cc47e66fec0fa406fb4 0x8c2ab8 - libswlo.so -
:b0dc1bd770f45033fae0cd2088942c9acd112cef 0x34f4fd - libvcllo.so -
:b0dc1bd770f45033fae0cd2088942c9acd112cef 0x351e13 - libvcllo.so -
:b0dc1bd770f45033fae0cd2088942c9acd112cef 0x3529ad - libvcllo.so -
:48f20d96a4e96374b796e5bd96270d9f8509a3f9 0x4c7dc - libvclplug_gtklo.so -
:8c1105fdca80308f44d545b954a7dcd518f98db5 0x14db1c - libgtk-x11-2.0.so.0 -
:31243d0d107bba586a96433c76c87a26db1e826c 0xf664 g_closure_invoke libgobject-2.0.so.0 -
:31243d0d107bba586a96433c76c87a26db1e826c 0x206d8 - libgobject-2.0.so.0 -
:31243d0d107bba586a96433c76c87a26db1e826c 0x282a7 g_signal_emit_valist libgobject-2.0.so.0 -
:31243d0d107bba586a96433c76c87a26db1e826c 0x287c2 g_signal_emit libgobject-2.0.so.0 -
:8c1105fdca80308f44d545b954a7dcd518f98db5 0x28156e - libgtk-x11-2.0.so.0 -
:8c1105fdca80308f44d545b954a7dcd518f98db5 0x14b8e4 gtk_propagate_event libgtk-x11-2.0.so.0 -
:8c1105fdca80308f44d545b954a7dcd518f98db5 0x14bc4b gtk_main_do_event libgtk-x11-2.0.so.0 -
:d8d393649ae4da146ebc8812db58514f245f08a9 0x616fc - libgdk-x11-2.0.so.0 -
:e5945f7dae3fc83ad499da1ea5a464bfa0e68202 0x476e5 g_main_context_dispatch libglib-2.0.so.0 -
:e5945f7dae3fc83ad499da1ea5a464bfa0e68202 0x47a18 - libglib-2.0.so.0 -
:e5945f7dae3fc83ad499da1ea5a464bfa0e68202 0x47ad4 g_main_context_iteration libglib-2.0.so.0 -
:48f20d96a4e96374b796e5bd96270d9f8509a3f9 0x30dd1 - libvclplug_gtklo.so -
:48f20d96a4e96374b796e5bd96270d9f8509a3f9 0x31acd - libvclplug_gtklo.so -
:b0dc1bd770f45033fae0cd2088942c9acd112cef 0xfbbe4 Application::Yield(bool) libvcllo.so -
:b0dc1bd770f45033fae0cd2088942c9acd112cef 0xfbc87 Application::Execute() libvcllo.so -
:243761d7e722b89c81f7f13d0841b4776c50890d 0x1dd59 - libsofficeapp.so -
:b0dc1bd770f45033fae0cd2088942c9acd112cef 0x102621 - libvcllo.so -
:b0dc1bd770f45033fae0cd2088942c9acd112cef 0x1026c5 SVMain() libvcllo.so -
:243761d7e722b89c81f7f13d0841b4776c50890d 0x41d36 soffice_main libsofficeapp.so -
:18ffb5d5f97d5a9e8dc0acd3f6ae0aa87917dc08 0x6bb - [exe] -

environ:
:XDG_VTNR=1
:XDG_SESSION_ID=2
:SSH_AGENT_PID=1334
:HOSTNAME=north.localdomain
:IMSETTINGS_INTEGRATE_DESKTOP=yes
:GLADE_PIXMAP_PATH=:
:GPG_AGENT_INFO=/home/neteler/.gnupg/S.gpg-agent:1363:1
:XDG_MENU_PREFIX=xfce-
:SHELL=/bin/bash
:TERM=xterm
:XDG_SESSION_COOKIE=be5e8ae77a2d94aa13f30c250000000e-1339482814.678507-1277120521
:HISTSIZE=50000
:WINDOWID=94371844
:OLDPWD=/usr/lib64/libreoffice/program
:QTDIR=/usr/lib64/qt-3.3
:GNOME_KEYRING_CONTROL=/run/user/neteler/keyring-1HAjod
:QTINC=/usr/lib64/qt-3.3/include
:QT_GRAPHICSSYSTEM_CHECKED=1
:IMSETTINGS_MODULE=none
:USER=neteler
:SVN_EDITOR=vim
:LS_COLORS=rs=0:di=01;34:ln=01;36:mh=00:pi=40;33:so=01;35:do=01;35:bd=40;33;01:cd=40;33;01:or=40;31;01:mi=01;05;37;41:su=37;41:sg=30;43:ca=30;41:tw=30;42:ow=34;42:st=37;44:ex=01;32:*.tar=01;31:*.tgz=01;31:*.arj=01;31:*.taz=01;31:*.lzh=01;31:*.lzma=01;31:*.tlz=01;31:*.txz=01;31:*.zip=01;31:*.z=01;31:*.Z=01;31:*.dz=01;31:*.gz=01;31:*.lz=01;31:*.xz=01;31:*.bz2=01;31:*.tbz=01;31:*.tbz2=01;31:*.bz=01;31:*.tz=01;31:*.deb=01;31:*.rpm=01;31:*.jar=01;31:*.war=01;31:*.ear=01;31:*.sar=01;31:*.rar=01;31:*.ace=01;31:*.zoo=01;31:*.cpio=01;31:*.7z=01;31:*.rz=01;31:*.jpg=01;35:*.jpeg=01;35:*.gif=01;35:*.bmp=01;35:*.pbm=01;35:*.pgm=01;35:*.ppm=01;35:*.tga=01;35:*.xbm=01;35:*.xpm=01;35:*.tif=01;35:*.tiff=01;35:*.png=01;35:*.svg=01;35:*.svgz=01;35:*.mng=01;35:*.pcx=01;35:*.mov=01;35:*.mpg=01;35:*.mpeg=01;35:*.m2v=01;35:*.mkv=01;35:*.ogm=01;35:*.mp4=01;35:*.m4v=01;35:*.mp4v=01;35:*.vob=01;35:*.qt=01;35:*.nuv=01;35:*.wmv=01;35:*.asf=01;35:*.rm=01;35:*.rmvb=01;35:*.flc=01;35:*.avi=01;35:*.fli=01;35:*.flv=01;35:*.gl=01;35:*.dl=01;35:*.xcf=01;35:*.xwd=01;35:*.yuv=01;35:*.cgm=01;35:*.emf=01;35:*.axv=01;35:*.anx=01;35:*.ogv=01;35:*.ogx=01;35:*.aac=01;36:*.au=01;36:*.flac=01;36:*.mid=01;36:*.midi=01;36:*.mka=01;36:*.mp3=01;36:*.mpc=01;36:*.ogg=01;36:*.ra=01;36:*.wav=01;36:*.axa=01;36:*.oga=01;36:*.spx=01;36:*.xspf=01;36:*.pdf=00;33:*.ps=00;33:*.ps.gz=00;33:*.txt=00;33:*.patch=00;33:*.diff=00;33:*.log=00;33:*.tex=00;33:*.xls=00;33:*.xlsx=00;33:*.ppt=00;33:*.pptx=00;33:*.rtf=00;33:*.doc=00;33:*.docx=00;33:*.odt=00;33:*.ods=00;33:*.odp=00;33:*.xml=00;33:*.epub=00;33:*.abw=00;33:*.html=00;33:*.wpd=00;33:
:GLADE_MODULE_PATH=:
:SSH_AUTH_SOCK=/tmp/ssh-dWjbfFxU1201/agent.1201
:USERNAME=neteler
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/1372,unix/unix:/tmp/.ICE-unix/1372
:'ARTOOLKIT_CONFIG=v4l2src device=/dev/video0 use-fixed-fps=false ! ffmpegcolorspace ! capsfilter caps=video/x-raw-rgb,bpp=24 ! identity name=artoolkit ! fakesink'
:XDG_CONFIG_DIRS=/etc/xdg
:DESKTOP_SESSION=xfce
:MAIL=/var/spool/mail/neteler
:PATH=/usr/java/default/bin:/usr/java/default/bin:/usr/lib64/qt-3.3/bin:/usr/lib64/ccache:/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/home/neteler/bin
:QT_IM_MODULE=xim
:PWD=/home/neteler/2012
:JAVA_HOME=/usr/java/default
:XMODIFIERS=@im=none
:KDE_IS_PRELINKED=1
:LANG=en_US.UTF-8
:GNOME_KEYRING_PID=1199
:KDEDIRS=/usr
:GDMSESSION=xfce
:HISTCONTROL=ignoredups
:SSH_ASKPASS=/usr/libexec/openssh/gnome-ssh-askpass
:SHLVL=3
:XDG_SEAT=seat0
:HOME=/home/neteler
:SAL_ENABLE_FILE_LOCKING=1
:LOGNAME=neteler
:CVS_RSH=ssh
:QTLIB=/usr/lib64/qt-3.3/lib
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-VaKnA2lJjU,guid=5d35a2195fdb9a9633b66c2200000030
:XDG_DATA_DIRS=/usr/local/share:/usr/share
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:WINDOWPATH=1
:XDG_RUNTIME_DIR=/run/user/neteler
:DISPLAY=:0.0
:GLADE_CATALOG_PATH=:
:LIBGLADE_MODULE_PATH=:
:XAUTHORITY=/var/run/gdm/auth-for-neteler-2fKjGH/database
:COLORTERM=Terminal
:CCACHE_HASHDIR=
:LD_LIBRARY_PATH=/usr/lib/jvm/java-1.7.0-openjdk-1.7.0.3.x86_64/jre/lib/amd64/client:/usr/lib/jvm/java-1.7.0-openjdk-1.7.0.3.x86_64/jre/lib/amd64/server:/usr/lib/jvm/java-1.7.0-openjdk-1.7.0.3.x86_64/jre/lib/amd64/native_threads:/usr/lib/jvm/java-1.7.0-openjdk-1.7.0.3.x86_64/jre/lib/amd64

limits:
:Limit                     Soft Limit           Hard Limit           Units     
:Max cpu time              unlimited            unlimited            seconds   
:Max file size             unlimited            unlimited            bytes     
:Max data size             unlimited            unlimited            bytes     
:Max stack size            8388608              unlimited            bytes     
:Max core file size        0                    unlimited            bytes     
:Max resident set          unlimited            unlimited            bytes     
:Max processes             1024                 31384                processes 
:Max open files            4096                 4096                 files     
:Max locked memory         65536                65536                bytes     
:Max address space         unlimited            unlimited            bytes     
:Max file locks            unlimited            unlimited            locks     
:Max pending signals       31384                31384                signals   
:Max msgqueue size         819200               819200               bytes     
:Max nice priority         0                    0                    
:Max realtime priority     0                    0                    
:Max realtime timeout      unlimited            unlimited            us        

open_fds:
:0:/dev/pts/0
:1:/dev/pts/0
:2:/dev/pts/0
:3:socket:[222745]
:4:anon_inode:[eventfd]
:5:pipe:[222083]
:6:pipe:[222083]
:7:socket:[222747]
:8:socket:[222093]

smolt_data:
:
:
:General
:=================================
:UUID: 33142b9c-cee3-4ba9-ab06-71f6a9c3327b
:OS: Fedora release 17 (Beefy Miracle)
:Default run level: Unknown
:Language: en_US.UTF-8
:Platform: x86_64
:BogoMIPS: 5053.46
:CPU Vendor: GenuineIntel
:CPU Model: Intel(R) Core(TM)2 Duo CPU     P8700  @ 2.53GHz
:CPU Stepping: 10
:CPU Family: 6
:CPU Model Num: 23
:Number of CPUs: 2
:CPU Speed: 2535
:System Memory: 3943
:System Swap: 3999
:Vendor: Dell Inc.
:System: Precision M4400 
:Form factor: Portable
:Kernel: 3.4.0-1.fc17.x86_64
:SELinux Enabled: 1
:SELinux Policy: targeted
:SELinux Enforce: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(32902:10816:4136:592) pci, None, HOST/PCI, Mobile 4 Series Chipset Memory Controller Hub
:(32902:10817:4136:592) pci, pcieport, PCI/PCI, Mobile 4 Series Chipset PCI Express Graphics Port
:(32902:10544:4136:592) pci, i801_smbus, SERIAL, 82801I (ICH9 Family) SMBus Controller
:(32902:10282:4136:592) pci, ahci, RAID, Mobile 82801 SATA RAID Controller
:(32902:10519:4136:592) pci, None, PCI/ISA, ICH9M-E LPC Interface Controller
:(32902:4341:4136:592) pci, e1000e, ETHERNET, 82567LM Gigabit Network Connection
:(32902:16946:32902:4897) pci, iwlwifi, NETWORK, WiFi Link 5100 AGN
:(32902:9288:4136:592) pci, None, PCI/PCI, 82801 Mobile PCI Bridge
:(32902:10549:4136:592) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #2
:(32902:10548:4136:592) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #1
:(32902:10553:4136:592) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #6
:(32902:10550:4136:592) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #3
:(4480:2082:4136:592) pci, sdhci-pci, BASE, R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter
:(4480:1142:4136:592) pci, yenta_cardbus, PCI/CARDBUS, RL5c476 II
:(32902:10556:4136:592) pci, ehci_hcd, USB, 82801I (ICH9 Family) USB2 EHCI Controller #2
:(32902:10564:4136:592) pci, pcieport, PCI/PCI, 82801I (ICH9 Family) PCI Express Port 3
:(32902:10566:4136:592) pci, pcieport, PCI/PCI, 82801I (ICH9 Family) PCI Express Port 4
:(32902:10560:4136:592) pci, pcieport, PCI/PCI, 82801I (ICH9 Family) PCI Express Port 1
:(32902:10562:4136:592) pci, pcieport, PCI/PCI, 82801I (ICH9 Family) PCI Express Port 2
:(32902:10558:4136:592) pci, snd_hda_intel, MULTIMEDIA, 82801I (ICH9 Family) HD Audio Controller
:(32902:10551:4136:592) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #4
:(32902:10552:4136:592) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #5
:(4318:1628:4136:592) pci, nvidia, VIDEO, G96M [Quadro FX 770M]
:(32902:10554:4136:592) pci, ehci_hcd, USB, 82801I (ICH9 Family) USB2 EHCI Controller #1
:(4480:2098:4136:592) pci, firewire_ohci, FIREWIRE, R5C832 IEEE 1394 Controller
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/sda1 / ext4 4096 4096 3826755 841099 649099 960992 668852 668852
:/dev/sda3 /home ext4 4096 4096 56117990 9197553 6388286 14049280 13605492 13605492
:

var_log_messages:
:Jun 13 14:25:41 north kernel: [107574.347497] soffice.bin[31447]: segfault at 7fff181ec006 ip 00007fa004b4fb60 sp 00007fff181e6160 error 4 in libswlo.so[7fa0047c9000+bcf000]
:Jun 13 14:25:43 north abrt[7997]: Saved core dump of pid 31447 (/usr/lib64/libreoffice/program/soffice.bin) to /var/spool/abrt/ccpp-2012-06-13-14:25:41-31447 (144474112 bytes)
Comment 1 markusN 2012-06-13 08:39:15 EDT
Created attachment 591471 [details]
File: backtrace
Comment 2 markusN 2012-06-13 08:39:17 EDT
Created attachment 591472 [details]
File: maps
Comment 3 markusN 2012-06-13 08:39:19 EDT
Created attachment 591473 [details]
File: dso_list
Comment 4 Caolan McNamara 2012-06-15 11:02:14 EDT
Are you able to attach here the document that crashed libreoffice when you viewed it ?

I feel the root of the problem is in the file import, rather than the point of crash in rendering it.
Comment 5 markusN 2012-06-15 12:48:21 EDT
It is a kind of sensitive .doc document which I don't want to share with the world. Strip down to a minimum (which probably makes disappear the bug)?

Any suggestions for this case?
Comment 6 Caolan McNamara 2012-06-15 16:55:45 EDT
if you can strip it down and still reproduce it, then that'd be great. Otherwise if you can share it privately with me, feel free to email it to me directly
Comment 8 Caolan McNamara 2012-09-11 09:05:54 EDT
Got the reproducer document, but accepting/rejecting chanages works for me, so presumably its some unknown sequence of accepting or rejecting certain changes possibly with some modification inbetween :-(

Note You need to log in before you can comment on or make changes to this bug.