Bug 831612 - Unable to login graphically in enforcing mode
Unable to login graphically in enforcing mode
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-13 08:48 EDT by Bruno Wolff III
Modified: 2012-06-13 10:56 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-13 10:56:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bruno Wolff III 2012-06-13 08:48:00 EDT
Description of problem:
When trying to login graphically in enforcing mode, access to /var/lib/gdm/.Iceauthority is blocked. Switching to permissive mode fixes this.

Version-Release number of selected component (if applicable):
gdm-3.5.2-2.fc18.i686
selinux-policy-targeted-3.11.0-2.fc18.noarch

How reproducible:
Seems to happen repeatedly.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
I tried to relabel /var/lib/gdm and didn't see any changes.

type=AVC msg=audit(1339590941.847:358): avc:  denied  { write } for  pid=3050 comm="gnome-session" name=".ICEauthority" dev="dm-0" ino=2000767 scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=system_u:object_r:var_lib_t:s0 tclass=file
Comment 1 Bruno Wolff III 2012-06-13 10:56:04 EDT
It looks like there are fixes for this in today's rawhide updates so I am going to close this.

Note You need to log in before you can comment on or make changes to this bug.