Bug 831626 - Pretty and filter view toggle buttons are non-functional (Chrome and Firefox)
Pretty and filter view toggle buttons are non-functional (Chrome and Firefox)
Status: CLOSED ERRATA
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-conductor (Show other bugs)
1.1.0
Unspecified Unspecified
unspecified Severity high
: rc
: ---
Assigned To: Matt Wagner
Rehana
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-13 09:11 EDT by Justin Clift
Modified: 2015-07-13 00:35 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
A fault in the view toggle buttons prevented the user from switching between Pretty View and Filter View. This bug fix corrects the mechanism for switching views. Users now switch between Pretty View and Filter View without fault.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 10:10:39 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screencast showing the problem on both Chrome and Firefox (42.37 MB, video/mp4)
2012-06-13 09:11 EDT, Justin Clift
no flags Details
Filter view from toggle - Chrome (79.85 KB, image/png)
2012-09-21 09:45 EDT, Ronelle Landy
no flags Details

  None (edit)
Description Justin Clift 2012-06-13 09:11:58 EDT
Created attachment 591491 [details]
Screencast showing the problem on both Chrome and Firefox

Description of problem:

  With upstream Conductor 0.10.0-1 rpms on Fedora 16, the pretty and filter
  view toggle buttons don't do anything.

  Tested on both Chrome (v19) and Firefox (v13).  Haven't tested other browsers.

  Screencast attached (.mp4) showing the problem. (~1:30 in length)


Version-Release number of selected component (if applicable):

  $ rpm -qa | grep -i aeolus | sort
  aeolus-all-0.10.1-1.fc16.noarch
  aeolus-conductor-0.10.1-1.fc16.noarch
  aeolus-conductor-daemons-0.10.1-1.fc16.noarch
  aeolus-conductor-devel-0.10.1-1.fc16.noarch
  aeolus-conductor-doc-0.10.1-1.fc16.noarch
  aeolus-configure-2.6.0-1.fc16.noarch
  rubygem-aeolus-cli-0.5.0-1.fc16.noarch
  rubygem-aeolus-image-0.5.0-1.fc16.noarch

How reproducible:

  Every time.

Steps to Reproduce:
1.  With 1 or more instances (regardless of state), attempt to switch between pretty view and filter view.  Doesn't work.
Comment 1 Justin Clift 2012-06-13 09:36:05 EDT
Also tested Safari.  They're not working on that either.
Comment 2 Matt Wagner 2012-06-14 16:49:49 EDT
I ACKed this and pushed it to master as 8cb9f78be18bfb01936d9eb97a01ffc6645d3328
Comment 4 Matt Wagner 2012-09-06 11:13:56 EDT
That patch is also on 1.1, with the same commit ID.
Comment 6 Ronelle Landy 2012-09-21 09:44:28 EDT
Tested rpms:

>> rpm -qa |grep aeolus
aeolus-configure-2.8.6-1.el6cf.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
rubygem-aeolus-cli-0.7.1-1.el6cf.noarch
aeolus-conductor-0.13.8-1.el6cf.noarch
aeolus-conductor-daemons-0.13.8-1.el6cf.noarch
aeolus-conductor-doc-0.13.8-1.el6cf.noarch
aeolus-all-0.13.8-1.el6cf.noarch

Used FF and Chrome on F16 to connect to the conductor installed.

The 'Pretty view' and 'Filter view' work on both these browsers to switch the user from one view  to the other. 

See attached screenshot of the User in Filter view on Chrome.
Comment 7 Ronelle Landy 2012-09-21 09:45:04 EDT
Created attachment 615439 [details]
Filter view from toggle - Chrome
Comment 9 errata-xmlrpc 2012-12-04 10:10:39 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-1516.html

Note You need to log in before you can comment on or make changes to this bug.