Bug 831644 - [ovirt-engine-core] Error parsing OVF files from 3.0 export domains
[ovirt-engine-core] Error parsing OVF files from 3.0 export domains
Status: CLOSED CURRENTRELEASE
Product: oVirt
Classification: Community
Component: ovirt-engine-core (Show other bugs)
unspecified
x86_64 Linux
urgent Severity urgent
: ---
: 3.1
Assigned To: Shahar Havivi
storage
: Regression
Depends On:
Blocks: 811587
  Show dependency treegraph
 
Reported: 2012-06-13 09:57 EDT by Kiril Nesenko
Modified: 2016-02-10 12:11 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-09 04:01:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
engine.log (596.89 KB, application/x-bzip)
2012-06-13 09:57 EDT, Kiril Nesenko
no flags Details
ovf (2.02 KB, application/x-gzip)
2012-06-17 08:40 EDT, Kiril Nesenko
no flags Details

  None (edit)
Description Kiril Nesenko 2012-06-13 09:57:59 EDT
Created attachment 591508 [details]
engine.log

Description of problem:
Can not see templates from old export domain. Seems like there is some issue with readinf ovf files.

2012-06-13 16:53:29,504 ERROR [org.ovirt.engine.core.vdsbroker.irsbroker.IrsBrokerCommand] (QuartzScheduler_Worker-38) [6ae4d035] IrsBroker::Failed::GetStoragePoolInfoVDS due to: IRSErrorException: IRSErrorException:
2012-06-13 16:53:31,939 INFO  [org.ovirt.engine.core.vdsbroker.irsbroker.GetVmsInfoVDSCommand] (ajp--0.0.0.0-8009-6) START, GetVmsInfoVDSCommand(storagePoolId = b4716a5e-b532-11e1-9228-001a4a231020, ignoreFailoverLimit = false, compatabilityVersion = null, storageDomainId = b0dc20ec-d104-4e29-ba8f-abf6df92edf0, vmIdList = null), log id: 12f00afa
2012-06-13 16:53:31,998 INFO  [org.ovirt.engine.core.vdsbroker.irsbroker.GetVmsInfoVDSCommand] (ajp--0.0.0.0-8009-6) FINISH, GetVmsInfoVDSCommand, log id: 12f00afa
2012-06-13 16:53:32,316 INFO  [org.ovirt.engine.core.vdsbroker.irsbroker.GetVmsInfoVDSCommand] (ajp--0.0.0.0-8009-5) START, GetVmsInfoVDSCommand(storagePoolId = b4716a5e-b532-11e1-9228-001a4a231020, ignoreFailoverLimit = false, compatabilityVersion = null, storageDomainId = b0dc20ec-d104-4e29-ba8f-abf6df92edf0, vmIdList = null), log id: 4d8b30a5
2012-06-13 16:53:32,391 INFO  [org.ovirt.engine.core.vdsbroker.irsbroker.GetVmsInfoVDSCommand] (ajp--0.0.0.0-8009-5) FINISH, GetVmsInfoVDSCommand, log id: 4d8b30a5
2012-06-13 16:53:37,241 INFO  [org.ovirt.engine.core.vdsbroker.irsbroker.GetVmsInfoVDSCommand] (ajp--0.0.0.0-8009-2) START, GetVmsInfoVDSCommand(storagePoolId = b4716a5e-b532-11e1-9228-001a4a231020, ignoreFailoverLimit = false, compatabilityVersion = null, storageDomainId = b0dc20ec-d104-4e29-ba8f-abf6df92edf0, vmIdList = null), log id: 5f6d259f
2012-06-13 16:53:37,294 INFO  [org.ovirt.engine.core.vdsbroker.irsbroker.GetVmsInfoVDSCommand] (ajp--0.0.0.0-8009-2) FINISH, GetVmsInfoVDSCommand, log id: 5f6d259f
2012-06-13 16:53:39,531 ERROR [org.ovirt.engine.core.vdsbroker.irsbroker.GetStoragePoolInfoVDSCommand] (QuartzScheduler_Worker-91) [646de5cc] irsBroker::BuildStorageDynamicFromXmlRpcStruct::Failed building Storage dynamic, xmlRpcStruct = org.ovirt.engine.core.vdsbroker.xmlrpc.XmlRpcStruct@3895fd97
2012-06-13 16:53:39,532 ERROR [org.ovirt.engine.core.vdsbroker.irsbroker.GetStoragePoolInfoVDSCommand] (QuartzScheduler_Worker-91) [646de5cc] org.ovirt.engine.core.vdsbroker.irsbroker.IRSErrorException: IRSErrorException:
2012-06-13 16:53:39,532 ERROR [org.ovirt.engine.core.vdsbroker.irsbroker.IrsBrokerCommand] (QuartzScheduler_Worker-91) [646de5cc] IrsBroker::Failed::GetStoragePoolInfoVDS due to: IRSErrorException: IRSErrorException:
2012-06-13 16:53:49,561 ERROR [org.ovirt.engine.core.vdsbroker.irsbroker.GetStoragePoolInfoVDSCommand] (QuartzScheduler_Worker-46) [63a3bd86] irsBroker::BuildStorageDynamicFromXmlRpcStruct::Failed building Storage dynamic, xmlRpcStruct = org.ovirt.engine.core.vdsbroker.xmlrpc.XmlRpcStruct@1219fdc8
2012-06-13 16:53:49,562 ERROR [org.ovirt.engine.core.vdsbroker.irsbroker.GetStoragePoolInfoVDSCommand] (QuartzScheduler_Worker-46) [63a3bd86] org.ovirt.engine.core.vdsbroker.irsbroker.IRSErrorException: IRSErrorException:
2012-06-13 16:53:49,562 ERROR [org.ovirt.engine.core.vdsbroker.irsbroker.IrsBrokerCommand] (QuartzScheduler_Worker-46) [63a3bd86] IrsBroker::Failed::GetStoragePoolInfoVDS due to: IRSErrorException: IRSErrorException:




Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Haim 2012-06-13 15:26:55 EDT
Kiril, what is the tested build?
Comment 2 Kiril Nesenko 2012-06-14 01:18:44 EDT
(In reply to comment #1)
> Kiril, what is the tested build?

si6 based on dd65f35351e2806896b3f163b03b527ebd6c247e
Comment 3 Andrew Cathrow 2012-06-16 15:16:49 EDT
Changing topic to make it easier to find.

symptoms Export domain appears to be empty (no Vms or templates) but event log will warn that each individual ovf is corrupt.
Comment 4 Andrew Cathrow 2012-06-16 15:22:30 EDT
Same error message

Failed to read VM 'Name' OVF, it may be corrupted
Comment 5 Shahar Havivi 2012-06-17 07:01:47 EDT
Please attach the OVF file
Comment 6 Kiril Nesenko 2012-06-17 08:40:30 EDT
Created attachment 592426 [details]
ovf
Comment 7 Shahar Havivi 2012-06-18 11:11:56 EDT
patch send at: http://gerrit.ovirt.org/#/c/5449/
Comment 9 Itamar Heim 2012-08-09 04:01:55 EDT
closing ON_QA bugs as oVirt 3.1 was released:
http://www.ovirt.org/get-ovirt/
Comment 10 Itamar Heim 2012-08-09 04:03:24 EDT
closing ON_QA bugs as oVirt 3.1 was released:
http://www.ovirt.org/get-ovirt/

Note You need to log in before you can comment on or make changes to this bug.