Bug 831686 - Invalid results from scipy.special.stdtr (but only on Fedora)
Invalid results from scipy.special.stdtr (but only on Fedora)
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: scipy (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jef Spaleta
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-13 10:54 EDT by pav
Modified: 2013-05-14 23:08 EDT (History)
4 users (show)

See Also:
Fixed In Version: scipy-0.12.0-2.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-14 23:08:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description pav 2012-06-13 10:54:15 EDT
The function `scipy.special.stdtr` produces invalid results on Fedora 17, which makes the statistical t-test in `scipy.stats` similarly produce invalid results.

See the end of your build logs for the relevant test failure (test_stats.test_ttest_ind):

http://kojipkgs.fedoraproject.org/packages/scipy/0.10.1/1.fc17/data/logs/i686/build.log

and this bug report from the user:

http://projects.scipy.org/scipy/ticket/1676

This problem seems specific to Fedora. I'm not able to reproduce it on Ubuntu 12.04 (which has gcc 4.6.3). The problematic function is `stdtr` originating from file `scipy/special/cephes/stdtr.c`.

Perhaps the gcc version in Fedora 17 miscompiles this file?
Comment 1 Orion Poplawski 2013-05-14 23:08:22 EDT
This appears to be fixed in scipy-0.12.0-2.fc18

Note You need to log in before you can comment on or make changes to this bug.