Bug 831688 - Cannot rebuild GDB on i?86 machines
Cannot rebuild GDB on i?86 machines
Status: CLOSED DUPLICATE of bug 664427
Product: Red Hat Developer Toolset
Classification: Red Hat
Component: gdb (Show other bugs)
DTS 1.0 RHEL 6
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jan Kratochvil
Petr Muller
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-13 10:55 EDT by Marek Polacek
Modified: 2016-09-19 22:09 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-13 11:01:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marek Polacek 2012-06-13 10:55:45 EDT
Here we can see that GDB depends on x86-64 packages, but those cannot be installed on i?86 machine, thus rebuild FAILs.

# rpm -qpR /mnt/redhat/brewroot/packages/devtoolset-1.0-gdb/7.4.50.20120120/46.el6/data/signed/fd431d51/src/devtoolset-1.0-gdb-7.4.50.20120120-46.el6.src.rpm
scl-utils-build  
ncurses-devel(x86-64)  
texinfo  
gettext  
flex  
bison  
expat-devel(x86-64)  
rpm-devel(x86-64)  
zlib-devel(x86-64)  
libselinux-devel(x86-64)  
python-devel(x86-64)  
libstdc++(x86-64)  
texinfo-tex  
rpmlib(FileDigests) <= 4.6.0-1
rpmlib(CompressedFileNames) <= 3.0.4-1

It looks like there's nothing wrong with .spec file.  The problem seems to be that this package was build on x86_64 machine.

# rpm -qpi /mnt/redhat/brewroot/packages/devtoolset-1.0-gdb/7.4.50.20120120/46.el6/data/signed/fd431d51/src/devtoolset-1.0-gdb-7.4.50.20120120-46.el6.src.rpm
Name        : devtoolset-1.0-gdb           Relocations: (not relocatable)
Version     : 7.4.50.20120120                   Vendor: Red Hat, Inc.
Release     : 46.el6                        Build Date: Mon 14 May 2012 12:27:54 PM EDT
Install Date: (not installed)               Build Host: x86-012.build.bos.redhat.com
Group       : Development/Debuggers         Source RPM: (none)
Size        : 23560664                         License: GPLv3+ and GPLv3+ with exceptions and GPLv2+ and GPLv2+ with exceptions and GPL+ and LGPLv2+ and BSD and Public Domain
Signature   : RSA/8, Thu 07 Jun 2012 02:54:17 PM EDT, Key ID 199e2f91fd431d51
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
URL         : http://gnu.org/software/gdb/
Summary     : A GNU source-level debugger for C, C++, Fortran and other languages
Description :
GDB, the GNU debugger, allows you to debug programs written in C, C++,
Java, and other languages, by executing them in a controlled fashion
and printing their data.
Comment 2 Jan Kratochvil 2012-06-13 11:01:22 EDT

*** This bug has been marked as a duplicate of bug 664427 ***

Note You need to log in before you can comment on or make changes to this bug.