Bug 831693 - (EE) Failed to load module "intel" (module requirement mismatch, 0)
(EE) Failed to load module "intel" (module requirement mismatch, 0)
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel (Show other bugs)
17
Unspecified Linux
unspecified Severity high
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
: 831694 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-13 11:05 EDT by Mikael Ohlsson
Modified: 2012-06-18 12:06 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-18 12:06:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mikael Ohlsson 2012-06-13 11:05:54 EDT
Description of problem:
Cant use the intel driver with x11. 


Version-Release number of selected component (if applicable):
xorg-x11-drv-intel-2.19.0-1.fc17.i686

How reproducible:
start x

Steps to Reproduce:
1. start x
2.
3.
  
Actual results:
Vesa driver is loaded

Expected results:
intel driver loaded

Additional info:
My graphic card is:
VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03)

Have tried to run it with ignore the ABI checks with no result.

Here is the part from the log:
[    31.348] (II) LoadModule: "intel"
[    31.348] (II) Loading /usr/lib/xorg/modules/drivers/intel_drv.so
[    31.348] (II) Module intel: vendor="X.Org Foundation"
[    31.348] 	compiled for 1.11.4, module version = 2.19.0
[    31.348] 	Module class: X.Org Video Driver
[    31.348] 	ABI class: X.Org Video Driver, version 11.0
[    31.348] (EE) module ABI major version (11) doesn't match the server's ve
rsion (12)
[    31.349] (II) UnloadModule: "intel"
[    31.349] (II) Unloading intel
Comment 1 bschofield 2012-06-16 04:26:12 EDT
I experience the same issue on a Lenovo E520 with "Intel HD Graphics".

I end up with "fbdevhw" as an eventual fall-back, which is acceptable but gives me a flickering mouse pointer.

Seems like a pretty severe issue if everyone with Intel graphics is getting a poor experience on FC17?

[    32.278] (II) LoadModule: "intel"
[    32.278] (II) Loading /usr/lib64/xorg/modules/drivers/intel_drv.so
[    32.341] (II) Module intel: vendor="X.Org Foundation"
[    32.341]    compiled for 1.11.4, module version = 2.19.0
[    32.341]    Module class: X.Org Video Driver
[    32.341]    ABI class: X.Org Video Driver, version 11.0
[    32.341] (EE) module ABI major version (11) doesn't match the server's version (12)
[    32.341] (II) UnloadModule: "intel"
[    32.341] (II) Unloading intel
[    32.341] (EE) Failed to load module "intel" (module requirement mismatch, 0)
[    32.341] (II) LoadModule: "vesa"
[    32.341] (II) Loading /usr/lib64/xorg/modules/drivers/vesa_drv.so
[    32.361] (II) Module vesa: vendor="X.Org Foundation"
[    32.361]    compiled for 1.11.99.901, module version = 2.3.0
[    32.361]    Module class: X.Org Video Driver
[    32.361]    ABI class: X.Org Video Driver, version 12.0
[    32.361] (II) LoadModule: "fbdev"
[    32.361] (II) Loading /usr/lib64/xorg/modules/drivers/fbdev_drv.so
[    32.383] (II) Module fbdev: vendor="X.Org Foundation"
[    32.383]    compiled for 1.11.99.901, module version = 0.4.2
[    32.383]    ABI class: X.Org Video Driver, version 12.0
[    32.383] (II) VESA: driver for VESA chipsets: vesa
[    32.383] (II) FBDEV: driver for framebuffer: fbdev
[    32.383] (++) using VT number 1

[    32.385] vesa: Ignoring device with a bound kernel driver
[    32.385] (WW) Falling back to old probe method for vesa
[    32.385] (II) Loading sub module "fbdevhw"
[    32.385] (II) LoadModule: "fbdevhw"
[    32.385] (II) Loading /usr/lib64/xorg/modules/libfbdevhw.so
[    32.817] (II) Module fbdevhw: vendor="X.Org Foundation"
[    32.817]    compiled for 1.12.0, module version = 0.0.2
[    32.817]    ABI class: X.Org Video Driver, version 12.0
[    32.818] (**) FBDEV(1): claimed PCI slot 0@0:2:0
Comment 2 bschofield 2012-06-16 04:55:14 EDT
If relevant: setting IgnoreABI causes a segfault, kernel driver in use is i915, I upgraded from FC16 using preupgrade.
Comment 3 Mikael Ohlsson 2012-06-16 06:21:01 EDT
Solved the problem and it was quite a weird solution.

When I checked the version with yum it seemed to be the correct version. But when I tried to do an yum reinstall it told me that it tried to download an older version and it could not find it. 

So my solution was uninstall the driver and then install it again. So the bug should actually read wrong version shows up in yum.
Comment 4 bschofield 2012-06-16 08:07:08 EDT
Thanks very much! Turned out I had exactly the same problem, the fc16 package was still installed and yum would not upgrade it. A manual erase and install fixed it for me too.

In fact, doing rpm -qa | fgrep fc16 revealed a couple of other packages in the same state (notably mdadm). So maybe this is an issue with preupgrade.
Comment 5 Adam Jackson 2012-06-18 12:05:51 EDT
*** Bug 831694 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.