Bug 831724 - Error when installing gems using JRuby 1.6.7.2 on Solaris
Error when installing gems using JRuby 1.6.7.2 on Solaris
Status: CLOSED CANTFIX
Product: JBoss Enterprise WFK Platform 2
Classification: JBoss
Component: TorqueBox, doc-Release-Notes (Show other bugs)
2.0.0.ER7,2.1.0
Unspecified Solaris
urgent Severity urgent
: ---
: 2.2.0
Assigned To: Ben Browning
Karel Piwko
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-13 12:09 EDT by Oliver Kišš
Modified: 2015-08-02 19:42 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
TorqueBox is not supported on Solaris due to JRuby upstream bug http://jira.codehaus.org/browse/JRUBY-6494.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-25 05:37:25 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Oliver Kišš 2012-06-13 12:09:48 EDT
Description of problem:
Installing gems using JRuby 1.6.7.2 on Solaris does not work. This is caused by JRUBY-6494.


Additional info:
http://jira.codehaus.org/browse/JRUBY-6494
Comment 2 Karel Piwko 2012-06-14 08:17:52 EDT
Adding blocker? flag to discuss range of supported platforms for TorqueBox.
Comment 4 Burr Sutter 2012-06-15 07:43:31 EDT
Not a blocker due to TP status
Comment 5 mark yarborough 2012-06-18 11:20:03 EDT
Per PM call, document TorqueBox Tech Preview supported platforms in release notes. This will be adequate for WFK 2.0.
Comment 6 Karel Piwko 2012-06-20 11:08:57 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
TorqueBox is not supported on Solaris due to JRuby upstream bug http://jira.codehaus.org/browse/JRUBY-6494.
Comment 12 mark yarborough 2012-11-05 10:09:02 EST
Known issue (not supported)
Comment 13 rfalhar 2012-11-08 02:09:58 EST
There still seems to be problems.
I tested it with JRuby 1.6.7.2 and JRuby 1.7.0.0 in both Ruby 1.8 and 1.9 mode.
I'm not sure if it is still related to the upstream bug or if it is something else.

The problem right now is that torquebox_eap_overlay script fails in copy_modules method. The resulting exceptions are different for 1.6 and 1.7.
Comment 14 rfalhar 2012-11-08 03:11:48 EST
1.6.7.2 still doesn't work with upstream bug.

01:58:13  RuntimeError: unknown file type: /mnt/hudson_workspace/workspace/wfk-2.1-torquebox/48a3a978/jboss-wfk-2.1.0.ER2/torquebox-2.1.2.redhat.1/modules
01:58:13                 copy at /mnt/hudson_workspace/workspace/wfk-2.1-torquebox/48a3a978/wfk-qa/build/configuration/../../../jboss-wfk-2.1.0.ER2/jruby-1.6.7.2/lib/ruby/1.8/fileutils.rb:1262
01:58:13           copy_entry at /mnt/hudson_workspace/workspace/wfk-2.1-torquebox/48a3a978/wfk-qa/build/configuration/../../../jboss-wfk-2.1.0.ER2/jruby-1.6.7.2/lib/ruby/1.8/fileutils.rb:452
01:58:13    preorder_traverse at /mnt/hudson_workspace/workspace/wfk-2.1-torquebox/48a3a978/wfk-qa/build/configuration/../../../jboss-wfk-2.1.0.ER2/jruby-1.6.7.2/lib/ruby/1.8/fileutils.rb:1331
01:58:13           copy_entry at /mnt/hudson_workspace/workspace/wfk-2.1-torquebox/48a3a978/wfk-qa/build/configuration/../../../jboss-wfk-2.1.0.ER2/jruby-1.6.7.2/lib/ruby/1.8/fileutils.rb:449
01:58:13                 cp_r at /mnt/hudson_workspace/workspace/wfk-2.1-torquebox/48a3a978/wfk-qa/build/configuration/../../../jboss-wfk-2.1.0.ER2/jruby-1.6.7.2/lib/ruby/1.8/fileutils.rb:424
01:58:13     fu_each_src_dest at /mnt/hudson_workspace/workspace/wfk-2.1-torquebox/48a3a978/wfk-qa/build/configuration/../../../jboss-wfk-2.1.0.ER2/jruby-1.6.7.2/lib/ruby/1.8/fileutils.rb:1402
01:58:13    fu_each_src_dest0 at /mnt/hudson_workspace/workspace/wfk-2.1-torquebox/48a3a978/wfk-qa/build/configuration/../../../jboss-wfk-2.1.0.ER2/jruby-1.6.7.2/lib/ruby/1.8/fileutils.rb:1418
01:58:13     fu_each_src_dest at /mnt/hudson_workspace/workspace/wfk-2.1-torquebox/48a3a978/wfk-qa/build/configuration/../../../jboss-wfk-2.1.0.ER2/jruby-1.6.7.2/lib/ruby/1.8/fileutils.rb:1400
01:58:13                 cp_r at /mnt/hudson_workspace/workspace/wfk-2.1-torquebox/48a3a978/wfk-qa/build/configuration/../../../jboss-wfk-2.1.0.ER2/jruby-1.6.7.2/lib/ruby/1.8/fileutils.rb:423
01:58:13         copy_modules at /mnt/hudson_workspace/workspace/wfk-2.1-torquebox/48a3a978/wfk-qa/build/configuration/../../../jboss-wfk-2.1.0.ER2/torquebox-2.1.2.redhat.1/torquebox_eap_overlay.rb:34
01:58:13              overlay at /mnt/hudson_workspace/workspace/wfk-2.1-torquebox/48a3a978/wfk-qa/build/configuration/../../../jboss-wfk-2.1.0.ER2/torquebox-2.1.2.redhat.1/torquebox_eap_overlay.rb:28
01:58:13               (root) at /mnt/hudson_workspace/workspace/wfk-2.1-torquebox/48a3a978/wfk-qa/build/configuration/../../../jboss-wfk-2.1.0.ER2/torquebox-2.1.2.redhat.1/torquebox_eap_overlay.rb:196

1.7.0.0 seems to be fixed, but has different bug.
https://bugzilla.redhat.com/show_bug.cgi?id=874439
Comment 17 Karel Piwko 2013-02-25 05:37:25 EST
Closing as CANTFIX. TorqueBox delivered with WFK 2.2.0 does not support JRuby 1.6.

Note You need to log in before you can comment on or make changes to this bug.