Bug 831774 - Inserting DOD CAC smartcard generates error dialog
Inserting DOD CAC smartcard generates error dialog
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: esc (Show other bugs)
17
i686 Linux
unspecified Severity high
: ---
: ---
Assigned To: Jack Magne
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-13 14:28 EDT by John Wendel
Modified: 2012-07-02 12:40 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-02 12:40:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Wendel 2012-06-13 14:28:36 EDT
Description of problem:

Error message on inserting smartcard

Can't get UniversalXPConnect.TypeError: Components.classes['@redhat.com/rhCoolKey;1'] is undefined

Version-Release number of selected component (if applicable):

?

How reproducible:

Every time

Steps to Reproduce:
1.Insert DOD CAC smartcard
2.
3.
  
Actual results:

Error dialog

Expected results:

Smart card available

Additional info:

F16 had this same error until it was corrected by an update. I don't know which component fixed the problem.
Comment 1 John Wendel 2012-06-13 19:48:01 EDT
pklogin_finder works correctly

Firefox works correctly

Smartcard manager fails to see the card.
Comment 2 Kalev Lember 2012-06-14 05:16:46 EDT
Hi John,

Thanks for the report, but I believe it's not an issue with pcsc-lite, but with some other component. Do you know what rpm has the "smartcard manager" you mentioned?

Reassigning to esc which is hopefully the correct component.
Comment 3 Jack Magne 2012-06-14 13:00:44 EDT
Thanks:

This is the correct component.
Comment 4 John Wendel 2012-06-28 19:01:00 EDT
smart card manager is now working, I think there was an update that included "esc"

Using the card for login authenication doesn't seem to do anything, I still need to supply a password to gdm.
Comment 5 John Wendel 2012-06-29 17:55:42 EDT
smart card login works in runlevel 3, not working with gdm.
Comment 6 John Wendel 2012-07-02 12:40:45 EDT
My original complaint has been resolved. I'll open a new bug on gdm, since it doesn't support smart card login.

Note You need to log in before you can comment on or make changes to this bug.