Bug 831854 - User reported a problem: Cannot install XML::Parser on Perl app due to unresolved dependency on expat-devel package
User reported a problem: Cannot install XML::Parser on Perl app due to unres...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Rob Millner
libra bugs
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-13 18:26 EDT by Nam Duong
Modified: 2015-05-14 18:55 EDT (History)
5 users (show)

See Also:
Fixed In Version: cartridge-perl-5.10-0.25.1-1+
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-25 14:27:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nam Duong 2012-06-13 18:26:35 EDT
Description of problem:
See https://openshift.redhat.com/community/forums/openshift/cannot-install-xmlparser-from-cpan

User cannot deploy perl application due to a missing dependency.  XML::Parser requires expat-devel to be installed in production.
Comment 1 Rob Millner 2012-06-13 21:21:50 EDT
Crankcase commit 650f8328 adds expat-devel as a requirement for the PERL cartridge.
Comment 2 Xiaoli Tian 2012-06-14 04:52:49 EDT
The change has not been in the latest build now (devenv_1843), wait for next build to test.
Comment 3 Xiaoli Tian 2012-06-20 05:53:25 EDT
Verified it on devenv_1859, add XML::Parser to deplist.txt

[root@ip-10-70-73-135 functional]# rpm -qa|grep expat-devel
expat-devel-2.0.1-11.el6_2.x86_64

XML::Parser is installed successfully:

Writing objects: 100% (3/3), 254 bytes, done.
Total 3 (delta 1), reused 0 (delta 0)
remote: Stopping application...
remote: Done
remote: ~/git/perapp1.git ~/git/perapp1.git
remote: ~/git/perapp1.git
remote: Running .openshift/action_hooks/pre_build
remote: --> Working on XML::Parser
remote: Fetching http://mirror1.stg.rhcloud.com/mirror/perl/CPAN/authors/id/T/TO/TODDR/XML-Parser-2.41.tar.gz ... OK
remote: Configuring XML-Parser-2.41 ... OK
remote: Building XML-Parser-2.41 ... OK
remote: Successfully installed XML-Parser-2.41
remote: 1 distribution installed
remote: Running .openshift/action_hooks/build
remote: Running .openshift/action_hooks/deploy
remote: Starting application...
remote: Done
remote: Running .openshift/action_hooks/post_deploy
To ssh://ab1f42cbfb32472eb925c7a359fe4240@perapp1-domainbill007.dev.rhcloud.com/~/git/perapp1.git/
   41eb895..b40a7ef  master -> master

Note You need to log in before you can comment on or make changes to this bug.