Bug 831867 - rhevm-setup should allow connecting to remote Postgresql database
rhevm-setup should allow connecting to remote Postgresql database
Status: CLOSED DUPLICATE of bug 799710
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: RFEs (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Miki Kenneth
Yaniv Kaul
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-13 20:34 EDT by Grzegorz Wojcieszczuk
Modified: 2015-09-22 09 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-14 09:20:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Grzegorz Wojcieszczuk 2012-06-13 20:34:55 EDT
Description of problem:

rhevm-setup tool doesn't allow to connect to external PostgreSQL database.
Manaul modification of jboss-related files are necessary to achieve that goal.


Version-Release number of selected component (if applicable):

All.

How reproducible:

Run:

# rhevm-setup

Steps to Reproduce:
1.
2.
3.
  
Actual results:

PostgreSQL database used for RHEVM gets installed locally.
There's manual work required to connect it to remote db.

Expected results:

It would be very useful if rhevm-setup had few additional options that would allow specifying remote database IP and database credentials.
Ideally rhevm-setup installer should look after creating database schema on remote DB and also purging (upon user confirmation) existing DB tables, if the same DB is being reused for the second time for RHEVM.

Additional info:
Comment 1 Yaniv Kaul 2012-06-14 07:27:34 EDT
Duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=799710 ?
Comment 2 Itamar Heim 2012-06-14 09:20:50 EDT
planned for 3.1
dup of Bug 799710 - support installation using a remote postgres server

*** This bug has been marked as a duplicate of bug 799710 ***

Note You need to log in before you can comment on or make changes to this bug.