Bug 831885 - SELinux is preventing smbd from 'create' accesses on the file test.file.
SELinux is preventing smbd from 'create' accesses on the file test.file.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
17
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:68cde19dea1d894cb070301cbaa...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-13 22:22 EDT by Raj Upadhyaya
Modified: 2012-06-14 14:59 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-14 14:59:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Raj Upadhyaya 2012-06-13 22:22:27 EDT
libreport version: 2.0.10
executable:     /usr/bin/python2.7
hashmarkername: setroubleshoot
kernel:         3.4.0-1.fc17.i686
time:           Wed 13 Jun 2012 09:21:57 PM CDT

description:
:SELinux is preventing smbd from 'create' accesses on the file test.file.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that smbd should be allowed create access on the test.file file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep smbd /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:smbd_t:s0
:Target Context                system_u:object_r:home_root_t:s0
:Target Objects                test.file [ file ]
:Source                        smbd
:Source Path                   smbd
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-128.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.4.0-1.fc17.i686 #1 SMP Sun Jun 3
:                              07:16:04 UTC 2012 i686 i686
:Alert Count                   1
:First Seen                    Wed 13 Jun 2012 07:21:39 PM CDT
:Last Seen                     Wed 13 Jun 2012 07:21:39 PM CDT
:Local ID                      f3652b8c-5af3-4262-a0cd-28a798b54517
:
:Raw Audit Messages
:type=AVC msg=audit(1339633299.310:971): avc:  denied  { create } for  pid=29502 comm="smbd" name="test.file" scontext=system_u:system_r:smbd_t:s0 tcontext=system_u:object_r:home_root_t:s0 tclass=file
:
:
:Hash: smbd,smbd_t,home_root_t,file,create
:
:audit2allowunable to open /sys/fs/selinux/policy:  Permission denied
:
:
:audit2allow -Runable to open /sys/fs/selinux/policy:  Permission denied
:
:
Comment 1 Daniel Walsh 2012-06-14 14:59:42 EDT
This looks like you have a mislabeled homedir.

restorecon -R -v /home

Where is test.file being created.

Note You need to log in before you can comment on or make changes to this bug.