Bug 831905 - Cannot push to prod server with 0.24.7
Cannot push to prod server with 0.24.7
Status: CLOSED CURRENTRELEASE
Product: PressGang CCMS
Classification: Community
Component: CSProcessor (Show other bugs)
1.x
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Lee Newson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-13 23:29 EDT by Joshua Wulf
Modified: 2014-10-19 19:00 EDT (History)
3 users (show)

See Also:
Fixed In Version: 0.24.8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-05 20:05:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joshua Wulf 2012-06-13 23:29:19 EDT
cspclient-0.24.7-1.noarch
OS: Fedora release 15 (Lovelock)

JAVA: java version "1.7.0"
Java(TM) SE Runtime Environment (build 1.7.0-b147)
Java HotSpot(TM) Client VM (build 21.0-b17, mixed mode, sharing)


[jwulf@radhe Messaging_Programming_Reference]$ csprocessor push
CSProcessor client version: 0.24.7
Loading configuration from /home/jwulf/.config/csprocessor.ini
Loading project configuration from csprocessor.cfg
Connecting to Skynet server: http://skynet.usersys.redhat.com:8080/TopicIndex/

INFO:  The Content Specification is valid.
ERROR: An error occurred during processing please try again.



[jwulf@radhe Messaging_Programming_Reference]$ cat csprocessor.cfg 
# SPEC_TITLE=Messaging_Programming_Reference
SPEC_ID=8025
SERVER_URL=http://skynet.usersys.redhat.com:8080/TopicIndex/
Comment 1 Joshua Wulf 2012-06-13 23:36:22 EDT
No error thrown in the server log.

It does this consistently with two different specs that I've checked out locally: 8025 and 7069 (3-4 attempts each)
Comment 2 Joshua Wulf 2012-06-13 23:37:59 EDT
[jwulf@radhe Messaging_Programming_Reference]$ csprocessor info
CSProcessor client version: 0.24.7
Loading configuration from /home/jwulf/.config/csprocessor.ini
Loading project configuration from csprocessor.cfg
Connecting to Skynet server: http://skynet.usersys.redhat.com:8080/TopicIndex/

Content Specification ID: 8025
Content Specification Revision: 140349
Content Specification Title: Messaging Programming Reference
Comment 3 Lee Newson 2012-06-13 23:41:20 EDT
This comment is just for reference, for when I get to look at this properly. There are no errors that exist in the Skynet server logs.
Comment 4 Lee Newson 2012-06-15 02:46:39 EDT
Fixed. As I told josh yesterday I'll have to move this back down the commits to be able to fix it properly, so I'll change this to ON_QA and put a version number up once that happens.

Cause:

The clone function was trying to clone a null object in the CommonUtilities class, as such a NPE was thrown.

Consequence:

Topics couldn't be cloned to be updated and as such the push would fail.

Fix:

Add a check to see if the category tags is null before cloning. This should be fixed for all REST entities.
Comment 5 Lee Newson 2012-06-15 02:57:34 EDT
Just to add, as a reference why everyone else I talked to didn't have any issues, appears to be because they weren't adding tags to existing topics through global tags like Josh's two examples.
Comment 6 Lee Newson 2012-06-18 22:15:26 EDT
Released in version 0.24.8.
Comment 7 Joshua Wulf 2012-06-20 08:52:43 EDT
Verified with 0.24.8

Note You need to log in before you can comment on or make changes to this bug.