Bug 832102 - Seam2.3 seam-gen generated EAR project fails to deploy for missing jboss-deployment-structure.xml in the EAR
Seam2.3 seam-gen generated EAR project fails to deploy for missing jboss-depl...
Status: CLOSED DEFERRED
Product: JBoss Enterprise WFK Platform 2
Classification: JBoss
Component: Seam (Show other bugs)
2.0.0.ER8
Unspecified Unspecified
medium Severity high
: ---
: ---
Assigned To: Marek Novotny
Marek Schmidt
Seam2.3
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-14 10:05 EDT by Marek Schmidt
Modified: 2012-06-22 04:16 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-19 04:18:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marek Schmidt 2012-06-14 10:05:17 EDT
Description of problem:

Seam2.3 seam-gen generated EAR project fails to deploy with:

Caused by: java.lang.ClassNotFoundException: javax.faces.convert.DateTimeConverter from [Module "deployment.myproject.ear.jboss-seam.jar:main" from Service Module Loader]
        at org.jboss.modules.ModuleClassLoader.findClass(ModuleClassLoader.java:190)
        at org.jboss.modules.ConcurrentClassLoader.performLoadClassUnchecked(ConcurrentClassLoader.java:468)
        at org.jboss.modules.ConcurrentClassLoader.performLoadClassChecked(ConcurrentClassLoader.java:456)
        at org.jboss.modules.ConcurrentClassLoader.performLoadClassChecked(ConcurrentClassLoader.java:423)
        at org.jboss.modules.ConcurrentClassLoader.performLoadClass(ConcurrentClassLoader.java:398)
        at org.jboss.modules.ConcurrentClassLoader.loadClass(ConcurrentClassLoader.java:120)
        ... 36 more



The problem seems to be that it doesn't contain the proper jboss-deployment-structure.xml defining the required modules dependencies. (it does have one in the contained .war, but those are ignored in an EAR deployment).
Comment 1 Burr Sutter 2012-06-15 08:21:53 EDT
Release note it, WARs work

Note You need to log in before you can comment on or make changes to this bug.