Bug 832111 - some multiline strings extracted into string catalog incorrectly
some multiline strings extracted into string catalog incorrectly
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.9
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Adrian Likins
Entitlement Bugs
: Translation
Depends On: 820743
Blocks: 771748
  Show dependency treegraph
 
Reported: 2012-06-14 10:36 EDT by Alex Wood
Modified: 2013-01-07 22:54 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 820743
Environment:
Last Closed: 2013-01-07 22:54:57 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 3 John Sefler 2012-08-24 14:01:54 EDT
Verifying Version....

[root@jsefler-rhel59 ~]# rpm -q subscription-manager
subscription-manager-1.0.14-1.el5


I will re-verify that the msgid fixes from rhel63 are still present in rhel59...

_____________________________________________________________
CASE 1: "An error occurred while importing the certificate."

 [root@jsefler-rhel59 ~]# for f in `rpm -ql subscription-manager | grep rhsm.mo`; do echo ""; echo "$f"; msgunfmt --no-wrap $f | grep "An error occurred while importing the certificate." -A1; done;

/usr/share/locale/as/LC_MESSAGES/rhsm.mo
msgid "An error occurred while importing the certificate. Please check log file for more information."
msgstr "প্ৰমাণপত্ৰ ইমপোৰ্ট কৰোতে এটা ত্ৰুটি দেখা দিলে। অধিক তথ্যৰ বাবে অনুগ্ৰহ কৰি লগ নথিপত্ৰ নীৰিক্ষণ কৰক।"

/usr/share/locale/bn_IN/LC_MESSAGES/rhsm.mo
msgid "An error occurred while importing the certificate. Please check log file for more information."
msgstr "সার্টিফিকেটটি ইম্পোর্ট করতে সমস্যা দেখা দিয়েছে। অধিক বিবরণের জন্য অনুগ্রহ করে লগ ফাইল পরীক্ষা করুন।"

/usr/share/locale/de_DE/LC_MESSAGES/rhsm.mo
msgid "An error occurred while importing the certificate. Please check log file for more information."
msgstr "Beim Importieren des Zertifikats trat ein Fehler auf. Bitte werfen Sie einen Blick auf die Protokolldatei für weitere Informationen."

/usr/share/locale/es_ES/LC_MESSAGES/rhsm.mo
msgid "An error occurred while importing the certificate. Please check log file for more information."
msgstr "Error al importar el siguiente certificado. Por favor revise el archivo de registro para obtener mayor información."

/usr/share/locale/fr/LC_MESSAGES/rhsm.mo
msgid "An error occurred while importing the certificate. Please check log file for more information."
msgstr "Une erreur s'est produite lors de l'importation du certificat. Veuillez vérifier le fichier journal pour obtenir plus d'informations."

/usr/share/locale/gu/LC_MESSAGES/rhsm.mo
msgid "An error occurred while importing the certificate. Please check log file for more information."
msgstr "ભૂલ ઉદ્ભવી જ્યારે પ્રમાણપત્રને આયાત કરી રહ્યા હોય. મહેરબાની કરીને વધારે જાણકારી માટે લૉગ જુઓ."

/usr/share/locale/hi/LC_MESSAGES/rhsm.mo
msgid "An error occurred while importing the certificate. Please check log file for more information."
msgstr "प्रमाणपत्र आयात करने के लिए दौरान त्रुटि आयी. अधिक जानकारी के लिए कृपया लॉग चेक करें."

/usr/share/locale/it/LC_MESSAGES/rhsm.mo
msgid "An error occurred while importing the certificate. Please check log file for more information."
msgstr "Si è verificato un errore durante l'importazione del certificato. Controllare il file di log per maggiori informazioni."

/usr/share/locale/ja/LC_MESSAGES/rhsm.mo
msgid "An error occurred while importing the certificate. Please check log file for more information."
msgstr "証明書のインポート中にエラーが発生しました。詳細についてはログファイルをチェックして下さい。"

/usr/share/locale/kn/LC_MESSAGES/rhsm.mo
msgid "An error occurred while importing the certificate. Please check log file for more information."
msgstr "ಪ್ರಮಾಣಪತ್ರಗಳನ್ನು ಆಮದು ಮಾಡಿಕೊಳ್ಳುವಾಗ ಒಂದು ದೋಷವು ಎದುರಾಗಿದೆ. ಹೆಚ್ಚಿನ ಮಾಹಿತಿಗಾಗಿ ದಾಖಲೆ ಕಡತವನ್ನು ನೋಡಿ."

/usr/share/locale/ko/LC_MESSAGES/rhsm.mo
msgid "An error occurred while importing the certificate. Please check log file for more information."
msgstr "인증서를 가져오기하는 동안 오류가 발생했습니다. 자세한 내용은 로그 파일에서 확인하십시오."

/usr/share/locale/ml/LC_MESSAGES/rhsm.mo
msgid "An error occurred while importing the certificate. Please check log file for more information."
msgstr "സര്‍ട്ടിഫിക്കേറ്റ് ഇംപോര്‍ട്ട് ചെയ്യുന്നതില്‍ പിശക്. കൂടുതല്‍ വിവരങ്ങള്‍ക്കായി ലോഗ് ഫയല്‍ പരിശോധിയ്ക്കുക."

/usr/share/locale/mr/LC_MESSAGES/rhsm.mo
msgid "An error occurred while importing the certificate. Please check log file for more information."
msgstr "प्रमाणपत्र आयात करतेवेळी त्रुटी आढळली. कृपया अधिक माहितीकरीता लॉग फाइल तपासा."

/usr/share/locale/or/LC_MESSAGES/rhsm.mo
msgid "An error occurred while importing the certificate. Please check log file for more information."
msgstr "ପ୍ରମାଣପତ୍ରଗୁଡ଼ିକୁ ଆମଦାନୀ କରିବା ସମୟରେ ଗୋଟିଏ ତ୍ରୁଟି ଘଟିଛି। ଅଧିକ ସୂଚନା ପାଇଁ ଦୟାକରି ଲଗ ଫାଇଲ ଦେଖନ୍ତୁ।"

/usr/share/locale/pa/LC_MESSAGES/rhsm.mo
msgid "An error occurred while importing the certificate. Please check log file for more information."
msgstr "ਸਾਰਟੀਫਿਕੇਟ ਇੰਪੋਰਟ ਕਰਨ ਵੇਲੇ ਇੱਕ ਗਲਤੀ ਆਈ ਹੈ। ਵਧੇਰੇ ਜਾਣਕਾਰੀ ਲਈ ਲਾਗ ਫਾਇਲ ਵੇਖੋ।"

/usr/share/locale/pt_BR/LC_MESSAGES/rhsm.mo
msgid "An error occurred while importing the certificate. Please check log file for more information."
msgstr "Ocorreu um erro ao importar o certificado. Por favor, verifique o arquivo de log para mais informações."

/usr/share/locale/ru/LC_MESSAGES/rhsm.mo
msgid "An error occurred while importing the certificate. Please check log file for more information."
msgstr "Ошибка импорта сертификата. Подробную информацию можно найти в журнале."

/usr/share/locale/ta_IN/LC_MESSAGES/rhsm.mo
msgid "An error occurred while importing the certificate. Please check log file for more information."
msgstr "சான்றிதழை இறக்குமதி செய்யும்போது ஒரு பிழை ஏற்பட்டது. மேலும் தகவலுக்கு பதிவுக் கோப்பைப் பார்க்கவும்."

/usr/share/locale/te/LC_MESSAGES/rhsm.mo
msgid "An error occurred while importing the certificate. Please check log file for more information."
msgstr "ధృవీకరణపత్రమును దిగుమతి చేయునప్పుడు వొక దోషము యెదురైంది. మరింత సమాచారం కొరకు లాగ్ ఫైలు పరిశీలించు."

/usr/share/locale/zh_CN/LC_MESSAGES/rhsm.mo
msgid "An error occurred while importing the certificate. Please check log file for more information."
msgstr "导入该证书时出错。详情请检查日志文件。"

/usr/share/locale/zh_TW/LC_MESSAGES/rhsm.mo
msgid "An error occurred while importing the certificate. Please check log file for more information."
msgstr "匯入憑證時發生了一項錯誤。請檢查日誌檔案以取得更多資訊。"

^^^^ VERIFIED: The original multi-line string that was getting truncated during the string extraction has been fixed and the new (original length string) has been successfully translated in all languages.

_____________________________________________________________
CASE 2: "An error occurred while importing the certificate."

[root@jsefler-rhel59 ~]# for f in `rpm -ql subscription-manager | grep rhsm.mo`; do echo ""; echo "$f"; msgunfmt --no-wrap $f | grep "An error occurred while importing the certificate." -A1; done;

/usr/share/locale/as/LC_MESSAGES/rhsm.mo
msgid "An error occurred while importing the certificate. Please check log file for more information."
msgstr "প্ৰমাণপত্ৰ ইমপোৰ্ট কৰোতে এটা ত্ৰুটি দেখা দিলে। অধিক তথ্যৰ বাবে অনুগ্ৰহ কৰি লগ নথিপত্ৰ নীৰিক্ষণ কৰক।"

/usr/share/locale/bn_IN/LC_MESSAGES/rhsm.mo
msgid "An error occurred while importing the certificate. Please check log file for more information."
msgstr "সার্টিফিকেটটি ইম্পোর্ট করতে সমস্যা দেখা দিয়েছে। অধিক বিবরণের জন্য অনুগ্রহ করে লগ ফাইল পরীক্ষা করুন।"

/usr/share/locale/de_DE/LC_MESSAGES/rhsm.mo
msgid "An error occurred while importing the certificate. Please check log file for more information."
msgstr "Beim Importieren des Zertifikats trat ein Fehler auf. Bitte werfen Sie einen Blick auf die Protokolldatei für weitere Informationen."

/usr/share/locale/es_ES/LC_MESSAGES/rhsm.mo
msgid "An error occurred while importing the certificate. Please check log file for more information."
msgstr "Error al importar el siguiente certificado. Por favor revise el archivo de registro para obtener mayor información."

/usr/share/locale/fr/LC_MESSAGES/rhsm.mo
msgid "An error occurred while importing the certificate. Please check log file for more information."
msgstr "Une erreur s'est produite lors de l'importation du certificat. Veuillez vérifier le fichier journal pour obtenir plus d'informations."

/usr/share/locale/gu/LC_MESSAGES/rhsm.mo
msgid "An error occurred while importing the certificate. Please check log file for more information."
msgstr "ભૂલ ઉદ્ભવી જ્યારે પ્રમાણપત્રને આયાત કરી રહ્યા હોય. મહેરબાની કરીને વધારે જાણકારી માટે લૉગ જુઓ."

/usr/share/locale/hi/LC_MESSAGES/rhsm.mo
msgid "An error occurred while importing the certificate. Please check log file for more information."
msgstr "प्रमाणपत्र आयात करने के लिए दौरान त्रुटि आयी. अधिक जानकारी के लिए कृपया लॉग चेक करें."

/usr/share/locale/it/LC_MESSAGES/rhsm.mo
msgid "An error occurred while importing the certificate. Please check log file for more information."
msgstr "Si è verificato un errore durante l'importazione del certificato. Controllare il file di log per maggiori informazioni."

/usr/share/locale/ja/LC_MESSAGES/rhsm.mo
msgid "An error occurred while importing the certificate. Please check log file for more information."
msgstr "証明書のインポート中にエラーが発生しました。詳細についてはログファイルをチェックして下さい。"

/usr/share/locale/kn/LC_MESSAGES/rhsm.mo
msgid "An error occurred while importing the certificate. Please check log file for more information."
msgstr "ಪ್ರಮಾಣಪತ್ರಗಳನ್ನು ಆಮದು ಮಾಡಿಕೊಳ್ಳುವಾಗ ಒಂದು ದೋಷವು ಎದುರಾಗಿದೆ. ಹೆಚ್ಚಿನ ಮಾಹಿತಿಗಾಗಿ ದಾಖಲೆ ಕಡತವನ್ನು ನೋಡಿ."

/usr/share/locale/ko/LC_MESSAGES/rhsm.mo
msgid "An error occurred while importing the certificate. Please check log file for more information."
msgstr "인증서를 가져오기하는 동안 오류가 발생했습니다. 자세한 내용은 로그 파일에서 확인하십시오."

/usr/share/locale/ml/LC_MESSAGES/rhsm.mo
msgid "An error occurred while importing the certificate. Please check log file for more information."
msgstr "സര്‍ട്ടിഫിക്കേറ്റ് ഇംപോര്‍ട്ട് ചെയ്യുന്നതില്‍ പിശക്. കൂടുതല്‍ വിവരങ്ങള്‍ക്കായി ലോഗ് ഫയല്‍ പരിശോധിയ്ക്കുക."

/usr/share/locale/mr/LC_MESSAGES/rhsm.mo
msgid "An error occurred while importing the certificate. Please check log file for more information."
msgstr "प्रमाणपत्र आयात करतेवेळी त्रुटी आढळली. कृपया अधिक माहितीकरीता लॉग फाइल तपासा."

/usr/share/locale/or/LC_MESSAGES/rhsm.mo
msgid "An error occurred while importing the certificate. Please check log file for more information."
msgstr "ପ୍ରମାଣପତ୍ରଗୁଡ଼ିକୁ ଆମଦାନୀ କରିବା ସମୟରେ ଗୋଟିଏ ତ୍ରୁଟି ଘଟିଛି। ଅଧିକ ସୂଚନା ପାଇଁ ଦୟାକରି ଲଗ ଫାଇଲ ଦେଖନ୍ତୁ।"

/usr/share/locale/pa/LC_MESSAGES/rhsm.mo
msgid "An error occurred while importing the certificate. Please check log file for more information."
msgstr "ਸਾਰਟੀਫਿਕੇਟ ਇੰਪੋਰਟ ਕਰਨ ਵੇਲੇ ਇੱਕ ਗਲਤੀ ਆਈ ਹੈ। ਵਧੇਰੇ ਜਾਣਕਾਰੀ ਲਈ ਲਾਗ ਫਾਇਲ ਵੇਖੋ।"

/usr/share/locale/pt_BR/LC_MESSAGES/rhsm.mo
msgid "An error occurred while importing the certificate. Please check log file for more information."
msgstr "Ocorreu um erro ao importar o certificado. Por favor, verifique o arquivo de log para mais informações."

/usr/share/locale/ru/LC_MESSAGES/rhsm.mo
msgid "An error occurred while importing the certificate. Please check log file for more information."
msgstr "Ошибка импорта сертификата. Подробную информацию можно найти в журнале."

/usr/share/locale/ta_IN/LC_MESSAGES/rhsm.mo
msgid "An error occurred while importing the certificate. Please check log file for more information."
msgstr "சான்றிதழை இறக்குமதி செய்யும்போது ஒரு பிழை ஏற்பட்டது. மேலும் தகவலுக்கு பதிவுக் கோப்பைப் பார்க்கவும்."

/usr/share/locale/te/LC_MESSAGES/rhsm.mo
msgid "An error occurred while importing the certificate. Please check log file for more information."
msgstr "ధృవీకరణపత్రమును దిగుమతి చేయునప్పుడు వొక దోషము యెదురైంది. మరింత సమాచారం కొరకు లాగ్ ఫైలు పరిశీలించు."

/usr/share/locale/zh_CN/LC_MESSAGES/rhsm.mo
msgid "An error occurred while importing the certificate. Please check log file for more information."
msgstr "导入该证书时出错。详情请检查日志文件。"

/usr/share/locale/zh_TW/LC_MESSAGES/rhsm.mo
msgid "An error occurred while importing the certificate. Please check log file for more information."
msgstr "匯入憑證時發生了一項錯誤。請檢查日誌檔案以取得更多資訊。"


^^^^ VERIFIED: The original multi-line string that was getting truncated during the string extraction has been fixed and the new (original length string) has been successfully translated in all languages.

Note: This verification does not assert that other multi-line strings that may have been newly coded into the source is being extracted in full by the string extraction tool (xgettext).  However, my understanding from alikins is that part of the build process now includes a regex to check for these multi-line strings and then fail the build until the unwanted multi-line string style is fixed by the developer.  For now, I'll trust that this build mechanism is working.

Moving to VERIFIED.
Comment 5 errata-xmlrpc 2013-01-07 22:54:57 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0033.html

Note You need to log in before you can comment on or make changes to this bug.