Bug 832114 - general protection in libc causes virtualbox to abort
general protection in libc causes virtualbox to abort
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jeff Law
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-14 10:41 EDT by Stu
Modified: 2016-11-24 10:46 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-16 18:29:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stu 2012-06-14 10:41:28 EDT
Hello All

I am seeing an issue in the a Virtualbox VM just aborts.  The only message that gets logged in /var/log/messages relates to "general protection in libc" please see the below.

un 13 10:30:51 work16 kernel: [10883.463873] VirtualBox[2726] general protection ip:30f567e117 sp:7fd91c020c20 error:0 in libc-2.14.90.so[30f5600000+1ad000]

This is an intermittent error but I am sure that it will not be too long before I experience fs corruption in my VM.

I did first reply to the below post but was advised to create a new bug report.

Thanks in advance 

Regards

Stu

[root@work16 HardDisks]# uname -a
Linux work16 3.3.7-1.fc16.x86_64 #1 SMP Tue May 22 13:59:39 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux


[root@work16 HardDisks]# lspci
00:00.0 Host bridge: Intel Corporation Core Processor DRAM Controller (rev 02)
00:01.0 PCI bridge: Intel Corporation Core Processor PCI Express x16 Root Port (rev 02)
00:16.0 Communication controller: Intel Corporation 5 Series/3400 Series Chipset HECI Controller (rev 06)
00:16.3 Serial controller: Intel Corporation 5 Series/3400 Series Chipset KT Controller (rev 06)
00:19.0 Ethernet controller: Intel Corporation 82577LM Gigabit Network Connection (rev 05)
00:1a.0 USB Controller: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller (rev 05)
00:1b.0 Audio device: Intel Corporation 5 Series/3400 Series Chipset High Definition Audio (rev 05)
00:1c.0 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 1 (rev 05)
00:1c.1 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 2 (rev 05)
00:1c.2 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 3 (rev 05)
00:1c.3 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 4 (rev 05)
00:1d.0 USB Controller: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller (rev 05)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev a5)
00:1f.0 ISA bridge: Intel Corporation Mobile 5 Series Chipset LPC Interface Controller (rev 05)
00:1f.2 RAID bus controller: Intel Corporation Mobile 82801 SATA RAID Controller (rev 05)
00:1f.3 SMBus: Intel Corporation 5 Series/3400 Series Chipset SMBus Controller (rev 05)
00:1f.6 Signal processing controller: Intel Corporation 5 Series/3400 Series Chipset Thermal Subsystem (rev 05)
01:00.0 VGA compatible controller: nVidia Corporation GT218 [NVS 3100M] (rev a2)
01:00.1 Audio device: nVidia Corporation High Definition Audio Controller (rev a1)
03:00.0 Network controller: Intel Corporation Centrino Advanced-N 6200 (rev 35)
04:00.0 SD Host controller: Ricoh Co Ltd MMC/SD Host Controller (rev 03)
04:00.4 FireWire (IEEE 1394): Ricoh Co Ltd FireWire Host Controller (rev 03)
3f:00.0 Host bridge: Intel Corporation Core Processor QuickPath Architecture Generic Non-core Registers (rev 02)
3f:00.1 Host bridge: Intel Corporation Core Processor QuickPath Architecture System Address Decoder (rev 02)
3f:02.0 Host bridge: Intel Corporation Core Processor QPI Link 0 (rev 02)
3f:02.1 Host bridge: Intel Corporation Core Processor QPI Physical 0 (rev 02)
3f:02.2 Host bridge: Intel Corporation Core Processor Reserved (rev 02)
3f:02.3 Host bridge: Intel Corporation Core Processor Reserved (rev 02)
Comment 1 Stu 2012-06-19 11:41:18 EDT
Hello 

I am not sure if this will help but the problem seems to be network related.  By that I mean that when the is a DHCP request sometimes there is a crash soon after or not long before.  Like I say I am not sure how significant this is but there does seem to be a pretty strong pattern there.

All the best and thanks for looking into this.

Regards

Stu

[root@work16 log]# grep -i virtualbox messages

Jun 19 11:16:10 work16 kernel: [ 5732.555717] VirtualBox[2862] general protection ip:30f567e117 sp:7f259c318c20 error:0 in libc-2.14.90.so[30f5600000+1ad000]
Jun 19 12:06:54 work16 kernel: [ 8769.721904] VirtualBox[4811] general protection ip:30f567e117 sp:7fa82c145c20 error:0 in libc-2.14.90.so[30f5600000+1ad000]
Jun 19 13:31:31 work16 kernel: [13833.429733] VirtualBox[5187] general protection ip:30f567e117 sp:7f8bdd4bbc20 error:0 in libc-2.14.90.so[30f5600000+1ad000]
Jun 19 14:25:15 work16 kernel: [17049.016485] VirtualBox[5490] general protection ip:30f567e117 sp:7f1b34a8bc20 error:0 in libc-2.14.90.so[30f5600000+1ad000

[root@work16 log]# grep DHCPREQUEST messages

Jun 19 11:16:45 work16 dhclient[4372]: DHCPREQUEST on wlan0 to 1.1.1.1 port 67
Jun 19 14:07:21 work16 dhclient[5859]: DHCPREQUEST on wlan0 to 255.255.255.255 port 67
Jun 19 14:34:41 work16 dhclient[6487]: DHCPREQUEST on em1 to 255.255.255.255 port 67
Jun 19 14:34:44 work16 dhclient[6487]: DHCPREQUEST on em1 to 255.255.255.255 port 67
Comment 2 Andy Grimm 2012-07-12 16:30:37 EDT
I'm not sure how this issue ended up with ehcache-sizeof-agent as the component.  I'm switching it to glibc, because one of the glibc maintainers is most likely to be able to give you some debugging advice.  It would be helpful to provide other information such as the exact versions of glibc and virtualbox (rpm -q glibc VirtualBox).

To be honest, this sounds more likely to be a virtualbox issue, though (or perhaps a discrepancy between the glibc version for which it was built and the version which you have installed now).  Have you tried filing an issue in their system?
Comment 3 Jeff Law 2012-07-12 17:19:12 EDT
It'd really help to have a core dump so that we could more easily map the faulting address to code within glibc and examine the backtrace.

At the least we'd need to know the precise version of glibc in use (rpm -qa glibc).  Mapping back to an address is possible in that case, just harder, and of course we wouldn't have the backtrace to guide us in our investigations.

FWIW, I use Virtual Box regularly and haven't ever seen it fault in this way.
Comment 4 Jeff Law 2012-07-16 18:29:02 EDT
Assuming you're running the latest Fedora 16 glibc (glibc-2.14.90-24), then VirtualBox is faulting inside malloc_consolidate.  That is an indication VirtualBox has clobbered the heap.  That is a VirtualBox problem and needs to be reported to Oracle.

Note You need to log in before you can comment on or make changes to this bug.