Bug 832163 - Virtual Keyboard not detected with node-iso
Virtual Keyboard not detected with node-iso
Status: CLOSED CURRENTRELEASE
Product: oVirt
Classification: Community
Component: ovirt-node (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Joey Boggs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-14 13:35 EDT by Olivier D
Modified: 2016-04-27 00:22 EDT (History)
8 users (show)

See Also:
Fixed In Version: 2.6.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-14 08:53:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg on working kernel for this problem (60.35 KB, text/plain)
2012-06-22 13:23 EDT, Olivier D
no flags Details

  None (edit)
Description Olivier D 2012-06-14 13:35:17 EDT
Testing ovirt-node-iso image from testDay (http://www.ovirt.org/releases/beta/binary/ovirt-node-iso-2.4.0-0.0.fc17.iso)

on a DELL Blade Server PowerEdgeM610.

Booting with IPXE. Config is : 
kernel http://***/isos/ovirt/vmlinuz0 rootflags=loop root=live:/ovirt-node-iso-2.4.0-0.0.fc17.iso rootfstype=auto ro liveimg rootflags=ro crashkernel=512M-2G:64M,2G-:128M elevator=deadline stateless rd_NO_LVM rd.luks=0 rd.md=0 rd.dm=0 management_server=195.60.189.11:8080 ip=dhcp hostname=***.com ntp=***.com rootpw***
initrd http://ipxe.reagi.com/isos/ovirt/initrd0.img


I have the login prompt but no keyboard detected. it would need driver USBHID if I remember right.
Comment 1 Olivier D 2012-06-21 12:38:25 EDT
Problem still happening with iso file http://ovirt.org/releases/beta/binary/ovirt-node-iso-2.4.0-1.1.fc17.iso

Boot line can be simplified to have the issue : 
kernel http://***/isos/ovirt/vmlinuz0 rootflags=loop root=live:/ovirt-node-iso-2.4.0-1.1.fc17.iso rootfstype=auto ro liveimg rootflags=ro crashkernel=512M-2G:64M,2G-:128M elevator=deadline rd_NO_LVM rd.luks=0 rd.md=0 rd.dm=0

(no need for keyword 'stateless' to hit this bug, or any additional parameters).
Comment 2 Joey Boggs 2012-06-21 13:24:41 EDT
Added change to keep the hid kernel modules:

If possible you can pull that patch and run a test build with it to confirm it has the right module you need.

http://gerrit.ovirt.org/5598
Comment 3 Olivier D 2012-06-22 13:08:31 EDT
This patch does not work.

I have compiled (on an other system) my own kernel that is working for this problem, and driver seems to be hid/usbhid/usbhid.ko

your patch is only adding HID support and that's not enough I guess.

I cannot find relevant .ko in /lib/modules/ in my system when I build node-iso image, I think that's why driver is not included in iso.
Comment 4 Olivier D 2012-06-22 13:23:33 EDT
Created attachment 593805 [details]
dmesg on working kernel for this problem

This is dmesg output on a working kernel (built myself - version 3.2.0) for this problem.

Server is a blade Dell PowerEdge M610
Comment 5 Mike Burns 2012-06-22 13:35:13 EDT
fwiw, dmesg on a vm using latest master branch ovirt-node has usbhid mentioned in dmesg.  

usbcore: registered new interface driver usbhid
usbhid: USB HID core driver
Comment 6 Olivier D 2012-06-22 13:37:35 EDT
this driver seems builtin in Fedora kernel (if .config in kernel source is correct).

I tried booting Fedora-17-x86_64-Live-Desktop.iso on this server and I do have keyboard and mouse working...

will investigate further on monday.
Comment 7 Joey Boggs 2012-06-26 12:21:30 EDT
Oliver any luck determining the needed module? Are you using builtin idrac on the blade or a separate kvm? With RHEV-H I've successfully used a R510 and R210 with idrac without any issues. Kernel module blacklisting is similar between upstream and RHEV-H
Comment 8 Olivier D 2012-06-27 08:36:07 EDT
I cannot reproduce this problem easily as long as bug #804889 is not resolved :(

during ovirt node booting, I have keyboard working during first step (pressing ENTER skips a line), but at one moment I don't have the keyboard anymore.
Comment 9 Mike Burns 2012-07-11 08:04:14 EDT
Hi Olivier,

I've posted a new image (very much unofficial, but should be good enough for you to test this issue.

http://www.ovirt.org/releases/nightly/binary/ovirt-node-iso-2.4.0-999.mburns201207102007.fc17.iso

Can you update me with whether or not you still see this issue with the above iso image?

Thanks
Comment 10 Olivier D 2012-07-18 10:27:26 EDT
Hello,

Sorry for late reply, I was on vacation.

I tested your ISO file. Even if I go on debug shell with dracut (because of bug #804889), I now do have a keyboard working.
Your iso file does not have latest udev packages I guess, so I'll wait for this to be sure this bug is fixed.
Comment 11 Tal Nisan 2013-03-14 07:23:57 EDT
Olivier, any news on the issue? Was it solved?
Comment 12 Mike Burns 2013-03-14 08:53:39 EDT
Marking this fixed in 2.6.0 since it's not reproduced with latest builds

Note You need to log in before you can comment on or make changes to this bug.