Bug 832172 - Getting warning rpcbind needs to be restart as "rpcbind -w"
Getting warning rpcbind needs to be restart as "rpcbind -w"
Status: CLOSED CURRENTRELEASE
Product: oVirt
Classification: Community
Component: ovirt-node (Show other bugs)
3.1 RC
Unspecified Linux
unspecified Severity low
: ---
: ---
Assigned To: Fabian Deutsch
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-14 14:08 EDT by Robert Middleswarth
Modified: 2016-04-26 14:36 EDT (History)
9 users (show)

See Also:
Fixed In Version: 2.5.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-09 07:48:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Middleswarth 2012-06-14 14:08:20 EDT
Description of problem:
Getting warning:
rpcbind needs to be restart as "rpcbind -w"

Version-Release number of selected component (if applicable):
ovirt-node-iso-2.4.0-1.0.fc17.iso	

How reproducible:
On my test system it happens on ever boot.

Steps to Reproduce:
1.  Boot and give the system a min to display the warning.
  
Actual results:
Gets Warning

Expected results:
No output.

Additional info:
Doesn't seem to be causing any problems just getting an warning.
Comment 1 Mike Burns 2012-06-15 05:37:21 EDT
Very low priority -- cosmetic issue
Comment 2 Fabian Deutsch 2012-06-19 11:28:47 EDT
Seems to be spit out by the dracut's nfs module.
Comment 3 Harald Hoyer 2012-06-20 13:30:29 EDT
rpcbind moans, that it was killed
rpcbind explicitely uses syslog with openlog(LOG_CONS)
   LOG_CONS       Write directly to system console if there is an error while sending to system logger.
.. and because syslog does not run, it appears on the console
Comment 4 Harald Hoyer 2012-06-20 13:31:41 EDT
dracut cannot even redirect it to /dev/null
openlog opens /dev/console directly
Comment 5 Fabian Deutsch 2012-06-20 13:37:22 EDT
plymouth is redirecting /dev/console, so it could be prevented by fixing - it seems as if it's not working correctly - plymouth.
Comment 6 Fabian Deutsch 2012-06-25 10:21:59 EDT
The following patch adds plymouth to node, it got lost at some point.
http://gerrit.ovirt.org/5682

Tested as follows:
1. Build node w/ patch
2. Boot and look out for error
= Error does not appear
= Whole boot appearance is much cleaner now - again
Comment 7 Fabian Deutsch 2012-06-27 06:18:24 EDT
Pulling in the @base group, as discussed on irc, would pull in another 32MB.
Just pulling in plymouth-* packages (w patch from above) increases the size by 2MB.


Therefor I'm leaving the patch as is (adding plymouth* packages).

Note You need to log in before you can comment on or make changes to this bug.