Bug 832176 - katello install fails - Requires: candlepin >= 0.6.0
katello install fails - Requires: candlepin >= 0.6.0
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Subscription Management (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity high (vote)
: Unspecified
: --
Assigned To: Katello Bug Bin
Katello QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-14 14:21 EDT by James Laska
Modified: 2014-01-27 08:25 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-15 13:47:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Laska 2012-06-14 14:21:51 EDT
Description of problem:

Attempting to install katello from the latest brew target repo fails.  THere is a newer (but older) candlepin build that supercedes the proper candlepin-0.6.x* build.

How reproducible:


Steps to Reproduce:
1. Install RHEL-6.2
2. Enable brew target repo for se-rhel-6-candidate
3. yum install katello-all

Actual results:

> --> Finished Dependency Resolution
> Error: Package: katello-configure-0.1.110-1.el6_3.noarch (se-rhel-6-candidate)
>            Requires: candlepin >= 0.6.0
>            Available: candlepin-0.5.26-1.el6.noarch (rhel-6-server-cf-se-1-rpms)
>                candlepin = 0.5.26-1.el6
>            Installing: candlepin-0.5.34-1.el6_3.noarch (se-rhel-6-candidate)
>                candlepin = 0.5.34-1.el6_3
>  You could try using --skip-broken to work around the problem
>  You could try running: rpm -Va --nofiles --nodigest


Expected results:
 * katello-all should find the proper candlepin-0.6.x package

Additional info:

> # brew latest-pkg se-rhel-6-candidate candlepin
> Build                                     Tag                   Built by
> ----------------------------------------  --------------------  ----------------
> candlepin-0.5.34-1.el6_3                  se-rhel-6-candidate   jbowes
Comment 1 James Laska 2012-06-15 13:42:51 EDT
I'm waiting on a test to complete, but it appears this is lined up for success.

> # brew latest-pkg se-rhel-6-candidate candlepin
> Build                                     Tag                   Built by
> ----------------------------------------  --------------------  ----------------
> candlepin-0.6.5-1.el6_2                   se-rhel-6-candidate   dgoodwin

Note You need to log in before you can comment on or make changes to this bug.