Bug 832208 - Can we add a page to define what a brick is?
Can we add a page to define what a brick is?
Status: CLOSED CURRENTRELEASE
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: Documentation (Show other bugs)
2.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Divya
Sudhir D
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-14 17:18 EDT by Jacob Shucart
Modified: 2016-09-20 01:17 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-04-10 03:15:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jacob Shucart 2012-06-14 17:18:42 EDT
Description of problem:

I had one of my beta users(Qualcomm) report that they were unable to figure out what a "brick" was in the documentation.  They were looking in:

http://docs.redhat.com/docs/en-US/Red_Hat_Storage/2/html/User_Guide/index.html

I looked myself, but did not see a good definition anywhere...
Comment 2 Divya 2012-06-19 02:16:02 EDT
Storage Concepts has been added in the Administration Guide at: http://documentation-stage.bne.redhat.com/docs/en-US/Red_Hat_Storage/2.0/html/Administration_Guide/chap-Administration_Guide-storage_concepts.html

Administration Guide will be released for GA. If you would like me to add anything specific in this section, please let me know.
Comment 3 Justin Bautista 2012-07-03 10:13:51 EDT
Hi Divya,

I noticed the Volfile definition seems to be out of date:

"Volfile
    Volfile is a configuration file used by glusterfs process. Volfile will be usually located at /etc/glusterd/vols/VOLNAME."


I think it should read as:

Volfile
    Volfile is a configuration file used by glusterfs process. Volfile will be usually located at /var/lib/glusterd/vols/VOLNAME. 


Please feel free to disregard if this has already been addressed or if I'm mistaken.
Comment 4 Ujjwala 2012-07-06 01:25:04 EDT
Hi Divya,

The brick defnition looks fine. But as per Justin's comment, volfile defnition is still not fixed. 
I am moving it to modified.
Can you please fix that and then move it ON_QA.
Comment 5 Divya 2012-07-17 14:11:04 EDT
I have updated all the instances of /etc/glusterd to /var/lib/glusterd. The updated Storage Concepts chapter is available at: http://documentation-stage.bne.redhat.com/docs/en-US/Red_Hat_Storage/2.0/html/Administration_Guide/chap-Administration_Guide-storage_concepts.html
Comment 6 Ujjwala 2012-08-13 08:32:53 EDT
The above mentioned url is not browseable, so I verified it from source and it looks fine.

https://svn.devel.redhat.com/repos/ecs/Red_Hat_Storage/2.0/Administration_Guide/en-US/storage_concepts.xml

Note You need to log in before you can comment on or make changes to this bug.