Bug 832236 - [abrt] evolution-3.4.2-1.fc17: g_type_check_instance_cast: Process /usr/bin/evolution was killed by signal 11 (SIGSEGV)
[abrt] evolution-3.4.2-1.fc17: g_type_check_instance_cast: Process /usr/bin/e...
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
abrt_hash:d3377a098cb3d2536181500ee28...
:
: 956911 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-14 19:54 EDT by matt.lavin
Modified: 2013-04-26 01:59 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-15 05:52:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: maps (94.72 KB, text/plain)
2012-06-14 19:54 EDT, matt.lavin
no flags Details
File: dso_list (19.90 KB, text/plain)
2012-06-14 19:54 EDT, matt.lavin
no flags Details
File: backtrace (53.81 KB, text/plain)
2012-06-14 19:54 EDT, matt.lavin
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 678150 None None None 2012-06-15 05:52:51 EDT

  None (edit)
Description matt.lavin 2012-06-14 19:54:31 EDT
libreport version: 2.0.10
abrt_version:   2.0.10
backtrace_rating: 4
cmdline:        evolution
crash_function: g_type_check_instance_cast
executable:     /usr/bin/evolution
kernel:         3.4.0-1.fc17.x86_64
pid:            12153
pwd:            /home/matt
time:           Thu 14 Jun 2012 05:13:47 PM EDT
uid:            1000
username:       matt

backtrace:      Text file, 55105 bytes
dso_list:       Text file, 20382 bytes
maps:           Text file, 96994 bytes

cgroup:
:9:perf_event:/
:8:blkio:/
:7:net_cls:/
:6:freezer:/
:5:devices:/
:4:memory:/
:3:cpuacct,cpu:/
:2:cpuset:/
:1:name=systemd:/user/matt/3

core_backtrace:
:31243d0d107bba586a96433c76c87a26db1e826c 0x30e70 g_type_check_instance_cast libgobject-2.0.so.0 -
:62168d6c983ff9cb0c5a24414414dc8d3f0a2871 0xbda3 - liborg-gnome-itip-formatter.so -
:6ffd106c467fc2bbbe04c9509d66f7d97d2a751f 0x6ce77 g_simple_async_result_complete libgio-2.0.so.0 -
:95909b3e9ee9409c495461caba26793cc77d8d6b 0x1967b - libedataserverui-3.0.so.1 -
:e5945f7dae3fc83ad499da1ea5a464bfa0e68202 0x476e5 g_main_context_dispatch libglib-2.0.so.0 -
:e5945f7dae3fc83ad499da1ea5a464bfa0e68202 0x47a18 - libglib-2.0.so.0 -
:e5945f7dae3fc83ad499da1ea5a464bfa0e68202 0x47e12 g_main_loop_run libglib-2.0.so.0 -
:710b0d8cc36603d66327090defd37c99daa38f28 0x179d65 gtk_main libgtk-3.so.0 -
:17f014bbe23d507f5dea851f72da7ea83d0fe000 0x22da main [exe] -

environ:
:XDG_VTNR=1
:XDG_SESSION_ID=3
:HOSTNAME=mdlavin-laptop
:IMSETTINGS_INTEGRATE_DESKTOP=yes
:SHELL=/bin/bash
:TERM=dumb
:HISTSIZE=1000
:GNOME_KEYRING_CONTROL=/run/user/matt/keyring-ULVNku
:QT_GRAPHICSSYSTEM_CHECKED=1
:IMSETTINGS_MODULE=none
:USER=matt
:USERNAME=matt
:MAIL=/var/spool/mail/matt
:PATH=/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/home/matt/.local/bin:/home/matt/bin
:DESKTOP_SESSION=gnome
:QT_IM_MODULE=xim
:PWD=/home/matt
:XMODIFIERS=@im=none
:GNOME_KEYRING_PID=888
:LANG=en_US.UTF-8
:GDMSESSION=gnome
:HISTCONTROL=ignoredups
:XDG_SEAT=seat0
:HOME=/home/matt
:SHLVL=1
:LOGNAME=matt
:CVS_RSH=ssh
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-fEIJXSMYJY,guid=e4bc17ebcfcf2310f730f27a0000006e
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:WINDOWPATH=1
:XDG_RUNTIME_DIR=/run/user/matt
:DISPLAY=:0
:XAUTHORITY=/var/run/gdm/auth-for-matt-7OFKcm/database
:_=/usr/bin/gnome-session
:GNOME_DESKTOP_SESSION_ID=this-is-deprecated
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/892,unix/unix:/tmp/.ICE-unix/892
:SSH_AUTH_SOCK=/run/user/matt/keyring-ULVNku/ssh
:GPG_AGENT_INFO=/run/user/matt/keyring-ULVNku/gpg:0:1
:GJS_DEBUG_OUTPUT=stderr
:'GJS_DEBUG_TOPICS=JS ERROR;JS LOG'
:GIO_LAUNCHED_DESKTOP_FILE=/usr/share/applications/evolution.desktop
:GIO_LAUNCHED_DESKTOP_FILE_PID=12153
:DESKTOP_STARTUP_ID=gnome-shell-1117-mdlavin-laptop-evolution-19_TIME26624181

limits:
:Limit                     Soft Limit           Hard Limit           Units     
:Max cpu time              unlimited            unlimited            seconds   
:Max file size             unlimited            unlimited            bytes     
:Max data size             unlimited            unlimited            bytes     
:Max stack size            8388608              unlimited            bytes     
:Max core file size        0                    unlimited            bytes     
:Max resident set          unlimited            unlimited            bytes     
:Max processes             1024                 30923                processes 
:Max open files            1024                 4096                 files     
:Max locked memory         65536                65536                bytes     
:Max address space         unlimited            unlimited            bytes     
:Max file locks            unlimited            unlimited            locks     
:Max pending signals       30923                30923                signals   
:Max msgqueue size         819200               819200               bytes     
:Max nice priority         0                    0                    
:Max realtime priority     0                    0                    
:Max realtime timeout      unlimited            unlimited            us        

open_fds:
:0:/dev/null
:1:/home/matt/.xsession-errors
:2:/home/matt/.xsession-errors
:3:socket:[2392403]
:4:anon_inode:[eventfd]
:5:socket:[2392406]
:6:anon_inode:[eventfd]
:7:socket:[2396166]
:8:anon_inode:[eventfd]
:9:socket:[2393313]
:10:anon_inode:[eventfd]
:11:/home/matt/.local/share/evolution/mail/1339421311.2438.0@mdlavin-laptop/folders.db
:12:socket:[2391059]
:13:/home/matt/.pki/nssdb/cert9.db
:14:/var/tmp/etilqs_hw5F0GQbshdcnRr (deleted)
:15:/var/tmp/etilqs_jTbOBXqSpB0HMbs (deleted)
:16:/var/tmp/etilqs_0lBufDVbf4tCGTq (deleted)
:17:/home/matt/.pki/nssdb/key4.db
:18:/var/tmp/etilqs_0ZAJnCRIvquXiMr (deleted)
:19:/var/tmp/etilqs_jNsKbcU4QJJUD8b (deleted)
:20:/var/tmp/etilqs_AN8EvJGgXPIHvKO (deleted)
:21:/etc/pki/nssdb/cert9.db
:22:/var/tmp/etilqs_AH8w7EZd4lErETI (deleted)
:23:/var/tmp/etilqs_za0wPZZVvywVWXA (deleted)
:24:/etc/pki/nssdb/key4.db
:25:/var/tmp/etilqs_wvYa8Pwi1CJdK9M (deleted)
:26:/var/tmp/etilqs_kD1AUejeU555bW1 (deleted)
:27:/home/matt/.local/share/evolution/mail/local/folders.db
:28:/home/matt/.local/share/evolution/mail/vfolder/folders.db
:29:socket:[2394562]
:30:socket:[2393419]
:31:anon_inode:[eventfd]
:32:/home/matt/.cache/evolution/mail/1339423364.2438.1@mdlavin-laptop/folders.db
:33:anon_inode:[eventfd]
:34:anon_inode:inotify
:35:/dev/urandom
:36:socket:[2444109]
:37:/home/matt/.local/share/gvfs-metadata/home (deleted)
:38:/home/matt/.local/share/gvfs-metadata/home-135ac56d.log (deleted)
:39:socket:[2469614]

var_log_messages:
:Jun  9 22:59:44 mdlavin-laptop yum[2444]: Updated: evolution-data-server-3.4.2-1.fc17.x86_64
:Jun  9 22:59:46 mdlavin-laptop yum[2444]: Updated: evolution-3.4.2-1.fc17.x86_64
:Jun  9 22:59:58 mdlavin-laptop yum[2444]: Updated: evolution-NetworkManager-3.4.2-1.fc17.x86_64
:Jun 12 07:45:35 mdlavin-laptop abrt[21780]: Saved core dump of pid 1241 (/usr/libexec/evolution-addressbook-factory) to /var/spool/abrt/ccpp-2012-06-12-07:45:35-1241 (64499712 bytes)
:Jun 12 11:47:33 mdlavin-laptop kernel: [26594.490183] evolution[26127]: segfault at 4 ip 0000000000000004 sp 00007fffd5a45ff8 error 14 in evolution[400000+4000]
:Jun 12 11:47:35 mdlavin-laptop abrt[5129]: Saved core dump of pid 26127 (/usr/bin/evolution) to /var/spool/abrt/ccpp-2012-06-12-11:47:33-26127 (282849280 bytes)
:Jun 14 17:13:47 mdlavin-laptop kernel: [29857.082484] evolution[12153] general protection ip:3426630e70 sp:7fff3cb7a270 error:0 in libgobject-2.0.so.0.3200.3[3426600000+4b000]
:Jun 14 17:13:48 mdlavin-laptop abrt[19831]: Saved core dump of pid 12153 (/usr/bin/evolution) to /var/spool/abrt/ccpp-2012-06-14-17:13:47-12153 (205357056 bytes)
Comment 1 matt.lavin 2012-06-14 19:54:34 EDT
Created attachment 591949 [details]
File: maps
Comment 2 matt.lavin 2012-06-14 19:54:36 EDT
Created attachment 591950 [details]
File: dso_list
Comment 3 matt.lavin 2012-06-14 19:54:38 EDT
Created attachment 591951 [details]
File: backtrace
Comment 4 Milan Crha 2012-06-15 05:52:51 EDT
Thanks for a bug report. I moved this upstream as [1]. Please see [1] for any further updates. If possible, please CC yourself there, in case upstream developers will have additional questions.

[1] https://bugzilla.gnome.org/show_bug.cgi?id=678150
Comment 5 Milan Crha 2013-04-26 01:59:06 EDT
*** Bug 956911 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.