Bug 832245 - GlusterFS Native mount failure from RHEL 6.2
GlusterFS Native mount failure from RHEL 6.2
Status: CLOSED NOTABUG
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: fuse (Show other bugs)
2.0
Unspecified Linux
unspecified Severity high
: ---
: ---
Assigned To: Csaba Henk
Sudhir D
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-14 21:11 EDT by Veda Shankar
Modified: 2016-06-12 19:18 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-17 11:09:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Veda Shankar 2012-06-14 21:11:44 EDT
Description of problem:

I started a POC today at a premier customer.  The customer is interested in Amazon EC2 environment and so deployed 4 instances of the RHS 2.0 beta2 which is the only available package on EC2.  The volume creation went well and I am able to mount the volume from one of the storage nodes using GlusterFS – no problem.

The customer launched the RHEL 6.2 64bit that is available under “Quick Start” in EC2.  I installed the client packages (glusterfs-3.3.0qa38* and glusterfs-fuse-3.3.0qa38*) from http://bits.gluster.com/pub/gluster/glusterfs/3.3.0qa38/x86_64/.  The mount with “-t glusterfs” from the client failed.  

I was able to reproduce the problem in my EC2 environment, but this problem is not Amazon specific.  I tried this using 3.3.0qa39 and also the packages available under http://download.gluster.org/pub/gluster/glusterfs/3.3/3.3.0/RHEL/ and also the LATEST folder.  All of them failed with similar results documented below.

Regards,
Veda


[root@domU-12-31-39-06-2E-41 el6]# mount -t glusterfs 10.28.208.117:/gvol2 /mnt
Mount failed. Please check the log file for more details.

[2012-06-14 19:58:06.704619] I [glusterfsd.c:1629:main] 0-/usr/sbin/glusterfs: Started running /usr/sbin/glusterfs version 3.3.0qa39
[2012-06-14 19:58:06.709618] E [mount.c:580:fuse_mount_sys] 0-glusterfs-fuse: calling mount
[2012-06-14 19:58:06.720408] E [mount.c:583:fuse_mount_sys] 0-glusterfs-fuse: mount returned 0
[2012-06-14 19:58:06.725375] E [mount.c:625:fuse_mount_sys] 0-glusterfs-fuse: writing status
[2012-06-14 19:58:06.725470] E [mount.c:637:fuse_mount_sys] 0-glusterfs-fuse: Mount child exiting
[2012-06-14 19:58:06.757979] E [glusterfsd-mgmt.c:1548:mgmt_getspec_cbk] 0-glusterfs: XDR decoding error
[2012-06-14 19:58:06.758092] E [glusterfsd-mgmt.c:1623:mgmt_getspec_cbk] 0-mgmt: failed to fetch volume file (key:/gvol2)
[2012-06-14 19:58:06.758366] W [glusterfsd.c:794:cleanup_and_exit] (-->/usr/lib64/libgfrpc.so.0(rpc_clnt_notify+0xb6) [0x7facfbbde506] (-->/usr/lib64/libgfrpc.so.0(rpc_clnt_handle_reply+0xa2) [0x7facfbbde2f2] (-->/usr/sbin/glusterfs(mgmt_getspec_cbk+0x298) [0x40bf38]))) 0-: received signum (0), shutting down
[2012-06-14 19:58:06.758419] I [fuse-bridge.c:4649:fini] 0-fuse: Unmounting '/mnt'.
[2012-06-14 20:18:29.845136] I [glusterfsd.c:1666:main] 0-/usr/sbin/glusterfs: Started running /usr/sbin/glusterfs version 3.3.0
[2012-06-14 20:18:29.874393] E [glusterfsd-mgmt.c:1548:mgmt_getspec_cbk] 0-glusterfs: XDR decoding error
[2012-06-14 20:18:29.874474] E [glusterfsd-mgmt.c:1623:mgmt_getspec_cbk] 0-mgmt: failed to fetch volume file (key:/gvol2)
[2012-06-14 20:18:29.874698] W [glusterfsd.c:831:cleanup_and_exit] (-->/usr/lib64/libgfrpc.so.0(rpc_clnt_notify+0x120) [0x7f144cb6b890] (-->/usr/lib64/libgfrpc.so.0(rpc_clnt_handle_reply+0xa5) [0x7f144cb6b095] (-->/usr/sbin/glusterfs(mgmt_getspec_cbk+0x292) [0x40c922]))) 0-: received signum (0), shutting down
[2012-06-14 20:18:29.874733] I [fuse-bridge.c:4643:fini] 0-fuse: Unmounting '/mnt'.
[2012-06-14 20:43:18.991263] I [glusterfsd.c:1666:main] 0-/usr/sbin/glusterfs: Started running /usr/sbin/glusterfs version 3.3.0
[2012-06-14 20:43:19.541513] E [glusterfsd-mgmt.c:1548:mgmt_getspec_cbk] 0-glusterfs: XDR decoding error
[2012-06-14 20:43:19.541646] E [glusterfsd-mgmt.c:1623:mgmt_getspec_cbk] 0-mgmt: failed to fetch volume file (key:/gvol2)
[2012-06-14 20:43:19.546035] W [glusterfsd.c:831:cleanup_and_exit] (-->/usr/lib64/libgfrpc.so.0(rpc_clnt_notify+0x120) [0x7f4a82eca890] (-->/usr/lib64/libgfrpc.so.0(rpc_clnt_handle_reply+0xa5) [0x7f4a82eca095] (-->/usr/sbin/glusterfs(mgmt_getspec_cbk+0x292) [0x40c922]))) 0-: received signum (0), shutting down
[2012-06-14 20:43:19.546140] I [fuse-bridge.c:4643:fini] 0-fuse: Unmounting '/mnt'.


Version-Release number of selected component:
RHS 2.0 Beta2.

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 2 Veda Shankar 2012-06-17 11:09:19 EDT
The error was caused by DNS resolution - NOT A BUG.

Note You need to log in before you can comment on or make changes to this bug.