Bug 832400 - service-level –unset should display proper message for unregistered client.
service-level –unset should display proper message for unregistered client.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.9
Unspecified Unspecified
unspecified Severity unspecified
: rc
: 5.9
Assigned To: William Poteat
Entitlement Bugs
:
Depends On:
Blocks: 771748
  Show dependency treegraph
 
Reported: 2012-06-15 06:31 EDT by spandey
Modified: 2015-04-23 19:57 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-07 22:55:14 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description spandey 2012-06-15 06:31:15 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
2/2

Prerequisites : 
Rhel5.9 client with following subscription-manager rpm .
subscription-manager-1.0.3-1.git.69.b87abd7.el5
subscription-manager-firstboot-1.0.3-1.git.69.b87abd7.el5
subscription-manager-migration-data-1.11.1.1-1.git.2.c7fbafe.el5
subscription-manager-migration-1.0.3-1.git.69.b87abd7.el5
subscription-manager-gui-1.0.3-1.git.69.b87abd7.el5

Steps to repro : 
Execute following command on unregistered client .
subscription-manager service-level –unset

Expected Result : 
Following proper message should display.
This system is not yet registered. Try 'subscription-manager register --help' for more information.

Actual Result : 
[root@dhcp193-122 ~]# subscription-manager service-level --unset
[Errno 2] No such file or directory: '/etc/pki/consumer/key.pem'
Comment 1 J.C. Molet 2012-06-21 14:51:38 EDT
Testing with Version:
subscription-manager-1.0.4-1.git.1.b28337e.el5
python-rhsm-1.0.2-1.git.2.d5c3d05.el5

===================================================
[root@jmolet-vm0 ~]# subscription-manager unregister
This system is currently not registered.

[root@jmolet-vm0 ~]# subscription-manager service-level --unset
This system is not yet registered. Try 'subscription-manager register --help' for more information.


This looks good. Marking VERIFIED.
Comment 2 RHEL Product and Program Management 2012-06-26 14:08:39 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 4 errata-xmlrpc 2013-01-07 22:55:14 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0033.html

Note You need to log in before you can comment on or make changes to this bug.