Bug 832493 - python-bugzilla choses wrong bugclass
python-bugzilla choses wrong bugclass
Status: CLOSED WONTFIX
Product: Fedora EPEL
Classification: Fedora
Component: python-bugzilla (Show other bugs)
el6
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Will Woods
Fedora Extras Quality Assurance
: Regression, Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-15 10:30 EDT by Dalibor Pospíšil
Modified: 2013-01-10 01:49 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-30 17:33:41 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dalibor Pospíšil 2012-06-15 10:30:37 EDT
Description of problem:
Internal tools like tcms-submit or status-report
cannot connect to bugzilla due to bad initial negotiation.

On version python-bugzilla-0.6.0-1.el6.noarch it works ok.

Version-Release number of selected component (if applicable):
python-bugzilla-0.7.0-1.el6.noarch

How reproducible:
always

Steps to Reproduce:
1. DEBUG=2 status-report --bugzilla
  
Actual results:
[INFO] Bugzilla v0.7.0 initializing
[DEBUG] Choosing subclass for https://bugzilla.redhat.com/xmlrpc.cgi
[DEBUG] Checking for RH Bugzilla method bugzilla.getProdInfo()
[DEBUG] rhbz=True
[DEBUG] Checking return value of Buzilla.version()
[DEBUG] bzversion='4.2.1-2.2'
[INFO] Chose subclass RHBugzilla v0.1
[DEBUG] request_url is https://bugzilla.redhat.com/xmlrpc.cgi
[DEBUG] send_cookies(): using existing cookiejar
[DEBUG] cookie_request headers currently: []
[DEBUG] cookie_request headers now: [('Cookie', 'Bugzilla_logincookie=7hPP2m473x; Bugzilla_login=319215')]
[DEBUG] sending cookie: Cookie=Bugzilla_logincookie=7hPP2m473x; Bugzilla_login=319215
[DEBUG] cookiejar now contains: .....
[ERROR] An error encountered, while searching for bugs.
[ERROR] Have you prepared your cookies by 'bugzilla login'?
[ERROR] <Fault 53: 'field0-2-0 is not a valid parameter for the Bugzilla::Bug::match function.'>


Expected results:
something like on old version:
[INFO] Bugzilla v0.6.0 initializing
[DEBUG] Choosing subclass for https://bugzilla.redhat.com/xmlrpc.cgi
[DEBUG] Checking for RH Bugzilla method bugzilla.getProdInfo()
[DEBUG] rhbz=True
[DEBUG] Checking return value of Buzilla.version()
[DEBUG] bzversion='4.2.1-2.2'
[INFO] Chose subclass RHBugzilla v0.2
[DEBUG] request_url is https://bugzilla.redhat.com/xmlrpc.cgi
[DEBUG] send_cookies(): using existing cookiejar
[DEBUG] cookie_request headers currently: []
[DEBUG] cookie_request headers now: [('Cookie', 'Bugzilla_logincookie=7hPP2m473x; Bugzilla_login=319215')]
[DEBUG] sending cookie: Cookie=Bugzilla_logincookie=7hPP2m473x; Bugzilla_login=319215
[DEBUG] cookiejar now contains: .....
[DEBUG] Search result:
.....
Comment 1 Will Woods 2012-06-15 14:01:47 EDT

*** This bug has been marked as a duplicate of bug 825358 ***
Comment 2 Cole Robinson 2012-06-17 11:18:49 EDT
Reopening actually. User is claiming that the recent update pushed to EPEL is causing a regression here.

Dalibor, can you confirm that downgrading python-bugzilla makes that status-report command actually work? Or was this broken by the bugzilla.redhat.com upgrade?

Is there a git repo internally for this status-report command, so I can look at the code?

...but now that I'm looking at the python-bugzilla code, pre_translation in rhbugzilla.py needs to add query_format=advanced if anyone is manually passing in boolean charts.
Comment 3 Dalibor Pospíšil 2012-06-18 04:06:24 EDT
(In reply to comment #2)
> Dalibor, can you confirm that downgrading python-bugzilla makes that
> status-report command actually work? Or was this broken by the
> bugzilla.redhat.com upgrade?

Sure, I tried to downgrade the python-bugzilla, the correct output (Expected results) is from the downgraded version. Currently I use the old version since the new one does not work for me.

> Is there a git repo internally for this status-report command, so I can look
> at the code?

git://git.engineering.redhat.com/users/psplicha/apps
Comment 4 Cole Robinson 2012-12-30 17:33:41 EST
It looks like this was eventually worked around in the source script by not using the private _query method and passing query_format=advanced, so closing.

Note You need to log in before you can comment on or make changes to this bug.