Bug 832508 - 3.1 cannot register node: Unable to load the rest server module. Please make sure it is installed.
3.1 cannot register node: Unable to load the rest server module. Please make...
Status: CLOSED NEXTRELEASE
Product: oVirt
Classification: Community
Component: vdsm (Show other bugs)
3.1 RC
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Douglas Schilling Landgraf
Haim
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-15 11:07 EDT by Douglas Schilling Landgraf
Modified: 2014-01-12 19:52 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-17 13:59:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Douglas Schilling Landgraf 2012-06-15 11:07:29 EDT
Description of problem:

Try to register oVirt-Engine from the oVirt Node, vdsm-reg will complain about vdsm-rest not installed, from vdsm.reg log:

"Unable to load the rest  server module. Please make sure it is installed."

Reference:
http://www.mail-archive.com/users@ovirt.org/msg02005.html

Caused by:

vdsm/clientIF.py:
  if config.getboolean('vars', 'rest_enable'):
            try:
                self._loadBindingREST()
            except ImportError:
                self.log.error('Unable to load the rest server module. '
                               'Please make sure it is installed.')

Talked with aglitke, we are going to move to a warning message.
Comment 1 Douglas Schilling Landgraf 2012-06-15 11:29:15 EDT
Patch by Adam Litke:

rest: Change error to warning when binding not installed
http://gerrit.ovirt.org/#/c/5376/
Comment 2 Dan Kenigsberg 2012-06-17 13:59:16 EDT
That's no more than an annoying log line. No need to hurry it into ovirt-3.1.

Note You need to log in before you can comment on or make changes to this bug.