Bug 832515 - user data are not passed when creating an instance
user data are not passed when creating an instance
Status: CLOSED ERRATA
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-conductor (Show other bugs)
1.0.0
Unspecified Unspecified
unspecified Severity high
: 1.0.1
: ---
Assigned To: Angus Thomas
Rehana
: ZStream
Depends On: 831577
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-15 11:37 EDT by Chris Pelland
Modified: 2012-07-10 03:24 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
A code regression stopped user data parameters from being passed to Audrey. This update corrects the code regression and provides successful pass of user data.
Story Points: ---
Clone Of: 831577
Environment:
Last Closed: 2012-07-10 03:24:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Pelland 2012-06-15 11:37:12 EDT
+++ This bug was initially created as a clone of Bug #831577 +++

Conductor doesn't send userdata param when launching an instance, this causes that launch time params don't work then on launched instances.

This is a regression caused by a patch for 796528 (pushed to 1.0.1), original description can be found here: https://bugzilla.redhat.com/show_bug.cgi?id=796528#c26

Good news is that patch for this is really simple.

--- Additional comment from jprovazn@redhat.com on 2012-06-13 07:30:37 EDT ---

a patch sent: https://fedorahosted.org/pipermail/aeolus-devel/2012-June/010885.html

--- Additional comment from dgao@redhat.com on 2012-06-13 11:11:06 EDT ---

The patch looks good:


[root@10-16-120-124 ~]# audrey
[root@10-16-120-124 ~]# cat /var/log/audrey.log 
2012-06-13 11:10:19,924 - INFO    : audrey:1293 Invoked audrey_script_main
2012-06-13 11:10:20,147 - INFO    : audrey:1321 
<Instance of: CSClient
	Version: 1
	Config Server Endpoint: https://deaddonkey.usersys.redhat.com
	Config Server oAuth Key: 4fb4417e-b567-11e1-9376-e83935c21f2c
	Config Server oAuth Secret: 4P6KpUbrtDezDpSb4oocDxyn3gTRi9FRUylmCFvN0DPao7pkZA
	Config Server Params: 
	Config Server Configs: 
	Temporary Directory: 
	Tarball Name: 
eot>
2012-06-13 11:10:20,149 - INFO    : audrey:944 Invoked CSClient.get_cs_tooling()
2012-06-13 11:10:20,359 - INFO    : audrey:682 Invoked unpack_tooling()
2012-06-13 11:10:20,360 - INFO    : audrey:901 Invoked CSClient.get_cs_configs()
2012-06-13 11:10:20,564 - INFO    : audrey:916 Invoked CSClient.get_cs_params()
2012-06-13 11:10:20,771 - INFO    : audrey:520 Invoked generate_provides()
2012-06-13 11:10:21,163 - INFO    : audrey:931 Invoked CSClient.put_cs_params_values()

--- Additional comment from jprovazn@redhat.com on 2012-06-15 11:07:32 EDT ---

pushed to master, commit: 93f39f25ac386dabcef3b86afb4ad8e808207c8f
Comment 1 Tzu-Mainn Chen 2012-06-15 11:42:12 EDT
Pushed to 1.0.1
Comment 3 dgao 2012-06-18 17:11:58 EDT
Verified in


[root@qeblade38 ~]# rpm -qa | grep "conductor"
aeolus-conductor-0.8.30-1.el6_2.noarch
aeolus-conductor-daemons-0.8.30-1.el6_2.noarch
aeolus-conductor-doc-0.8.30-1.el6_2.noarch
Comment 4 dgao 2012-06-18 20:50:47 EDT
On second thought, maybe not....
Comment 5 dgao 2012-06-19 10:51:06 EDT
The reversal is caused by the floppyinject being removed from rhevm server. The original patch worked as intended. Flipping back to verified.
Comment 6 Dan Macpherson 2012-06-24 12:40:33 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
A code regression stopped user data parameters from being passed to Audrey. This update corrects the code regression and provides successful pass of user data.
Comment 8 errata-xmlrpc 2012-07-10 03:24:06 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-1063.html

Note You need to log in before you can comment on or make changes to this bug.