Bug 832533 - systemtap process probes stopped working after kernel-3.4.0-1.fc17 update
systemtap process probes stopped working after kernel-3.4.0-1.fc17 update
Status: CLOSED DUPLICATE of bug 832083
Product: Fedora
Classification: Fedora
Component: systemtap (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Frank Ch. Eigler
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-15 12:39 EDT by Scott Tsai
Modified: 2012-06-15 12:55 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-15 12:55:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Scott Tsai 2012-06-15 12:39:46 EDT
Description of problem:
systemtap process probes stopped working after the kernel-3.4.0-1.fc17 update because the utrace patch was removed. User space process probes worked on kernel-3.3.7-1.fc17.

Version-Release number of selected component (if applicable):
kernel-3.4.0-1.fc17.x86_64
systemtap-1.7-7.fc17.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. Boot kernel-3.4.0-1.fc17.x86_64
2. sudo stap -v -e 'probe process("cat").function("*") { printf("%s\n", probefunc()); }'

  
Actual results:

Pass 1: parsed user script and 91 library script(s) using 206036virt/27876res/3008shr kb, in 80usr/10sys/88real ms.
Pass 2: analyzed script: 1 probe(s), 0 function(s), 0 embed(s), 0 global(s) using 207080virt/29420res/3600shr kb, in 10usr/0sys/4real ms.
Pass 3: translated to C into "/tmp/stapPUgDY0/stap_a4376c57cd23fb8ce2154b598b578c63_810_src.c" using 343340virt/29860res/3988shr kb, in 0usr/40sys/49real ms.
user-space facilities not available without kernel CONFIG_UTRACE
Pass 4: compiled C into "stap_a4376c57cd23fb8ce2154b598b578c63_810.ko" in 0usr/0sys/0real ms.
Pass 4: compilation failed.  Try again with another '--vp 0001' option.


Additional info:
The utrace patch was removed from the F17 kernel package in this changeset: http://pkgs.fedoraproject.org/gitweb/?p=kernel.git;a=blobdiff;f=kernel.spec;h=77096c6146afb552cd60d448717bde3914b447c5;hp=aa3a86b9535321e35ca63d370e682bb37b714c0a;hb=39acffae2628af168c9351183e7b45b06e9a3116;hpb=506e7ae6a2a52c25e9c6da6fa815a18f39ab347e
Comment 1 Frank Ch. Eigler 2012-06-15 12:55:04 EDT

*** This bug has been marked as a duplicate of bug 832083 ***

Note You need to log in before you can comment on or make changes to this bug.