Bug 832541 - Displaying long error message on clicking monitor page for Global profile user
Displaying long error message on clicking monitor page for Global profile user
Status: CLOSED ERRATA
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-conductor (Show other bugs)
1.0.0
Unspecified Unspecified
unspecified Severity medium
: 1.0.1
: ---
Assigned To: Angus Thomas
Rehana
: ZStream
Depends On: 831057
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-15 13:13 EDT by Chris Pelland
Modified: 2012-07-10 03:24 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
A data query with an ambiguous ORDER BY caused a long error message to appear when viewing the Monitor page for instances in a pending state. This update fixes the query and removes the error.
Story Points: ---
Clone Of: 831057
Environment:
Last Closed: 2012-07-10 03:24:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
no err (208.03 KB, image/png)
2012-06-18 08:58 EDT, Aziza Karol
no flags Details

  None (edit)
Description Chris Pelland 2012-06-15 13:13:06 EDT
+++ This bug was initially created as a clone of Bug #831057 +++

Created attachment 591098 [details]
error_msg

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1.Create new user with Global profile user (default role)
2.Login to Conductor as Global profile user
3.Start a new VM
4.When the VM is in pending state, click on monitor
  
Actual results:
It will display a long error message on the UI

Expected results:
It should not display any error message on click of monitor .

PFA: attacher error screen shot (error_msg.png) and rails log(Rails_log)

Additional info:
 rpm -qa | grep aeolus
aeolus-configure-2.5.7-1.el6_3.noarch
aeolus-all-0.8.27-1.el6_3.noarch
aeolus-conductor-0.8.27-1.el6_3.noarch
aeolus-conductor-doc-0.8.27-1.el6_3.noarch
aeolus-conductor-daemons-0.8.27-1.el6_3.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
rubygem-aeolus-cli-0.3.3-1.el6_3.noarch

--- Additional comment from redakkan@redhat.com on 2012-06-12 02:08:48 EDT ---

Created attachment 591100 [details]
Rails_log

--- Additional comment from redakkan@redhat.com on 2012-06-13 09:26:33 EDT ---

this error is observed for global zone user also

--- Additional comment from sseago@redhat.com on 2012-06-15 11:42:04 EDT ---

Subject: [PATCH conductor] bug 831057: fix ambiguous order by name

https://bugzilla.redhat.com/show_bug.cgi?id=831057

There was a deployments 'order by' clause that just listed 'name'
which was ambiguous (since the joined pool and pool_families models
also have a 'name' column)
---
 src/app/models/pool.rb |    2 +-
 1 files changed, 1 insertions(+), 1 deletions(-)

diff --git a/src/app/models/pool.rb b/src/app/models/pool.rb
index 6bd3605..c4acbce 100644
--- a/src/app/models/pool.rb
+++ b/src/app/models/pool.rb
@@ -124,7 +124,7 @@ class Pool < ActiveRecord::Base
 
     if options[:with_deployments]
       result[:deployments] = deployments.list_for_user(options[:current_user], Privilege::VIEW).
-                                         order('name asc').
+                                         order('deployments.name asc').
                                          paginate(:page => options[:page], :per_page => options[:per_page]).
                                          map {|d| d.as_json}
     end
--

--- Additional comment from sseago@redhat.com on 2012-06-15 12:15:17 EDT ---

Pushed to 1.0.1 at 22ffc7b96288a21b09f558c852309488025df0a3
Comment 1 Tzu-Mainn Chen 2012-06-15 13:15:31 EDT
Set to modified
Comment 3 Aziza Karol 2012-06-18 08:57:21 EDT
No error message displayed on clicking monitor page for Global profile user.
see attached screenshot.

verified on:
rpm -qa | grep aeolus
aeolus-conductor-daemons-0.8.30-1.el6_2.noarch
aeolus-configure-2.5.7-2.el6_2.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
aeolus-conductor-0.8.30-1.el6_2.noarch
rubygem-aeolus-cli-0.3.3-2.el6_2.noarch
aeolus-conductor-doc-0.8.30-1.el6_2.noarch
aeolus-all-0.8.30-1.el6_2.noarch
Comment 4 Aziza Karol 2012-06-18 08:58:03 EDT
Created attachment 592633 [details]
no err
Comment 5 Dan Macpherson 2012-06-24 12:47:07 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
A data query with an ambiguous ORDER By caused an long error message to appear when viewing the Monitor page for instances in a pending state. This update fixes the query and removes the error.
Comment 6 Dan Macpherson 2012-06-24 12:59:23 EDT
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1 +1 @@
-A data query with an ambiguous ORDER By caused an long error message to appear when viewing the Monitor page for instances in a pending state. This update fixes the query and removes the error.+A data query with an ambiguous ORDER BY caused a long error message to appear when viewing the Monitor page for instances in a pending state. This update fixes the query and removes the error.
Comment 8 errata-xmlrpc 2012-07-10 03:24:08 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-1063.html

Note You need to log in before you can comment on or make changes to this bug.