Bug 832696 - [abrt] ekiga-3.3.2-7.fc17: PSocket::Select: Process /usr/bin/ekiga was killed by signal 11 (SIGSEGV)
[abrt] ekiga-3.3.2-7.fc17: PSocket::Select: Process /usr/bin/ekiga was killed...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ekiga (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Robinson
Fedora Extras Quality Assurance
abrt_hash:a407afaf2650d374495ad961efa...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-16 12:55 EDT by Bruno Martins
Modified: 2013-03-03 17:37 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-03 17:30:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (63.46 KB, text/plain)
2012-06-16 12:55 EDT, Bruno Martins
no flags Details
File: maps (70.75 KB, text/plain)
2012-06-16 12:55 EDT, Bruno Martins
no flags Details
File: dso_list (10.72 KB, text/plain)
2012-06-16 12:55 EDT, Bruno Martins
no flags Details
File: build_ids (5.57 KB, text/plain)
2012-06-16 12:55 EDT, Bruno Martins
no flags Details

  None (edit)
Description Bruno Martins 2012-06-16 12:55:47 EDT
libreport version: 2.0.10
abrt_version:   2.0.10
backtrace_rating: 4
cmdline:        ekiga
comment:        Just closed ekiga.
crash_function: PSocket::Select
executable:     /usr/bin/ekiga
kernel:         3.4.0-1.fc17.x86_64
pid:            1864
pwd:            /home/skorzen
time:           Sat 16 Jun 2012 12:15:20 PM WEST
uid:            1000
username:       skorzen

backtrace:      Text file, 64980 bytes
build_ids:      Text file, 5699 bytes
dso_list:       Text file, 10982 bytes
maps:           Text file, 72447 bytes

cgroup:
:9:perf_event:/
:8:blkio:/
:7:net_cls:/
:6:freezer:/
:5:devices:/
:4:memory:/
:3:cpuacct,cpu:/
:2:cpuset:/
:1:name=systemd:/user/skorzen/2

core_backtrace:
:3fd7671dcde06e21ecf52fa2936004fe85846127 0x335767 PSocket::Select(PSocket::SelectList&, libpt.so.2.10.2 -
:3fd7671dcde06e21ecf52fa2936004fe85846127 0x3770ee PSocket::Select(PSocket&, libpt.so.2.10.2 -
:b0829f36af8b7a016bc0f3e528fe10ebb313959f 0x576391 RTP_UDP::Internal_WaitForPDU(PUDPSocket&, libopal.so.3.10.2 -
:b0829f36af8b7a016bc0f3e528fe10ebb313959f 0x57da5d RTP_UDP::WaitForPDU(PUDPSocket&, libopal.so.3.10.2 -
:b0829f36af8b7a016bc0f3e528fe10ebb313959f 0x576dea RTP_UDP::Internal_ReadData(RTP_DataFrame&) libopal.so.3.10.2 -
:b0829f36af8b7a016bc0f3e528fe10ebb313959f 0x57dac3 RTP_UDP::ReadData(RTP_DataFrame&) libopal.so.3.10.2 -
:b0829f36af8b7a016bc0f3e528fe10ebb313959f 0x5843e3 RTP_JitterBuffer::OnReadPacket(RTP_DataFrame&) libopal.so.3.10.2 -
:b0829f36af8b7a016bc0f3e528fe10ebb313959f 0x584659 OpalJitterBufferThread::JitterThreadMain(PThread&, libopal.so.3.10.2 -
:3fd7671dcde06e21ecf52fa2936004fe85846127 0x3483cf PThread::PX_ThreadStart(void*) libpt.so.2.10.2 -
:73777e822e00ca152ffca281ab0ace0cb498ec48 0x7d14 start_thread libpthread.so.0 -
:a4ec59d7fc9c453fb4287d7ebc5fcf6579792e65 0xf199d clone libc.so.6 -

environ:
:XDG_VTNR=1
:XDG_SESSION_ID=2
:HOSTNAME=g62
:IMSETTINGS_INTEGRATE_DESKTOP=yes
:SHELL=/bin/bash
:TERM=dumb
:HISTSIZE=1000
:GNOME_KEYRING_CONTROL=/run/user/skorzen/keyring-SAmUyG
:QT_GRAPHICSSYSTEM_CHECKED=1
:IMSETTINGS_MODULE=none
:USER=skorzen
:USERNAME=skorzen
:MAIL=/var/spool/mail/skorzen
:PATH=/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/home/skorzen/.local/bin:/home/skorzen/bin
:DESKTOP_SESSION=gnome
:QT_IM_MODULE=xim
:PWD=/home/skorzen
:XMODIFIERS=@im=none
:GNOME_KEYRING_PID=1118
:LANG=en_US.UTF-8
:GDMSESSION=gnome
:HISTCONTROL=ignoredups
:XDG_SEAT=seat0
:HOME=/home/skorzen
:SHLVL=1
:LOGNAME=skorzen
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-KBvxAP63Uj,guid=75446900078d2afff40b043100000021
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:WINDOWPATH=1
:XDG_RUNTIME_DIR=/run/user/skorzen
:DISPLAY=:0
:XAUTHORITY=/var/run/gdm/auth-for-skorzen-ldkLyg/database
:_=/usr/bin/gnome-session
:GNOME_DESKTOP_SESSION_ID=this-is-deprecated
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/1122,unix/unix:/tmp/.ICE-unix/1122
:SSH_AUTH_SOCK=/run/user/skorzen/keyring-SAmUyG/ssh
:GPG_AGENT_INFO=/run/user/skorzen/keyring-SAmUyG/gpg:0:1
:GJS_DEBUG_OUTPUT=stderr
:'GJS_DEBUG_TOPICS=JS ERROR;JS LOG'
:GIO_LAUNCHED_DESKTOP_FILE=/usr/share/applications/gnome-ekiga.desktop
:GIO_LAUNCHED_DESKTOP_FILE_PID=1864
:DESKTOP_STARTUP_ID=gnome-shell-1333-g62-ekiga-24_TIME127893865

gconf_subtree:
: /apps/ekiga/protocols:
:  accounts_list = [1|1|6a42550d-a8b5-e111-937d-c446197e0a42|Ekiga.net|SIP|ekiga.net|ekiga.net|skorzen|skorzen|vudajum6s|3600]
: /apps/ekiga/general:
:  kind_of_net = 5
:  version = 3032
:  /apps/ekiga/general/nat:
:   enable_stun = false
:  /apps/ekiga/general/user_interface:
:   /apps/ekiga/general/user_interface/video_display:
:    video_view = 0
:    zoom = 100
:   /apps/ekiga/general/user_interface/main_window:
:    size = 1366,711
:    panel_section = 0
:    position = 0,27
:   /apps/ekiga/general/user_interface/accounts_window:
:    size = 730,324
:    position = 489,261
:   /apps/ekiga/general/user_interface/preferences_window:
:    size = 700,411
:    position = 332,157
:   /apps/ekiga/general/user_interface/chat_window:
:    size = 366,240
:    position = 352,243
:  /apps/ekiga/general/sound_events:
:   output_device = Default (PTLIB/ALSA)
:  /apps/ekiga/general/personal_data:
:   full_name = Bruno Martins
: /apps/ekiga/contacts:
:  ldap_servers = <?xml version="1.0"?>
:<list><server><name>Ekiga.net Directory</name><uri>ldap://ekiga.net/dc=ekiga,dc=net?givenName,telephoneNumber?sub?(cn=$)</uri><authcID></authcID><password></password></server></list>
:
:  roster = <?xml version="1.0"?>
:<list><entry uri="sip:500@ekiga.net" preferred="false"><name>Echo test</name><group>Services</group></entry><entry uri="sip:501@ekiga.net" preferred="false"><name>Conference room</name><group>Services</group></entry><entry uri="sip:520@ekiga.net" preferred="false"><name>Call back test</name><group>Services</group></entry></list>
:
:  call_history = <?xml version="1.0"?>
:<list><entry uri="sip:520@ekiga.net" type="1"><name>sip:520@ekiga.net</name><call_start>1339799722</call_start><call_duration></call_duration></entry><entry uri="sip:520@ekiga.net" type="1"><name>sip:520@ekiga.net</name><call_start>1339799724</call_start><call_duration></call_duration></entry><entry uri="sip:500@ekiga.net" type="1"><name>sip:500@ekiga.net</name><call_start>1339799825</call_start><call_duration></call_duration></entry><entry uri="sip:500@ekiga.net" type="1"><name>sip:500@ekiga.net</name><call_start>1339799864</call_start><call_duration>00:00:19</call_duration></entry><entry uri="sip:500@ekiga.net" type="1"><name>sip:500@ekiga.net</name><call_start>1339799911</call_start><call_duration>00:00:02</call_duration></entry></list>
:
: /apps/ekiga/codecs:
:  /apps/ekiga/codecs/video:
:   maximum_video_tx_bitrate = 384
:   media_list = [h261*90000*0*H.323 SIP*1,theora*90000*0*SIP*1]
:  /apps/ekiga/codecs/audio:
:   media_list = [G722*16000*1*H.323 SIP*1,G7221*16000*1*H.323 SIP*1,AMR-WB*16000*1*H.323 SIP*1,Speex*16000*1*H.323 SIP*1,PCMA*8000*1*H.323 SIP*1,PCMU*8000*1*H.323 SIP*1,G726-16*8000*1*H.323 SIP*1,G726-24*8000*1*H.323 SIP*1,G726-32*8000*1*H.323 SIP*1,G726-40*8000*1*H.323 SIP*1,gsm*8000*1*H.323 SIP*1,ms-gsm*8000*1*H.323*1,Speex*8000*1*H.323 SIP*1,iLBC*8000*1*H.323 SIP*1]
:   enable_echo_cancellation = false
: /apps/ekiga/devices:
:  /apps/ekiga/devices/video:
:   size = 3
:   input_device = HP Webcam-101 (PTLIB/V4L2)
:  /apps/ekiga/devices/audio:
:   output_device = Default (PTLIB/ALSA)
:   input_device = Default (PTLIB/ALSA)

limits:
:Limit                     Soft Limit           Hard Limit           Units     
:Max cpu time              unlimited            unlimited            seconds   
:Max file size             unlimited            unlimited            bytes     
:Max data size             unlimited            unlimited            bytes     
:Max stack size            8388608              unlimited            bytes     
:Max core file size        0                    unlimited            bytes     
:Max resident set          unlimited            unlimited            bytes     
:Max processes             1024                 29869                processes 
:Max open files            1024                 4096                 files     
:Max locked memory         65536                65536                bytes     
:Max address space         unlimited            unlimited            bytes     
:Max file locks            unlimited            unlimited            locks     
:Max pending signals       29869                29869                signals   
:Max msgqueue size         819200               819200               bytes     
:Max nice priority         0                    0                    
:Max realtime priority     0                    0                    
:Max realtime timeout      unlimited            unlimited            us        

open_fds:
:0:/dev/null
:1:/home/skorzen/.xsession-errors (deleted)
:2:/home/skorzen/.xsession-errors (deleted)
:3:socket:[736300]
:4:anon_inode:[eventfd]
:5:socket:[735295]

smolt_data:
:
:
:General
:=================================
:UUID: a28c7ee6-51b4-4254-8872-88dc2c98fbf4
:OS: Fedora release 17 (Beefy Miracle)
:Default run level: Unknown
:Language: en_US.UTF-8
:Platform: x86_64
:BogoMIPS: 4533.32
:CPU Vendor: GenuineIntel
:CPU Model: Intel(R) Core(TM) i3 CPU       M 350  @ 2.27GHz
:CPU Stepping: 5
:CPU Family: 6
:CPU Model Num: 37
:Number of CPUs: 4
:CPU Speed: 2266
:System Memory: 3755
:System Swap: 0
:Vendor: Hewlett-Packard
:System: HP G62 Notebook PC 0594110000252710001020100
:Form factor: Notebook
:Kernel: 3.4.0-1.fc17.x86_64
:SELinux Enabled: 0
:SELinux Policy: targeted
:SELinux Enforce: Unknown
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(5348:18215:4156:5212) pci, bcma-pci-bridge, NETWORK, BCM4313 802.11b/g/n Wireless LAN Controller
:(4332:33078:4156:5177) pci, r8169, ETHERNET, RTL8101E/RTL8102E PCI Express Fast Ethernet controller
:(32902:70:4156:5177) pci, i915, VIDEO, Core Processor Integrated Graphics Controller
:(32902:15145:4156:5177) pci, ahci, STORAGE, 5 Series/3400 Series Chipset 4 port SATA AHCI Controller
:(32902:15170:4156:5177) pci, pcieport, PCI/PCI, 5 Series/3400 Series Chipset PCI Express Root Port 1
:(32902:15113:4156:5177) pci, None, PCI/ISA, Mobile 5 Series Chipset LPC Interface Controller
:(32902:11537:4156:5177) pci, None, HOST/PCI, Core Processor QPI Physical 0
:(32902:11536:4156:5177) pci, None, HOST/PCI, Core Processor QPI Link 0
:(32902:11539:4156:5177) pci, None, HOST/PCI, Core Processor Reserved
:(32902:15190:4156:5177) pci, snd_hda_intel, MULTIMEDIA, 5 Series/3400 Series Chipset High Definition Audio
:(32902:15174:4156:5177) pci, pcieport, PCI/PCI, 5 Series/3400 Series Chipset PCI Express Root Port 3
:(32902:15152:4156:5177) pci, None, SERIAL, 5 Series/3400 Series Chipset SMBus Controller
:(32902:9288:4156:5177) pci, None, PCI/PCI, 82801 Mobile PCI Bridge
:(32902:11538:4156:5177) pci, None, HOST/PCI, Core Processor Reserved
:(32902:15164:4156:5177) pci, ehci_hcd, USB, 5 Series/3400 Series Chipset USB2 Enhanced Host Controller
:(32902:15156:4156:5177) pci, ehci_hcd, USB, 5 Series/3400 Series Chipset USB2 Enhanced Host Controller
:(32902:68:4156:5177) pci, agpgart-intel, HOST/PCI, Core Processor DRAM Controller
:(32902:15204:4156:5177) pci, None, SIMPLE, 5 Series/3400 Series Chipset HECI Controller
:(32902:11521:4156:5177) pci, None, HOST/PCI, Core Processor QuickPath Architecture System Address Decoder
:(32902:11362:4156:5177) pci, None, HOST/PCI, Core Processor QuickPath Architecture Generic Non-core Registers
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/mapper/vg_g62-lv_root / ext4 4096 4096 13092026 11560928 11429878 3276800 3137742 3137742
:/dev/sda1 /boot ext4 1024 1024 508745 423731 398131 128016 127660 127660
:/dev/mapper/vg_g62-lv_home /home ext4 4096 4096 63348857 46801807 43630684 15859712 15851401 15851401
:

var_log_messages:
:Jun 15 23:32:59 g62 yum[1801]: Installed: ekiga-3.3.2-7.fc17.x86_64
:Jun 16 12:15:20 g62 kernel: [173274.008303] ekiga[1946]: segfault at f8 ip 00007ff41fddf767 sp 00007ff3ee04e060 error 4 in libpt.so.2.10.2.#prelink#.54lAzb (deleted)[7ff41faaa000+462000]
:Jun 16 12:15:20 g62 abrt[4841]: File '/usr/bin/ekiga' seems to be deleted
:Jun 16 12:15:21 g62 abrt[4841]: Saved core dump of pid 1864 (/usr/bin/ekiga) to /var/spool/abrt/ccpp-2012-06-16-12:15:20-1864 (66625536 bytes)
Comment 1 Bruno Martins 2012-06-16 12:55:53 EDT
Created attachment 592324 [details]
File: backtrace
Comment 2 Bruno Martins 2012-06-16 12:55:55 EDT
Created attachment 592325 [details]
File: maps
Comment 3 Bruno Martins 2012-06-16 12:55:57 EDT
Created attachment 592326 [details]
File: dso_list
Comment 4 Bruno Martins 2012-06-16 12:55:59 EDT
Created attachment 592327 [details]
File: build_ids
Comment 5 Fedora Update System 2013-02-21 11:10:59 EST
ptlib-2.10.10-1.fc17,opal-3.10.10-1.fc17,ekiga-4.0.1-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/ptlib-2.10.10-1.fc17,opal-3.10.10-1.fc17,ekiga-4.0.1-1.fc17
Comment 6 Fedora Update System 2013-02-21 11:15:20 EST
ptlib-2.10.10-1.fc18,opal-3.10.10-1.fc18,ekiga-4.0.1-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/ptlib-2.10.10-1.fc18,opal-3.10.10-1.fc18,ekiga-4.0.1-1.fc18
Comment 7 Fedora Update System 2013-02-24 03:29:52 EST
Package ptlib-2.10.10-1.fc17, opal-3.10.10-1.fc17, ekiga-4.0.1-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing ptlib-2.10.10-1.fc17 opal-3.10.10-1.fc17 ekiga-4.0.1-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-2890/ptlib-2.10.10-1.fc17,opal-3.10.10-1.fc17,ekiga-4.0.1-1.fc17
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2013-03-03 17:30:34 EST
ptlib-2.10.10-1.fc18, opal-3.10.10-1.fc18, ekiga-4.0.1-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2013-03-03 17:37:39 EST
ptlib-2.10.10-1.fc17, opal-3.10.10-1.fc17, ekiga-4.0.1-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.