Bug 83272 - gcc tried to access a negative line number in a header file during a 'make'
Summary: gcc tried to access a negative line number in a header file during a 'make'
Status: CLOSED DUPLICATE of bug 83271
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gcc3   
(Show other bugs)
Version: 8.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-01 06:50 UTC by Robert Hanson
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 18:51:32 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Robert Hanson 2003-02-01 06:50:25 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
when trying to compile an app on my default RH 8.0 system, I received an access
error to a negative line number in a header file. 



Version-Release number of selected component (if applicable):
3.2

How reproducible:
Always

Steps to Reproduce:
1.use ./configure
2.use make
3.get error
    

Actual Results:  received error

Expected Results:  this header should've been accessed correctly, and
compilation should've continued.

Additional info:

gcc -c -O4 -march=athlon-xp -mcpu=athlon-xp -pipe -ffast-math
-fomit-frame-pointer -D_REENTRANT -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64
-Ilibmpdemux -Iloader -Ilibvo -I/usr/include/freetype2     -o mplayer.o mplayer.c
In file included from cfg-mplayer.h:126,
                 from mplayer.c:503:
libaf/af.h:-47250: internal error: Floating point exception
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.
make: *** [mplayer.o] Error 1

quite obviously, there is no line "-47250" and this file, af.h, is maybe 300
lines long.

Comment 1 Jakub Jelinek 2003-02-01 14:16:20 UTC

*** This bug has been marked as a duplicate of 83271 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:51:32 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.