Bug 832749 - [abrt] mdadm-3.2.3-6.fc17: __GI_raise: Process /usr/sbin/mdadm was killed by signal 6 (SIGABRT)
[abrt] mdadm-3.2.3-6.fc17: __GI_raise: Process /usr/sbin/mdadm was killed by ...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: mdadm (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jes Sorensen
Fedora Extras Quality Assurance
abrt_hash:36b1722fbbd0a5aebf80ed807dd...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-17 03:05 EDT by Frank Crawford
Modified: 2012-06-26 10:38 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-26 10:38:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: backtrace (19.60 KB, text/plain)
2012-06-17 03:05 EDT, Frank Crawford
no flags Details
File: coredump (552.00 KB, text/plain)
2012-06-17 03:05 EDT, Frank Crawford
no flags Details
File: var_log_messages (8.37 KB, text/plain)
2012-06-17 03:06 EDT, Frank Crawford
no flags Details

  None (edit)
Description Frank Crawford 2012-06-17 03:05:44 EDT
libreport version: 2.0.10
abrt_version:   2.0.10
backtrace_rating: 4
cmdline:        /sbin/mdadm --monitor --scan -f --pid-file=/var/run/mdadm/mdadm.pid
crash_function: __GI_raise
executable:     /usr/sbin/mdadm
kernel:         3.4.2
pid:            1151
pwd:            /
smolt_data:     Unable to save UUID to /etc/smolt/hw-uuid.  Please run once as root.
time:           Sun 17 Jun 2012 01:27:31 EST
uid:            0
username:       root

backtrace:      Text file, 20067 bytes
var_log_messages: Text file, 8571 bytes

cgroup:
:9:perf_event:/
:8:blkio:/
:7:net_cls:/
:6:freezer:/
:5:devices:/
:4:memory:/
:3:cpuacct,cpu:/system/mdmonitor.service
:2:cpuset:/
:1:name=systemd:/system/mdmonitor.service

core_backtrace:
:a4ec59d7fc9c453fb4287d7ebc5fcf6579792e65 0x35965 raise libc.so.6 -
:a4ec59d7fc9c453fb4287d7ebc5fcf6579792e65 0x37118 abort libc.so.6 -
:a4ec59d7fc9c453fb4287d7ebc5fcf6579792e65 0x7568b __libc_message libc.so.6 -
:a4ec59d7fc9c453fb4287d7ebc5fcf6579792e65 0x1097e7 __fortify_fail libc.so.6 -
:a4ec59d7fc9c453fb4287d7ebc5fcf6579792e65 0x1079a0 __chk_fail libc.so.6 -
:a4ec59d7fc9c453fb4287d7ebc5fcf6579792e65 0x106e29 _IO_str_chk_overflow libc.so.6 -
:a4ec59d7fc9c453fb4287d7ebc5fcf6579792e65 0x78f0b _IO_default_xsputn_internal libc.so.6 -
:a4ec59d7fc9c453fb4287d7ebc5fcf6579792e65 0x46e78 vfprintf libc.so.6 -
:a4ec59d7fc9c453fb4287d7ebc5fcf6579792e65 0x106ec7 __vsprintf_chk libc.so.6 -
:a4ec59d7fc9c453fb4287d7ebc5fcf6579792e65 0x106e0d __sprintf_chk libc.so.6 -
:0fcc31492c421ca63c9213c9e145530131c71eb8 0x24e94 - [exe] -
:0fcc31492c421ca63c9213c9e145530131c71eb8 0x2542d - [exe] -
:0fcc31492c421ca63c9213c9e145530131c71eb8 0x4e50 - [exe] -

dso_list:
:/usr/lib64/libgcc_s-4.7.0-20120507.so.1 libgcc-4.7.0-5.fc17.x86_64 (Fedora Project) 1338791676
:/usr/lib64/libc-2.15.so glibc-2.15-37.fc17.x86_64 (Fedora Project) 1338791713
:/usr/sbin/mdadm mdadm-3.2.3-6.fc17.x86_64 (Fedora Project) 1338793788
:/usr/lib64/ld-2.15.so glibc-2.15-37.fc17.x86_64 (Fedora Project) 1338791713

environ:
:SYSFONT=latarcyrheb-sun16
:PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin
:LANG=en_AU.UTF-8
:KEYTABLE=us
:BOOT_IMAGE=/vmlinuz

event_log:
:2012-06-17-17:02:04> Querying server settings
:2012-06-17-17:02:06  Preparing an archive to upload
:2012-06-17-17:02:07  Uploading 32564 bytes
:2012-06-17-17:02:07  Upload successful
:2012-06-17-17:02:08  Retrace job started
:2012-06-17-17:02:19  Initializing virtual root
:2012-06-17-17:02:30  Initializing virtual root
:2012-06-17-17:02:41  Initializing virtual root
:2012-06-17-17:02:52  Initializing virtual root
:2012-06-17-17:03:03  Initializing virtual root
:2012-06-17-17:03:14  Initializing virtual root
:2012-06-17-17:03:25  Retrace job finished successfully
:2012-06-17-17:03:51* (exited with 9)

limits:
:Limit                     Soft Limit           Hard Limit           Units     
:Max cpu time              unlimited            unlimited            seconds   
:Max file size             unlimited            unlimited            bytes     
:Max data size             unlimited            unlimited            bytes     
:Max stack size            8388608              unlimited            bytes     
:Max core file size        0                    unlimited            bytes     
:Max resident set          unlimited            unlimited            bytes     
:Max processes             127914               127914               processes 
:Max open files            1024                 4096                 files     
:Max locked memory         65536                65536                bytes     
:Max address space         unlimited            unlimited            bytes     
:Max file locks            unlimited            unlimited            locks     
:Max pending signals       127914               127914               signals   
:Max msgqueue size         819200               819200               bytes     
:Max nice priority         0                    0                    
:Max realtime priority     0                    0                    
:Max realtime timeout      unlimited            unlimited            us        

maps:
:00400000-00467000 r-xp 00000000 fd:04 412800                             /usr/sbin/mdadm
:00667000-0066e000 rw-p 00067000 fd:04 412800                             /usr/sbin/mdadm
:0066e000-00682000 rw-p 00000000 00:00 0 
:022ee000-0230f000 rw-p 00000000 00:00 0                                  [heap]
:0230f000-02334000 rw-p 00000000 00:00 0                                  [heap]
:3c66800000-3c66820000 r-xp 00000000 fd:04 393232                         /usr/lib64/ld-2.15.so
:3c66a1f000-3c66a20000 r--p 0001f000 fd:04 393232                         /usr/lib64/ld-2.15.so
:3c66a20000-3c66a21000 rw-p 00020000 fd:04 393232                         /usr/lib64/ld-2.15.so
:3c66a21000-3c66a22000 rw-p 00000000 00:00 0 
:3c67000000-3c671ac000 r-xp 00000000 fd:04 393234                         /usr/lib64/libc-2.15.so
:3c671ac000-3c673ac000 ---p 001ac000 fd:04 393234                         /usr/lib64/libc-2.15.so
:3c673ac000-3c673b0000 r--p 001ac000 fd:04 393234                         /usr/lib64/libc-2.15.so
:3c673b0000-3c673b2000 rw-p 001b0000 fd:04 393234                         /usr/lib64/libc-2.15.so
:3c673b2000-3c673b7000 rw-p 00000000 00:00 0 
:3c68800000-3c68815000 r-xp 00000000 fd:04 394988                         /usr/lib64/libgcc_s-4.7.0-20120507.so.1
:3c68815000-3c68a14000 ---p 00015000 fd:04 394988                         /usr/lib64/libgcc_s-4.7.0-20120507.so.1
:3c68a14000-3c68a15000 rw-p 00014000 fd:04 394988                         /usr/lib64/libgcc_s-4.7.0-20120507.so.1
:7f62163bf000-7f62163c2000 rw-p 00000000 00:00 0 
:7f621640e000-7f621640f000 rw-p 00000000 00:00 0 
:7f621640f000-7f6216410000 rw-p 00000000 00:00 0 
:7fff3102a000-7fff3104b000 rw-p 00000000 00:00 0                          [stack]
:7fff311ff000-7fff31200000 r-xp 00000000 00:00 0                          [vdso]
:ffffffffff600000-ffffffffff601000 r-xp 00000000 00:00 0                  [vsyscall]

open_fds:
:0:/dev/null
:pos:	0
:flags:	0100002
:1:/dev/null
:pos:	0
:flags:	0100002
:2:/dev/null
:pos:	0
:flags:	0100002
:3:/dev/md5
:pos:	0
:flags:	02100000
:4:/proc/mdstat
:pos:	356
:flags:	02100000
Comment 1 Frank Crawford 2012-06-17 03:05:49 EDT
Created attachment 592377 [details]
File: backtrace
Comment 2 Frank Crawford 2012-06-17 03:05:58 EDT
Created attachment 592378 [details]
File: coredump
Comment 3 Frank Crawford 2012-06-17 03:06:00 EDT
Created attachment 592379 [details]
File: var_log_messages
Comment 4 Jes Sorensen 2012-06-18 03:29:50 EDT
I believe this problem may be fixed by the mdadm-3.2.5 update found
in updates testing.

https://admin.fedoraproject.org/updates/FEDORA-2012-8988/mdadm-3.2.5-1.fc17

or run 'yum --enablerepo=updates-testing install mdadm'

If you see this again after updating to mdadm-3.2.5, please make sure
to install the debuginfo package and report the backtrace with that.

Thanks,
Jes
Comment 5 Chris Siebenmann 2012-06-26 10:22:11 EDT
The updates-testing mdadm fixed what I think is this problem for me. In
my case, mdadm monitoring would die with a SIGABRT shortly after the
first scan finished in the weekly 'check all RAID arrays' cron job.
I installed the updated mdadm (and restarted mdmonitor.service), ran
/usr/sbin/raid-check by hand, and mdadm monitoring is still alive and
happy.
Comment 6 Jes Sorensen 2012-06-26 10:38:12 EDT
Excellent!

I was suspecting that could be the case as I know there is a fix for mdmon
crashes in that update.

FWIW I just poushed mdadm-3.2.5-3 out however the fixes are minor.

I'll close this bug since it seems to work for you. If you hit the issue
again please reopen it or file a new bug.

Cheers,
Jes

Note You need to log in before you can comment on or make changes to this bug.