Bug 832768 - [abrt]: WARNING: at drivers/net/wireless/iwlwifi/iwl-agn-tx.c:397 iwlagn_tx_skb+0xd3a/0xdb0 [iwlwifi]()
[abrt]: WARNING: at drivers/net/wireless/iwlwifi/iwl-agn-tx.c:397 iwlagn_tx_s...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
abrt_hash:fe2505c6db5f5404e134bf787a3...
:
: 820165 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-17 05:35 EDT by Matthias Kuhn
Modified: 2012-07-27 10:48 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-27 10:48:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthias Kuhn 2012-06-17 05:35:57 EDT
libreport version: 2.0.10
cmdline:        BOOT_IMAGE=/vmlinuz-3.3.7-1.fc16.x86_64 root=UUID=56059921-0758-401e-b6b3-a96e654712f4 ro rd.md=0 rd.lvm=0 rd.dm=0 quiet KEYTABLE=sg SYSFONT=latarcyrheb-sun16 rhgb rd.luks=0 LANG=en_US.UTF-8 processor.max_cstate=3

backtrace:
:WARNING: at drivers/net/wireless/iwlwifi/iwl-agn-tx.c:397 iwlagn_tx_skb+0xd3a/0xdb0 [iwlwifi]()
:Hardware name: 2815A29
:Tx while agg.state = 2
:Modules linked in: tcp_lp ppdev parport_pc lp parport fuse ebtable_nat ebtables ipt_MASQUERADE iptable_nat nf_nat xt_CHECKSUM iptable_mangle bridge stp llc fcoe lockd libfcoe libfc scsi_transport_fc scsi_tgt be2iscsi iscsi_boot_sysfs bnx2i cnic uio cxgb4i cxgb4 cxgb3i libcxgbi cxgb3 mdio ib_iser rdma_cm ib_cm iw_cm ib_sa ib_mad ib_core ib_addr iscsi_tcp libiscsi_tcp libiscsi scsi_transport_iscsi ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 ip6table_filter ip6_tables nf_conntrack_ipv4 nf_defrag_ipv4 xt_state nf_conntrack arc4 uvcvideo videobuf2_core videodev media videobuf2_vmalloc videobuf2_memops iwlwifi joydev snd_hda_codec_conexant mac80211 snd_hda_intel snd_hda_codec snd_hwdep snd_seq i2c_i801 snd_seq_device snd_pcm microcode cfg80211 iTCO_wdt iTCO_vendor_support thinkpad_acpi snd_timer snd_page_alloc rfkill snd soundcore tpm_tis tpm tpm_bios binfmt_misc e1000e vhost_net macvtap macvlan tun kvm_intel kvm uinput sunrpc wmi i915 drm_kms_helper drm i2c_algo_bit i2c_
:core video
:Pid: 6226, comm: plugin-containe Not tainted 3.3.7-1.fc16.x86_64 #1
:Call Trace:
: <IRQ>  [<ffffffff81057adf>] warn_slowpath_common+0x7f/0xc0
: [<ffffffff81057bd6>] warn_slowpath_fmt+0x46/0x50
: [<ffffffffa03e375a>] iwlagn_tx_skb+0xd3a/0xdb0 [iwlwifi]
: [<ffffffff8116c196>] ? kmem_cache_free+0x116/0x130
: [<ffffffffa03e092a>] iwlagn_mac_tx+0xaa/0xe0 [iwlwifi]
: [<ffffffffa02e3f75>] __ieee80211_tx+0x175/0x2a0 [mac80211]
: [<ffffffffa040237b>] ? iwl_rx_queue_update_write_ptr+0xfb/0x170 [iwlwifi]
: [<ffffffffa02e68aa>] ieee80211_tx_pending+0xca/0x270 [mac80211]
: [<ffffffff8105ea68>] tasklet_action+0x78/0x140
: [<ffffffff8105f0c8>] __do_softirq+0xb8/0x230
: [<ffffffff810e3e50>] ? handle_irq_event+0x50/0x70
: [<ffffffff815fd9dc>] call_softirq+0x1c/0x30
: [<ffffffff81016455>] do_softirq+0x65/0xa0
: [<ffffffff8105f4de>] irq_exit+0x9e/0xc0
: [<ffffffff815fe243>] do_IRQ+0x63/0xe0
: [<ffffffff815f47ee>] common_interrupt+0x6e/0x6e
: <EOI>  [<ffffffff815f31d2>] ? _cond_resched+0x22/0x40
: [<ffffffff81070315>] sys_getrlimit+0x45/0x70
: [<ffffffff815fc529>] system_call_fastpath+0x16/0x1b
Comment 1 John W. Linville 2012-06-18 14:57:42 EDT
drivers/net/wireless/iwlwifi/iwl-agn-tx.c:397

                /* We can receive packets from the stack in IWL_AGG_{ON,OFF}
                 * only. Check this here.
                 */
                if (WARN_ONCE(tid_data->agg.state != IWL_AGG_ON &&
                    tid_data->agg.state != IWL_AGG_OFF,
                    "Tx while agg.state = %d", tid_data->agg.state))
                        goto drop_unlock_sta;
Comment 2 John W. Linville 2012-07-10 10:02:42 EDT
*** Bug 820165 has been marked as a duplicate of this bug. ***
Comment 3 John W. Linville 2012-07-10 10:05:33 EDT
Does this persist with any of the 3.4-based Fedora kernels?
Comment 4 Matthias Kuhn 2012-07-27 05:38:50 EDT
I haven't seen it again since I updated to FC17
Comment 5 John W. Linville 2012-07-27 10:48:21 EDT
Closing on the basis of comment 4...

Note You need to log in before you can comment on or make changes to this bug.