Bug 832784 - ovirt-engine-setup: "service ovirt-engine status" does not return a clear message [TEXT]
ovirt-engine-setup: "service ovirt-engine status" does not return a clear mes...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-setup (Show other bugs)
3.1.0
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: Juan Hernández
Yaniv Kaul
integration
:
: 838825 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-17 07:23 EDT by Yaniv Kaul
Modified: 2015-09-22 09 EDT (History)
8 users (show)

See Also:
Fixed In Version: si10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 15:03:45 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yaniv Kaul 2012-06-17 07:23:57 EDT
Description of problem:
[root@ykaul-rhevm3 /]# service ovirt-engine status
The engine PID file "/var/run/ovirt-engine.pid" doesn't exist.

compare with (for example):
[root@ykaul-rhevm3 /]# /etc/init.d/iscsi status
iscsi is stopped

Version-Release number of selected component (if applicable):
rhevm-setup-3.1.0_0001-14.el6ev.noarch

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:
should be "ovirt-engine is stopped"

Additional info:
Comment 1 Juan Hernández 2012-06-21 11:54:33 EDT
The following change contains the fix for this bug:

http://gerrit.ovirt.org/#/c/5355

The output of the script will look like this:

# service ovirt-engine stop
Stopping engine-service:                                    [  OK  ]
# service ovirt-engine status
ovirt-engine is stopped
# service ovirt-engine start
Starting engine-service:                                    [  OK  ]
# service ovirt-engine status
ovirt-engine is running

Additional information will be sent to syslog (/var/log/messages).
Comment 3 Yaniv Kaul 2012-07-10 10:02:48 EDT
*** Bug 838825 has been marked as a duplicate of this bug. ***
Comment 4 Haim 2012-08-07 02:18:38 EDT
verified on si13:

[root@hateya-rhevm ~]# /etc/init.d/ovirt-engine status
The engine process 11265 is running.
[root@hateya-rhevm ~]# /etc/init.d/ovirt-engine stop 
Stopping engine-service:
                                                            [  OK  ]
[root@hateya-rhevm ~]# /etc/init.d/ovirt-engine status
The engine is not running

Note You need to log in before you can comment on or make changes to this bug.