Bug 832800 - User not created during first boot
User not created during first boot
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: firstboot (Show other bugs)
17
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: Martin Gracik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-17 10:02 EDT by Giovanni Tirloni
Modified: 2013-07-04 09:03 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-23 09:33:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Giovanni Tirloni 2012-06-17 10:02:38 EDT
Description of problem:

When boot a fresh F17 install (done from the F17 Live CD - KDE Spin), Anaconda request that a user be created. I entered the username, left name blank, entered password twice and selected "Add to administrative group" (or something like that).

On the login screen, it doesn't accept the username/password. Verifying /etc/passwd I see that no user was created.


Version-Release number of selected component (if applicable):

Fedora 17 (KDE Spin)


How reproducible:


Steps to Reproduce:
1. Install F17 from a Live KDE Spin CD
2. During the installation, create a user
3. Try to login
  
Actual results:

User is not created.
Login is not accepted.


Expected results:

User is created.
Login accepted.

Additional info:
Comment 1 Giovanni Tirloni 2012-06-17 15:48:51 EDT
I tried the installation again and in fact I had left empty the "username" field.

1) Filled the "Name" field
2) Left "Username" empty (thinking it was "Name")
3) Entered password twice
4) Continued

When I left "Username" empty, Anaconda did not warn me about it and moved on. Anaconda should issue a warning that I need to fill the username field

--

I found another behavior that I think is an issue and wanted the maintainer opinion if I should another bug report.

In the user creation screen, I filled all fields correctly and marked the user as administrative. I clicked Forward and immediately clicked Back because I wanted to change something in the user.

All fields were blank and I entered the same name/username and a different password. When I clicked forward, Anaconda complained that "user xxxx is in the administrative group" and didn't allow me to proceed. 

It seems as if Anaconda had already created the user when I first passed through the user creation screen and now was counting that as done. Perhaps it should leave the actual user creation for the end of the process so the user installing the machine can go back and forth changing the options?
Comment 2 Martin Gracik 2012-07-23 09:33:48 EDT
The user creation is done after you click Next. This is by design. That's why when you go back all the fields are empty, so if you click next again, no user will be created.

And about the first problem. Some users don't want to create a user, because they already have users created in kickstart, or just root is enough. That's why we allow to skip the user creation, by leaving the username text entry empty.

Firstboot issues a warning only if there's no user able to login into gdm available on the system and you don't supply the username for new user.

Note You need to log in before you can comment on or make changes to this bug.