Bug 83285 - radeon 8500/64MB 3D stuttering; mode switching problems in wolfenstein.
radeon 8500/64MB 3D stuttering; mode switching problems in wolfenstein.
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: XFree86 (Show other bugs)
phoebe
athlon Linux
medium Severity low
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks: 79579
  Show dependency treegraph
 
Reported: 2003-02-01 09:39 EST by Pawel Salek
Modified: 2007-04-18 12:50 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-31 21:09:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pawel Salek 2003-02-01 09:39:38 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030120

Description of problem:
When playing wolfenstein (RTCW, exactly) on ATi powered 8500LE card with
XFree86-4.2.99.4-20030129.1, game hangs for a second when entering new rooms.
Also, starting a new level takes unusually long time. These problems did not
exist when I used dri.sf.net snapshots in August-September 2002. My first guess
there is something wrong either with card memory management or with the texture
upload. The delays remain even after changing the quality settings.

FWIW, mode switching (geometry and texture detail) work only if the Xserver is
started with the same resolution as used later by the game (i.e. if the game
uses 800x600, XF86Config should contain only Mode "800x600"). This may RTCW bug,
though.

Version-Release number of selected component (if applicable):
XFree86-4.2.99.4-20030129.1

How reproducible:
Always

Steps to Reproduce:
1. Run RTCW with normal quality settings. Try opening a door (the tram station,
third level, is particularly good test case). The computer can hang for a
second, and the sound will stutter like on damaged CD.


Actual Results:  The computer can hang for a second, and the sound will stutter
like on damaged CD. Frame rate drops down from 100fps to 1. It can be very
difficult to aim and shoot in such a situation.


Expected Results:  Smooth door opening. Constant frame rate.

Additional info:

This is a regression wrt September 2002. I thought it might have been connected
with introduction of RandR, but since I unsuccesfully tried playing with the
resolution, I am not sure any longer. 

This report is probably worth to forward upstream (I would do it myself but I am
not sure which version of the ati/r200 driver is actually used).

dmesg reports:
agpgart: Maximum main memory to use for agp memory: 203M
agpgart: Detected Via Apollo Pro KT266 chipset
agpgart: AGP aperture is 64M @ 0xe0000000
[drm] AGP 0.99 on VIA Apollo KT133 @ 0xe0000000 64MB
[drm] Initialized radeon 1.7.0 20020828 on minor 0
[drm] Loading R200 Microcode

graphics card shares IRQ with a network card but I do not think this is a problem.

I mark severity as low: while RTCW is hardly playable now (no way to rush
through the door and shoot), the 3D performance is satisfactory for other
purposes (other people may think differently, though).
Comment 1 Pawel Salek 2003-02-01 10:18:45 EST
Decreasing color depth from 24 to 16 helps considerably to shorten delays. It
makes the image more coarse, too. I played with that quality on my old radeon
7500 32MB. It looks like half of the memory on the card gets wasted.
Comment 2 Mike A. Harris 2003-02-01 13:33:42 EST
Please report this problem to the DRI development team directly by emailing
your report to dri-devel@lists.sourceforge.net as the DRI team has a lot
more knowledge in this area so this will accelerate the path to a solution.
Once the problem is fixed upstream, if it is committed to XFree86 CVS prior
to the 4.3.0 release it will be picked up by me automatically.  If it isn't
in 4.3.0, then it could be backported possibly.

Changing bug status to UPSTREAM pending DRI development team fix.
Comment 3 Mike A. Harris 2003-07-17 06:17:37 EDT
Reopening bug...

I haven't noticed anything about this problem upstream, and am not aware
of any fixes that may have occured.  XFree86.org now has a bugzilla, which
is also used by the DRI project.  If this problem is still present and relevant,
please report it upstream in XFree86 bugzilla at http://bugs.xfree86.org and
provide the upstream bug report URL, and I will track the issue there, and
investigate any fixes that come along for inclusion in future erratum and OS
releases.
Comment 4 Pawel Salek 2003-07-17 06:33:10 EDT
1. The mode-switching related hang has been resolved since the problem was first
reported (4.3.0 as in Shrike works in this respect just fine).

2. I asked on dri-level and the stuttering is most likely a result of somewhat
more wasteful storing of display lists - the program simply did not fit in
memory any more (the RtCW requirements officially state 128MB memory for PC but
the process size grows under linux to 300MB which is more than my 256MB box can
provide). See in particular
http://sourceforge.net/mailarchive/message.php?msg_id=4048476 - Ian Romanick
says it is a "known problem".
(the summary of this report probably could be changed to "display list excessive
memory usage").
Comment 5 Pawel Salek 2003-07-17 07:00:38 EDT
Cross-reported as http://bugs.xfree86.org/show_bug.cgi?id=509
Comment 6 Mike A. Harris 2004-08-31 21:09:08 EDT
We've switched to X.Org X11 for Fedora Core 2, and have a newer
release in Fedora devel currently, which puts us 2 Mesa releases
(or more possibly) ahead now.  Current release is Mesa 6.1, so a lot
has changed.

The upstream report indicates this is fixed in a newer Mesa, so I'll
assume it's fixed in 6.1 and close this as "RAWHIDE" for now.

If the problem recurs, or any other problems are experienced with
Wolfenstein, please report a bug to the X.Org bugzilla on
freedesktop.org, in the "xorg" component.  The DRI project is now
officially moved into X.Org CVS repository, so the Xorg bugzilla
is the canonical place to report all DRI/Mesa related bugs.  We
can track issues in the upstream bugzilla(s) if people file
a placeholder bug in our bugzilla after filing their official bug
report upstream.

Setting status to "RAWHIDE".

Note You need to log in before you can comment on or make changes to this bug.